Difference between revisions of "Construction Protocol"

From GeoGebra Manual
Jump to: navigation, search
m
 
(6 intermediate revisions by 3 users not shown)
Line 1: Line 1:
<noinclude>{{Manual Page|version=4.0}}[[Category:Manual (official)|{{PAGENAME}}]]</noinclude>
+
<noinclude>{{Manual Page|version=5.0}}</noinclude>
 
{{gui|dialog}}
 
{{gui|dialog}}
You can access the interactive Construction Protocol by selecting item Construction Protocol - Show from the View menu. The Construction Protocol is a table that shows all construction steps,  allowing you to redo a construction step by step using the [[Navigation Bar]] at the bottom of the Construction Protocol dialog.
+
=='''GeoGebra Web and Tablet Apps'''==
 +
 
 +
You can access the interactive [[File:Menu view construction protocol.svg|link=|16px]] '''Construction Protocol''' by selecting the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' option in the [[File:Menu-view.svg|link=|16px]] [[View Menu]]. The [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' is a table that shows all construction steps.
 +
Using the [[Navigation Bar]] you can also animate the construction steps. To show the ''Navigation Bar'' at the bottom of the GeoGebra window, select the ''Navigation Bar'' option in the [[File:Menu-view.svg|link=|16px]] ''View Menu''.
 +
 
 +
=='''GeoGebra Desktop'''==
 +
 
 +
You can access the interactive [[File:Menu view construction protocol.svg|link=|16px]] '''Construction Protocol''' by selecting the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' option in the ''View Menu''. The [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' is a table that shows all construction steps,  allowing you to redo a construction step by step.
 +
Using the [[Navigation Bar]] you can also animate the construction steps. To show the ''Navigation Bar'' at the bottom of the GeoGebra window, right click in the [[File:Menu view graphics.svg|link=|16px]] [[Graphics View]], then select the ''Navigation bar'' option in the [[Context Menu]] displayed.
  
 
==Navigating and Modifying the Construction Protocol==
 
==Navigating and Modifying the Construction Protocol==
  
You may use the keyboard to navigate in the Construction Protocol:
+
You may use the keyboard to navigate in the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'':
  
* Use the ↑ up arrow of your keyboard to go to the previous construction step.
+
* Press the {{KeyCode|}} up arrow on your keyboard to go to the previous construction step.
* Use the ↓ down arrow of you keyboard to go to the next construction step.
+
* Press the {{KeyCode|}} down arrow on your keyboard to go to the next construction step.
* Use the Home key to go to the beginning of the Construction Protocol.
+
* Press the {{KeyCode|Home}} key to return to the beginning of the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol''.
* Use the End key to go to the end of the Construction Protocol.
+
* Press the {{KeyCode|End}} key to move to the end of the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol''.
* Use the Delete key in order to delete the selected construction step.
+
* Press the {{KeyCode|Delete}} key to delete the selected construction step.
  
:{{Note| This may also affect other objects that depend on the selected object/construction step.}}
+
:{{Note| Deleting also affects other objects that depend on the selected object/construction step.}}
  
You may also use the mouse in order to navigate in the Construction Protocol:
+
You may also use the mouse in order to navigate in the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'':
  
 
* Double click a row to select a construction step.
 
* Double click a row to select a construction step.
* Double click the header of any column to go to the beginning of the Construction Protocol.
+
* Double click the header of any column to go to the beginning of the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol''.
* Drag and drop a row to move a construction step to another position in the Construction Protocol.
+
* Drag and drop a row to move a construction step to another position in the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol''.
{{Note| This is not always possible due to the dependencies between different objects.}}
+
:{{Note| This is not always possible due to the dependencies between different objects.}}
* Right click a row to open the Context Menu for the object of this construction step.
+
* Right click on a row to open the context menu related to the currently selected object.
 +
 
  
{{Note| You can insert construction steps at any position. Select the construction step below you would like to insert a new construction step. Leave the Construction Protocol window open while you create a new object. This new construction step is immediately inserted into the selected position of the Construction Protocol.}}
+
{{Note| You can insert construction steps at any position. Select the construction step below the one you would like to insert a new construction step. Leave the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' window open while you create a new object. This new construction step is immediately inserted into the selected position of the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol''.}}
  
Using the column Breakpoint in the View menu of the Construction Protocol window, you can define certain construction steps as Breakpoints. This allows you to group several objects together. When navigating through your construction using the [[Navigation Bar]], groups of objects are shown at the same time.
+
Select the options listed when you select the first left icon of the Construction Protocol toolbar, to decide which informations related to the construction will be shown.
 +
The ''Breakpoint'' option allows you to define certain construction steps as breakpoints, i.e. group several objects together. When navigating through your construction using the [[Navigation Bar]], selected groups of objects are shown at the same time.
  
{{Note| You may switch the different columns of the Construction Protocol on and off by using the ''Styling Bar'' of the Construction Protocol window.}}
 
  
 
==Exporting the Construction Protocol as a Webpage==
 
==Exporting the Construction Protocol as a Webpage==
  
GeoGebra allows you to export the Construction Protocol as a webpage. First, you need to open the Construction Protocol using the View menu. Then open the File menu of the appearing Construction Protocol window and select item Export as Webpage.   
+
GeoGebra Desktop allows you to export the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' as a Webpage. Open the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' using the related option in the ''View Menu'', then select the third icon of the ''Construction Protocol'''s toolbar (''Export as Webpage'').   
  
In the export window of the Construction Protocol you can enter Title, Author, and a Date for the construction and choose whether or not you want to include a picture of the [[Graphics View]] and the [[Algebra View]]. In addition, you can also choose to export a Colorful Construction Protocol. This means that objects in the Construction Protocol will match the color of the corresponding objects in the construction.
+
In the export window of the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' you can enter ''Title'', ''Author'', and a ''Date'' for the construction and choose whether or not you want to include a picture of the [[File:Menu view graphics.svg|link=|16px]] ''Graphics View'' and the [[File:Menu view algebra.svg|link=|16px]] [[Algebra View]]. In addition, you can also choose to export a ''Colorful Construction Protocol''. This means that objects in the [[File:Menu view construction protocol.svg|link=|16px]] ''Construction Protocol'' will match the color of the corresponding objects in the construction.
  
:{{Note| The exported HTML file can be viewed with any Internet browser (e. g. Firefox, Internet Explorer) and edited with many text processing systems (e. g. OpenOffice Writer).}}
+
:{{Note| The exported HTML file can be viewed with any Internet browser (e.g. Firefox, Internet Explorer, Safari) and edited with many text processing systems (e.g. OpenOffice Writer).}}

Latest revision as of 17:09, 6 November 2015


GeoGebra Web and Tablet Apps

You can access the interactive Menu view construction protocol.svg Construction Protocol by selecting the Menu view construction protocol.svg Construction Protocol option in the Menu-view.svg View Menu. The Menu view construction protocol.svg Construction Protocol is a table that shows all construction steps. Using the Navigation Bar you can also animate the construction steps. To show the Navigation Bar at the bottom of the GeoGebra window, select the Navigation Bar option in the Menu-view.svg View Menu.

GeoGebra Desktop

You can access the interactive Menu view construction protocol.svg Construction Protocol by selecting the Menu view construction protocol.svg Construction Protocol option in the View Menu. The Menu view construction protocol.svg Construction Protocol is a table that shows all construction steps, allowing you to redo a construction step by step. Using the Navigation Bar you can also animate the construction steps. To show the Navigation Bar at the bottom of the GeoGebra window, right click in the Menu view graphics.svg Graphics View, then select the Navigation bar option in the Context Menu displayed.

Navigating and Modifying the Construction Protocol

You may use the keyboard to navigate in the Menu view construction protocol.svg Construction Protocol:

  • Press the up arrow on your keyboard to go to the previous construction step.
  • Press the down arrow on your keyboard to go to the next construction step.
  • Press the Home key to return to the beginning of the Menu view construction protocol.svg Construction Protocol.
  • Press the End key to move to the end of the Menu view construction protocol.svg Construction Protocol.
  • Press the Delete key to delete the selected construction step.
Note: Deleting also affects other objects that depend on the selected object/construction step.

You may also use the mouse in order to navigate in the Menu view construction protocol.svg Construction Protocol:

  • Double click a row to select a construction step.
  • Double click the header of any column to go to the beginning of the Menu view construction protocol.svg Construction Protocol.
  • Drag and drop a row to move a construction step to another position in the Menu view construction protocol.svg Construction Protocol.
Note: This is not always possible due to the dependencies between different objects.
  • Right click on a row to open the context menu related to the currently selected object.


Note: You can insert construction steps at any position. Select the construction step below the one you would like to insert a new construction step. Leave the Menu view construction protocol.svg Construction Protocol window open while you create a new object. This new construction step is immediately inserted into the selected position of the Menu view construction protocol.svg Construction Protocol.

Select the options listed when you select the first left icon of the Construction Protocol toolbar, to decide which informations related to the construction will be shown. The Breakpoint option allows you to define certain construction steps as breakpoints, i.e. group several objects together. When navigating through your construction using the Navigation Bar, selected groups of objects are shown at the same time.


Exporting the Construction Protocol as a Webpage

GeoGebra Desktop allows you to export the Menu view construction protocol.svg Construction Protocol as a Webpage. Open the Menu view construction protocol.svg Construction Protocol using the related option in the View Menu, then select the third icon of the Construction Protocol's toolbar (Export as Webpage).

In the export window of the Menu view construction protocol.svg Construction Protocol you can enter Title, Author, and a Date for the construction and choose whether or not you want to include a picture of the Menu view graphics.svg Graphics View and the Menu view algebra.svg Algebra View. In addition, you can also choose to export a Colorful Construction Protocol. This means that objects in the Menu view construction protocol.svg Construction Protocol will match the color of the corresponding objects in the construction.

Note: The exported HTML file can be viewed with any Internet browser (e.g. Firefox, Internet Explorer, Safari) and edited with many text processing systems (e.g. OpenOffice Writer).
© 2021 International GeoGebra Institute