Tool Creation Dialog

From GeoGebra Manual
Jump to: navigation, search

First, create the construction your tool should be able to create later on. In the Menu-tools.svg Tools menu, select Menu-tools-new.svg Create New Tool in order to open the corresponding dialog box. Now you need to fill in the three tabs Output Objects, Input Objects, and Name and Icon in order to create your custom tool.

Example: Create a Square-tool that creates a square whenever you click on two existing points or on two empty spots in the Menu view graphics.svg Graphics View.
  • Construct a square starting with two points A and B. Construct the other vertices and connect them with the tool Mode polygon.svg Polygon to get the square poly1.
  • Select Menu-tools-new.svg Create New Tool in the Menu-tools.svg Tools Menu.
  • Specify the Output Objects: Click on the square or select it from the drop down menu. Also, specify the edges of the square as Output Objects.
  • Specify the Input Objects: GeoGebra automatically specifies the Input Objects for you (here: points A and B). You can also modify the selection of input objects using the drop down menu or by clicking on them in your construction.
  • Specify the Tool Name and Command Name for your new tool.
Note: The Tool Name will appear in GeoGebra's Toolbar, while the Command Name can be used in GeoGebra's Input Bar.
  • You may also enter text to be shown in the Toolbar Help.
  • You can also choose an image from you computer for the Toolbar icon. GeoGebra resizes your image automatically to fit on a Toolbar button.
Note: Outputs of the tool are not moveable, even if they are defined as Point[<Path>]. In case you need moveable output, you can define a list of commands and use it with Execute Command.
  • GeoGebra
  • Help
  • Partners
  • Contact us
    • Feedback & Questions
    • This email address is being protected from spambots. You need JavaScript enabled to view it.
    • +43 677 6137 2693
© 2017 International GeoGebra Institute