Différences entre versions de « Utilisateur »

De GeoGebra Manual
Aller à : navigation, rechercher
 
(6 versions intermédiaires par le même utilisateur non affichées)
Ligne 1 : Ligne 1 :
<noinclude>{{Manual Page|version=4.0}}</noinclude>{{tool|type=custom|name=Utilisateur}}
+
<noinclude>{{Manual Page|version=5.0}}</noinclude>{{tool|type=custom| Utilisateur}}
  
 
GeoGebra vous permet de créer vos propres outils de construction basés sur une construction existante.
 
GeoGebra vous permet de créer vos propres outils de construction basés sur une construction existante.
 
Une fois créés, vos outils peuvent être utilisés aussi bien à la souris qu’en commande dans le champ de [[saisie]].
 
Une fois créés, vos outils peuvent être utilisés aussi bien à la souris qu’en commande dans le champ de [[saisie]].
  
 +
{{Note|1=Les objets créés ne sont pas déplaçables, même s'ils ont été définis par une commande du type <code>[[Commande Point|Point]][<Chemin>]</code>. Dans le cas où vous désireriez un objet créé déplaçable, vous pouvez définir une liste de commandes et la faire fonctionner grâce à la [[Commande Exécute]].}}
  
D’abord, réalisez la construction que votre outil devra répéter plus tard.
+
 
 +
D’abord, réaliser la construction que l'outil devra répéter plus tard.
  
  
 
==Créer un outil==
 
==Créer un outil==
  
Pour créer un outil personnel, utilisez l'option [[Dialogue_Création_Outil|Créer un nouvel outil]] du [[Menu Outils]].
+
Pour créer un outil personnel, utiliser l'option [[Dialogue_Création_Outil|Créer un nouvel outil]] du [[Menu Outils]].
Maintenant il vous faut renseigner les trois onglets ‘Objets Finaux’, ‘Objets Initiaux’, et ‘Nom et Icône’ afin de créer votre propre outil.
+
Maintenant renseigner les trois onglets ‘Objets Finaux’, ‘Objets Initiaux’, et ‘Nom et Icône’ afin de créer l'outil.
  
 +
{{Note|Pour l'icône, utiliser une image *.png dans le cas d'une utilisation en ligne.}}
  
 
==Sauvegarder un outil utilisateur==
 
==Sauvegarder un outil utilisateur==
  
Tous vos outils sont automatiquement enregistrés dans votre fichier GeoGebra.
+
Tous les outils sont automatiquement enregistrés dans le fichier GeoGebra.
Vous pouvez sauvegarder votre outil utilisateur afin de pouvoir le réutiliser dans d’autres constructions GeoGebra.
+
Ils peuvent être sauvegardés afin de pouvoir les réutiliser dans d’autres constructions GeoGebra.
Dans le menu Outils, choisissez ‘Gérer les outils’. Ensuite, choisissez l’outil personnel que vous voulez sauvegarder dans la liste qui est apparue. Cliquez sur le bouton ‘Sauvegarder sous…’ pour enregistrer votre outil dans votre ordinateur.
+
Dans le menu Outils, choisir ‘Gérer les outils’. Ensuite, choisir les outils à sauvegarder dans la liste qui est apparue. Cliquer sur le bouton ‘Sauvegarder sous…’ pour les enregistrer dans votre ordinateur.
 
{{Note | Les outils utilisateurs sont enregistrés dans des fichiers ayant pour extension ‘ggt’ afin d’être différenciés des habituels fichiers GeoGebra(‘ggb’). }}
 
{{Note | Les outils utilisateurs sont enregistrés dans des fichiers ayant pour extension ‘ggt’ afin d’être différenciés des habituels fichiers GeoGebra(‘ggb’). }}
  
Ligne 25 : Ligne 28 :
 
Si vous ouvrez un nouveau fichier GeoGebra en utilisant l’item ‘Nouveau’ du menu Fichier, après avoir créé un outil personnel, celui-ci est toujours présent dans la barre d’outils GeoGebra. Mais si vous ouvrez une nouvelle fenêtre GeoGebra (item [[Image:Menu New.png]] ‘Nouvelle fenêtre’ du [[menu Fichier]]), ou ouvrez GeoGebra un autre jour, votre outil personnel n’est plus présent dans la barre d’outils GeoGebra.
 
Si vous ouvrez un nouveau fichier GeoGebra en utilisant l’item ‘Nouveau’ du menu Fichier, après avoir créé un outil personnel, celui-ci est toujours présent dans la barre d’outils GeoGebra. Mais si vous ouvrez une nouvelle fenêtre GeoGebra (item [[Image:Menu New.png]] ‘Nouvelle fenêtre’ du [[menu Fichier]]), ou ouvrez GeoGebra un autre jour, votre outil personnel n’est plus présent dans la barre d’outils GeoGebra.
  
Il y a différentes manières de vous assurez que vos outils personnels soient affichés  la barre d’outils d’une nouvelle fenêtre GeoGebra.
+
Il y a différentes manières de vous assurer de la présence de vos outils personnels dans la barre d’outils (et liste des commandes) d’une nouvelle fenêtre GeoGebra.
  
 
Par exemple, après avoir créé un nouvel outil personnel vous pouvez sauvegarder la configuration en sélectionnant l’item  [[Image:Menu Save.png]] ‘Enregistrer  la configuration’ du [[menu Options]]. Dès cet instant, votre outil personnel sera toujours présent dans la barre d’outils GeoGebra.   
 
Par exemple, après avoir créé un nouvel outil personnel vous pouvez sauvegarder la configuration en sélectionnant l’item  [[Image:Menu Save.png]] ‘Enregistrer  la configuration’ du [[menu Options]]. Dès cet instant, votre outil personnel sera toujours présent dans la barre d’outils GeoGebra.   
{{Note | Vous pouvez retirer votre outil personnel de la barre d‘outils en sélectionnant l’item ‘Barre d’outils personnalisée…’ dans le [[menu Outils]]. Sélectionnez ensuite votre outil personnel dans la liste d’outils à gauche dans la fenêtre de dialogue apparue et cliquez sur le bouton ‘Retirer >’. N’oubliez pas de sauvegarder votre configuration après avoir retiré l’outil personnel.}}     
+
{{Note | Vous pouvez retirer votre outil personnel de la barre d‘outils en sélectionnant l’item ‘Barre d’outils personnalisée…’ dans le [[menu Outils]]. Sélectionner ensuite votre outil personnel dans la liste d’outils à gauche dans la fenêtre de dialogue apparue et cliquer sur le bouton ‘Retirer >’. Ne pas oublier de sauvegarder votre configuration après avoir retiré l’outil personnel.}}     
  
  
==Importer à un outil utilisateur==
+
==Importer un outil utilisateur==
  
Après avoir sauvegardé votre outil personnel sur votre ordinateur (dans un fichier ‘ggt’), vous pouvez à chaque instant l’importer dans une nouvelle fenêtre GeoGebra. Sélectionnez simplement l’item  [[Image:Menu Open.png]] ‘Ouvrir’ dans le [[menu Fichier]] et ouvrez le fichier contenant votre outil.       
+
Après avoir sauvegardé votre outil personnel sur votre ordinateur (dans un fichier ‘ggt’), vous pouvez à chaque instant l’importer dans une nouvelle fenêtre GeoGebra. Sélectionner simplement l’item  [[Image:Menu Open.png]] ‘Ouvrir’ dans le [[menu Fichier]] et ouvrir le fichier contenant votre outil.       
 
{{Note |* L’ouverture d’un fichier d’outils GeoGebra n’affecte en rien la construction courante. Simplement, cela rajoute votre outil personnel dans la barre d’outils GeoGebra.
 
{{Note |* L’ouverture d’un fichier d’outils GeoGebra n’affecte en rien la construction courante. Simplement, cela rajoute votre outil personnel dans la barre d’outils GeoGebra.
 
* Vous pouvez aussi charger un outil par glisser-déposer.}}
 
* Vous pouvez aussi charger un outil par glisser-déposer.}}
 
__NOTOC__
 
__NOTOC__

Version actuelle datée du 3 février 2017 à 18:05

GeoGebra vous permet de créer vos propres outils de construction basés sur une construction existante. Une fois créés, vos outils peuvent être utilisés aussi bien à la souris qu’en commande dans le champ de saisie.

Note : Les objets créés ne sont pas déplaçables, même s'ils ont été définis par une commande du type Point[<Chemin>]. Dans le cas où vous désireriez un objet créé déplaçable, vous pouvez définir une liste de commandes et la faire fonctionner grâce à la Commande Exécute.


D’abord, réaliser la construction que l'outil devra répéter plus tard.


Créer un outil

Pour créer un outil personnel, utiliser l'option Créer un nouvel outil du Menu Outils. Maintenant renseigner les trois onglets ‘Objets Finaux’, ‘Objets Initiaux’, et ‘Nom et Icône’ afin de créer l'outil.

Note : Pour l'icône, utiliser une image *.png dans le cas d'une utilisation en ligne.

Sauvegarder un outil utilisateur

Tous les outils sont automatiquement enregistrés dans le fichier GeoGebra. Ils peuvent être sauvegardés afin de pouvoir les réutiliser dans d’autres constructions GeoGebra. Dans le menu Outils, choisir ‘Gérer les outils’. Ensuite, choisir les outils à sauvegarder dans la liste qui est apparue. Cliquer sur le bouton ‘Sauvegarder sous…’ pour les enregistrer dans votre ordinateur.

Note : Les outils utilisateurs sont enregistrés dans des fichiers ayant pour extension ‘ggt’ afin d’être différenciés des habituels fichiers GeoGebra(‘ggb’).

Accéder à un outil utilisateur

Si vous ouvrez un nouveau fichier GeoGebra en utilisant l’item ‘Nouveau’ du menu Fichier, après avoir créé un outil personnel, celui-ci est toujours présent dans la barre d’outils GeoGebra. Mais si vous ouvrez une nouvelle fenêtre GeoGebra (item Menu New.png ‘Nouvelle fenêtre’ du menu Fichier), ou ouvrez GeoGebra un autre jour, votre outil personnel n’est plus présent dans la barre d’outils GeoGebra.

Il y a différentes manières de vous assurer de la présence de vos outils personnels dans la barre d’outils (et liste des commandes) d’une nouvelle fenêtre GeoGebra.

Par exemple, après avoir créé un nouvel outil personnel vous pouvez sauvegarder la configuration en sélectionnant l’item Menu Save.png ‘Enregistrer la configuration’ du menu Options. Dès cet instant, votre outil personnel sera toujours présent dans la barre d’outils GeoGebra.

Note : Vous pouvez retirer votre outil personnel de la barre d‘outils en sélectionnant l’item ‘Barre d’outils personnalisée…’ dans le menu Outils. Sélectionner ensuite votre outil personnel dans la liste d’outils à gauche dans la fenêtre de dialogue apparue et cliquer sur le bouton ‘Retirer >’. Ne pas oublier de sauvegarder votre configuration après avoir retiré l’outil personnel.


Importer un outil utilisateur

Après avoir sauvegardé votre outil personnel sur votre ordinateur (dans un fichier ‘ggt’), vous pouvez à chaque instant l’importer dans une nouvelle fenêtre GeoGebra. Sélectionner simplement l’item Menu Open.png ‘Ouvrir’ dans le menu Fichier et ouvrir le fichier contenant votre outil.

Note :
  • L’ouverture d’un fichier d’outils GeoGebra n’affecte en rien la construction courante. Simplement, cela rajoute votre outil personnel dans la barre d’outils GeoGebra.
  • Vous pouvez aussi charger un outil par glisser-déposer.
© 2022 International GeoGebra Institute