Diferencia entre revisiones de «Nueva herramienta»

De GeoGebra Manual
Saltar a: navegación, buscar
Línea 1: Línea 1:
<noinclude>{{Manual Page|version=4.2}}</noinclude>{{Interfaz_Gráfica|Nueva herramienta}}En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori. En el  [[Menú de Herramientas|menú]] de [[Herramientas]] basta un ''clic'' sobre [[Image:Menu Create Tool.png]] [[Propias#Creando una... Nueva Herramienta|''Nueva herramienta'']] para abrir el correspondiente cuadro de diálogo.
+
{{DISPLAYTITLE:Nueva Herramienta}}<noinclude>{{Manual Page|version=4.2}}</noinclude>{{Interfaz_Gráfica|Cuadro}}En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori.<br>En el  [[Menú de Herramientas|menú]] de [[Herramientas]] basta un ''clic'' sobre [[Image:Menu Create Tool.png]] [[Propias#Creando una... Nueva Herramienta|''Nueva herramienta'']] para abrir el correspondiente cuadro de diálogo.
 
;
 
;
 
Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:<br>
 
Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:<br>
Línea 16: Línea 16:
 
*Además, se puede anotar el texto que orienta y se expone en la [[Barra de Herramientas#Ayuda de la Barra de Herramientas|Ayuda de la Barra de Herramientas]].
 
*Además, se puede anotar el texto que orienta y se expone en la [[Barra de Herramientas#Ayuda de la Barra de Herramientas|Ayuda de la Barra de Herramientas]].
 
*También puede elegirse una imagen para que represente el ícono de la herramienta.<br>GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.<hr>
 
*También puede elegirse una imagen para que represente el ícono de la herramienta.<br>GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.<hr>
*Las salidas de las herramientas no son desplazables aún que se hubieran definido como  '''<code>[[Comando Punto|Punto]][ <Recorrido> ].</code>'''<br>En caso de precisarse salidas desplazables, se puede recurrir a definir una lista de comandos para emplearlos con el comando [[Comando Ejecuta|Ejecuta]].}}
+
*Las salidas de las herramientas no son trasladables aún que se hubieran definido como  '''<code>[[Comando Punto|Punto]][ <Recorrido> ].</code>'''<br>En caso de precisarse salidas trasladables, se puede recurrir a definir una lista de comandos para emplearlos con el comando [[Comando Ejecuta|Ejecuta]].}}

Revisión del 14:54 18 ene 2014

En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori.
En el menú de Herramientas basta un clic sobre Menu Create Tool.png Nueva herramienta para abrir el correspondiente cuadro de diálogo.

Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:

  • Objetos de salida,

  • Objetos de entrada y

  • Nombre e Icono

Ejemplos: Receta para crear una herramienta Cuadrada que trazará un cuadrado con dos clic sucesivos en dos posiciones vacías de la Vista Gráfica (que establecerán los puntos vértices de una de sus diagonales).
  • Construir un cuadrado empezando por dos puntos A y B que den lugar a los otros dos vértices para que al conectarlos, con la herramienta Tool Polygon.gif Polígono, procuren el cuadrado deseado.
    (Basta con indicar el Punto medio o Centro entre los dos marcados y llevar adelante las maniobras necesarias para que el ambos giren un ángulo recto alrededor de tal centro).
  • Seleccionar Menu Create Tool.png Nueva Herramienta en el menú correspondiente.
  • Especificar en Objetos de salida al cuadrado con un clic para seleccionarlo, o elegirlo en el menú que se descuelga a partir de la flechita derecha del campo de entrada correspondiente.
  • Además del clic sobre el cuadrado o de su selección del menú descolgable, también deben especificarse sus lados como Objetos de salida.
  • Especificar los Objetos de entrada: GeoGebra automáticamente especifica los Objetos de entrada (en este caso, los puntos A y B). También puede modificarse la selección de los objetos de entrada usando el menú desplegado o eligiéndolos con un clic que los señale en la construcción
  • Anotar el Nombre de la herramienta’ y el del comando para esta que se está creando.
Bulbgraph.pngAtención: El Nombre de la herramienta aparecerá en la correspondiente barra y el del nuevo comando que se le ha asociado podrá emplearse en la Entrada como uno más de los “propios” de GeoGebra.
Notas:
  • Además, se puede anotar el texto que orienta y se expone en la Ayuda de la Barra de Herramientas.
  • También puede elegirse una imagen para que represente el ícono de la herramienta.
    GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.
  • Las salidas de las herramientas no son trasladables aún que se hubieran definido como Punto[ <Recorrido> ].
    En caso de precisarse salidas trasladables, se puede recurrir a definir una lista de comandos para emplearlos con el comando Ejecuta.
© 2022 International GeoGebra Institute