Benutzerdefinierte Werkzeuge: Unterschied zwischen den Versionen

Aus GeoGebra Manual
Wechseln zu: Navigation, Suche
Zeile 1: Zeile 1:
 
<noinclude>{{Manual Page|version=4.0}}</noinclude>{{tool|type=custom|name=Benutzerdefinierte Werkzeuge}}
 
<noinclude>{{Manual Page|version=4.0}}</noinclude>{{tool|type=custom|name=Benutzerdefinierte Werkzeuge}}
{{translate|Custom Tools}}
+
 
 
In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit der Maus als auch als Befehl in der [[Eingabezeile]] verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.
 
In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit der Maus als auch als Befehl in der [[Eingabezeile]] verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.
  
Zeile 7: Zeile 7:
  
 
==Ein benutzerdefiniertes Werkzeug speichern==
 
==Ein benutzerdefiniertes Werkzeug speichern==
Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Klicken Sie dazu im Menü [[Werkzeuge-Menü|Werkzeuge]] auf die Option Werkzeuge verwalten. Wählen Sie anschließend das zu speichernde Werkzeug aus der Liste im erscheinenden [[Werkzeugleiste anpassen - Dialog|Dialog]] aus und klicken Sie auf die Schaltfläche Speichern unter um das Werkzeug als GeoGebra-Werkzeug-Datei (Dateiname endet mit .ggt) auf Ihrem Computer zu speichern.
+
Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Klicken Sie dazu im Menü [[Werkzeuge-Menü|Werkzeuge]] auf die Option Werkzeuge verwalten. Wählen Sie anschließend das zu speichernde Werkzeug aus der Liste im erscheinenden [[Werkzeugleiste anpassen - Dialog|Dialog-Fenster]] aus und klicken Sie auf die Schaltfläche Speichern unter um das Werkzeug als GeoGebra-Werkzeug-Datei auf Ihrem Computer zu speichern.
  
 
{{note|Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.}}
 
{{note|Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.}}
  
==Accessing custom tools==
+
==Ein benutzerdefiniertes Werkzeug abrufen==
If you open a new GeoGebra interface using item New from the File menu, after you created a custom tool, it will still be part of the GeoGebra Toolbar. However, if you open a new GeoGebra window (item [[Image:Menu New.png]] New Window from the [[File Menu]]), or open GeoGebra on another day, your custom tools won’t be part of the Toolbar any more.
+
Wenn Sie eine neue GeoGebra-Oberfläche öffnen (Menü Datei – Neu) nachdem Sie ein benutzerdefiniertes Werkzeug erstellt haben, so bleibt dieses Werkzeug in der Werkzeugleiste erhalten. Wenn Sie jedoch ein neues GeoGebra-Fenster öffnen (Menü Datei – [[Image:Menu New.png]] Neues Fenster), oder wenn Sie GeoGebra schließen und später wieder öffnen, so verschwindet Ihr benutzerdefiniertes Werkzeug aus der Werkzeugleiste.
 
 
There are different ways of making sure that your user defined tools are displayed in the Toolbar of a new GeoGebra window:
 
  
After creating a new user defined tool you can save your settings using item [[Image:Menu Save.png]] Save Settings from the [[Options Menu]]. From now on, your customized tool will be part of the GeoGebra Toolbar. {{Note|You can remove the custom tool from the Toolbar after opening item Customize Toolbar… from the [[Tools Menu]]. Then, select your custom tool from the list of tools on the left hand side of the appearing dialog window and click button Remove.  Don’t forget to save your settings after removing the custom tool.}}
+
==Benutzerdefinierten Werkzeuge in die Werkzeugleiste aufnehmen==
==Importing custom tools==
+
*Nach dem Erstellen eines benutzerdefinierten Werkzeugs können Sie im Menü [[Einstellungen-Menü|Einstellungen]] die Option  [[Image:Menu Save.png]] Einstellungen speichern auswählen, um das neue Werkzeug zu einem permanenten Teil der [[Werkzeugleiste]] zu machen.
After saving your custom tool on your computer (as a GGT file), you can import it into a new GeoGebra window at any time. Just select item [[Image:Menu Open.png]] Open from the [[File Menu]] and open the file of your custom tool.          
+
{{note|Sie können das benutzerdefinierte Werkzeug wieder aus der Werkzeugleiste entfernen, indem Sie im Menü [[Werkzeuge-Menü|Werkzeuge]] die Option Werkzeugleiste anpassen öffnen. Wählen Sie danach das entsprechende Werkzeug aus der linken Liste der Werkzeuge im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche Entfernen. Vergessen Sie nicht, ihre Einstellungen nach dem Entfernen des benutzerdefinierten Werkzeugs nochmals zu speichern.}}
{{Note|* Opening a GeoGebra tool file (GGT) in GeoGebra doesn’t affect your current construction. It only makes this tool part of the current GeoGebra Toolbar.
+
*Nachdem Sie ihr benutzerdefiniertes Werkzeug auf Ihrem Computer (als .ggt-Datei) gespeichert haben, können Sie es jederzeit in ein neues GeoGebra-Fenster importieren. Wählen Sie dazu im Menü [[Datei-Menü|Datei]] die Option [[Image:Menu Open.png]] Öffnen und öffnen sie die entsprechende Datei.
* You can also load GGT file by dragging it from file manager and droping into GeoGebra window.}}
+
{{note|Das Öffnen einer GeoGebra-Werkzeug-Datei hat keinerlei Effekt auf die aktuelle Konstruktion und fügt das neue Werkzeug lediglich zur Werkzeugleiste hinzu.}}
 +
{{note|Sie können .ggt-Datein auch durch Ziehen aus dem Datei Manager in das GeoGebra Fenster einfügen.}}
 
__NOTOC__
 
__NOTOC__

Version vom 13. Juli 2011, 15:29 Uhr


In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit der Maus als auch als Befehl in der Eingabezeile verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.

Ein benutzerdefiniertes Werkzeug erstellen

Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü Werkzeuge die Option Neues Werkzeug erstellen. Im erscheinenden Dialog-Fenster können Sie anschließend die drei Karten Ausgabe-Objekte, Eingabe-Objekte, und Name & Symbol für Ihr neues Werkzeug ausfüllen.

Ein benutzerdefiniertes Werkzeug speichern

Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Klicken Sie dazu im Menü Werkzeuge auf die Option Werkzeuge verwalten. Wählen Sie anschließend das zu speichernde Werkzeug aus der Liste im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche Speichern unter um das Werkzeug als GeoGebra-Werkzeug-Datei auf Ihrem Computer zu speichern.

Anmerkung: Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.

Ein benutzerdefiniertes Werkzeug abrufen

Wenn Sie eine neue GeoGebra-Oberfläche öffnen (Menü Datei – Neu) nachdem Sie ein benutzerdefiniertes Werkzeug erstellt haben, so bleibt dieses Werkzeug in der Werkzeugleiste erhalten. Wenn Sie jedoch ein neues GeoGebra-Fenster öffnen (Menü Datei – Menu New.png Neues Fenster), oder wenn Sie GeoGebra schließen und später wieder öffnen, so verschwindet Ihr benutzerdefiniertes Werkzeug aus der Werkzeugleiste.

Benutzerdefinierten Werkzeuge in die Werkzeugleiste aufnehmen

  • Nach dem Erstellen eines benutzerdefinierten Werkzeugs können Sie im Menü Einstellungen die Option Menu Save.png Einstellungen speichern auswählen, um das neue Werkzeug zu einem permanenten Teil der Werkzeugleiste zu machen.
Anmerkung: Sie können das benutzerdefinierte Werkzeug wieder aus der Werkzeugleiste entfernen, indem Sie im Menü Werkzeuge die Option Werkzeugleiste anpassen öffnen. Wählen Sie danach das entsprechende Werkzeug aus der linken Liste der Werkzeuge im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche Entfernen. Vergessen Sie nicht, ihre Einstellungen nach dem Entfernen des benutzerdefinierten Werkzeugs nochmals zu speichern.
  • Nachdem Sie ihr benutzerdefiniertes Werkzeug auf Ihrem Computer (als .ggt-Datei) gespeichert haben, können Sie es jederzeit in ein neues GeoGebra-Fenster importieren. Wählen Sie dazu im Menü Datei die Option Menu Open.png Öffnen und öffnen sie die entsprechende Datei.
Anmerkung: Das Öffnen einer GeoGebra-Werkzeug-Datei hat keinerlei Effekt auf die aktuelle Konstruktion und fügt das neue Werkzeug lediglich zur Werkzeugleiste hinzu.
Anmerkung: Sie können .ggt-Datein auch durch Ziehen aus dem Datei Manager in das GeoGebra Fenster einfügen.
© 2021 International GeoGebra Institute