Herramientas Propias

De GeoGebra Manual
Saltar a: navegación, buscar
GeoGebra permite la creación de herramientas propias que pueden, posteriormente, emplearse como cualquiera de las del repertorio original e incluso ingresarse como un comando más en la Barra de Entrada.
Una vez creadas, se guardan automáticamente dentro del archivo “ggb” de la construcción.
Bulbgraph.pngAtención: Un objeto creado como salida de una herramienta propia, aunque se hubiera definido como deslizable dentro de un recorrido o región, no podrá ser desplazado.
Así, no se podría desplazar el punto originado por una herramienta propia pese a que surgiera como una de sus salidas como...
Punto[ <Recorrido> ]
Nota: En caso de precisarse elementos desplazables, se puede recurrir a definir una lista, en inglés, de comandos adecuados empleados con Ejecuta.

Hacia... una Nueva Herramienta

Para crear una herramienta se acude a la opciónMenu Create Tool.png Nueva herramienta del correspondiente menú.

Desde una construcción existente, se pueden crear herramientas propias. Tras preparar la construcción de una herramienta, se selecciona Nueva Herramienta en el menú de Herramientas.

Se despliega una ventana de diálogo donde se pueden especificar...

-los Objetos de salida y

-Objetos de Entrada de la herramienta en marcha para luego elegirle...

-Nombre e Ícono con que aparecerá en la barra.

Guardando la Nueva Herramienta

Cuando el boceto en que se produjo la nueva herramienta se guarda, queda también archivada automáticamente, como parte de la información que lo compone.

Nota: Se pueden guardar las herramientas creadas para poder reutilizarlas en otras construcciones de GeoGebra.

En el Menú de Herramientas, al seleccionar Gestión de herramientas, se pueden elegir las que se quiere que aparezcan, de una lista.
Basta un clic sobre el botón Guarda como… para guardar la herramienta en el equipo.

Nota: Las herramientas definidas se guardan como archivos con extensión ‘.ggt’ para distinguirlos de los usuales de GeoGebra (‘.ggb’).

Acceso a Herramientas Creadas

Al abrir una nueva interfaz de GeoGebra usando el ítem Nuevo del menú Archivos, después de haber creado una herramienta, será parte aún de la Barra de Herramientas.
Sin embargo, si se abre una nueva ventana de GeoGebra (ítem Menu New.png Nueva Ventana del Menú Archivo), o GeoGebra otro día, la creada ya no será parte de la barra.

Bulbgraph.pngAtención: Para asegurarse de disponer, en una nueva ventana, de las herramientas creadas, se puede apelar al ítem Menu Save.png Guarda Configuración del Menú de Opciones.
Desde ese momento, la confeccionada será una más del repertorio usual en la barra de las de GeoGebra.
Nota: Se pueden eliminar las herramientas nuevas de la Barra de Herramientas después de abrirlas con la opción "Gestión de herramientas… " desde el correspondiente menú.
Basta con seleccionarlas de la Lista de Herramientas de la ventana de diálogo emergente e ir pulsando el botón Borra.
Es importante guardar cualquier herramienta que se desee conservar, antes de borrarla.

Importación de Herramientas Desarrolladas

Después de guardar la herramienta creada (como archivo .ggt), es posible importarla a una nueva ventana de GeoGebra en cualquier momento:

  • Simplemente seleccionando Menu Open.png Abre del Menú Archivo y eligiendo el que corresponda a la herramienta.
  • Se puede recuperar un archivo GGT arrastrándolo desde su posición en el directorio de archivos y depositándolo en la ventana de GeoGebra.
Nota: Abrir un archivo de herramientas (GGT) no afecta la construcción en marcha. Solo hace que tal herramienta pase a formar parte de la barra.

© 2020 International GeoGebra Institute