自訂工具

来自GeoGebra Manual
跳转至: 导航搜索
Accessories dictionary.png
本頁為官方文件,一般使用者無法修改,若有任何誤謬,請與官方聯絡。如欲編輯,請至本頁的開放版
UnderConstruction.png
目前本頁中文說明尚未翻譯完成,請先連至英文說明。如果您有權限,請幫忙翻譯本頁的官方手冊

GeoGebra allows you to create your own construction tools based on an existing construction. Once created, your custom tool can be used both with the mouse and as a command in the Input Bar. All tools are automatically saved in your GeoGebra file.

備註: Outputs of the tool are not moveable, even if they are defined as Point[<Path>]. In case you need moveable output, you can define a list of commands and use it with Execute Command.

Creating custom tools

To create a custom tool, use the option Create new tool from Tools Menu.

Saving custom tools

When you save the construction as GGB file, all custom tools are stored in it. To save the tools in separate file(s) use the Tool Manager Dialog (option Manage Tools from Tools Menu).

Accessing custom tools

If you open a new GeoGebra interface using item New from the File menu, after you created a custom tool, it will still be part of the GeoGebra Toolbar. However, if you open a new GeoGebra window (item Menu New.png New Window from the File Menu), or open GeoGebra on another day, your custom tools won’t be part of the Toolbar any more.

There are different ways of making sure that your user defined tools are displayed in the Toolbar of a new GeoGebra window:

After creating a new user defined tool you can save your settings using item Menu Save.png Save Settings from the Options Menu. From now on, your customized tool will be part of the GeoGebra Toolbar.

備註: You can remove the custom tool from the Toolbar after opening item Customize Toolbar… from the Tools Menu. Then, select your custom tool from the list of tools on the left hand side of the appearing dialog window and click button Remove. Don’t forget to save your settings after removing the custom tool.

Importing custom tools

After saving your custom tool on your computer (as a GGT file), you can import it into a new GeoGebra window at any time. Just select item Menu Open.png Open from the File Menu and open the file of your custom tool.

備註:
  • Opening a GeoGebra tool file (GGT) in GeoGebra doesn’t affect your current construction. It only makes this tool part of the current GeoGebra Toolbar.
  • You can also load GGT file by dragging it from file manager and droping into GeoGebra window.
© 2021 International GeoGebra Institute