Korisnički alati

Izvor: GeoGebra Manual
Inačica 2149 od 9. travnja 2012. u 21:04 koju je unijela Elarac (razgovor | doprinosi)
Skoči na: orijentacija, traži
Accessories dictionary.png
Ova je stranica dio službenog priručnika za printanje i PDF. Iz strukturnih razloga obični korisnici ne mogu uređivati ovu stranicu. Ukoliko pronađete koju grešku na ovoj stranici, molimo da nas kontaktirate.Idite na verziju koju korisnik može uređivati.

Na temelju postojeće konstrukcije u GeoGebri možete napraviti svoje vlastite alate.

Kada je napravljen, vaš se alat može koristiti na oba načina, pomoću miša (odabirom ikone iz alatne trake) i kao naredba iz trake za unos. Svi alati se automatski spremaju u vašu “ggb” datoteku.

Napomena: Izlazni objekti ne mogu se pomicati sami po sebi, čak i kada su definirani kao Točka[<Putanja>]. Ako želite pomične objekta, možete definirati listu naredbi i korisitit ih pomoću naredbe Izvrši.

Izrada korisničkog alata

Za stvaranje novog alata u izborniku Alati odaberite Izrada novog alata. U dijaloškom okviru koji se otvorio možete specificirati izlazne i ulazne objekte vašeg alata i odabrati ikonu, naziv za alat i naredbu.

Spremanje korisničkog alata

Kada ste spremili konstrukciju kao GGB datoteku, svi su korisnički alati u njoj pohranjeni. Kako biste alate spremili u druge datoteke koristite Dijaloški okvir Upravljanje alatima (podizbornik Upravljanje alatima.. izbornika Alati).

Accessing custom tools

If you open a new GeoGebra interface using item New from the File menu, after you created a custom tool, it will still be part of the GeoGebra Toolbar. However, if you open a new GeoGebra window (item Menu New.png New Window from the File Menu), or open GeoGebra on another day, your custom tools won’t be part of the Toolbar any more.

There are different ways of making sure that your user defined tools are displayed in the Toolbar of a new GeoGebra window:

After creating a new user defined tool you can save your settings using item Menu Save.png Save Settings from the Options Menu. From now on, your customized tool will be part of the GeoGebra Toolbar.

Napomena: You can remove the custom tool from the Toolbar after opening item Customize Toolbar… from the Tools Menu. Then, select your custom tool from the list of tools on the left hand side of the appearing dialog window and click button Remove. Don’t forget to save your settings after removing the custom tool.

Importing custom tools

After saving your custom tool on your computer (as a GGT file), you can import it into a new GeoGebra window at any time. Just select item Menu Open.png Open from the File Menu and open the file of your custom tool.

Napomena:
  • Opening a GeoGebra tool file (GGT) in GeoGebra doesn’t affect your current construction. It only makes this tool part of the current GeoGebra Toolbar.
  • You can also load GGT file by dragging it from file manager and droping into GeoGebra window.

Comments

© 2021 International GeoGebra Institute