Différences entre versions de « Tutoriel:Champ de Saisie »

De GeoGebra Manual
Aller à : navigation, rechercher
 
Ligne 2 : Ligne 2 :
  
  
==Tips and Tricks==
+
==Trucs et astuces==
* '''Name a new object''' by typing ''name ='' into the input bar in front of its algebraic representation. {{Example|1= P = (3, 2) creates point P.}}
+
* '''Nommer un nouvel objet''' en écrivant, dans le champ de saisie, son  ''nom ='' devant son expression algébrique. {{Example|1= P = (3, 2) crée le point P.}}
* '''Multiplication''' needs to be entered using an asterisk or space between the factors. {{Example|a*x or a x}}
+
* Une '''multiplication''' nécessite d'être écrite avec une ''étoile'' ou une espace entre les facteurs. {{Example|a*x ou a x}}
* '''GeoGebra is case sensitive!''' Thus, upper and lower case letters must not be mixed up.  
+
* '''GeoGebra est sensible à la case !''' Il s'ensuit que les minuscules et les majuscules ne peuvent être interverties.  
**Points are always named with upper case letters {{Example|1= A = (1, 2)}}
+
**Les points sont toujours nommés avec des majuscules {{Example|1= A = (1, 2)}}
** Vectors are named with lower case letters {{Example|1= v = (1, 3)}}
+
** Les vecteurs sont toujours nommés avec des minuscules {{Example|1= v = (1, 3)}}
**Segments, lines, circles, functions… are always named with lower case letters. {{Example|1= circle c: (x – 2)^2 + (y – 1)^2 = 16}}
+
**Les segments, droites, cercles, fonctions… sont toujours nommés avec des minuscules. {{Example|1= cercle c: (x – 2)^2 + (y – 1)^2 = 16}}
** The variable x within a function and the variables x and y in the equation of a conic section always need to be lower case. {{Example|1= f(x) = 3*x + 2}}
+
** La variable x dans l'écriture d'une fonction et les variables x et y dans l'équation d'une conique sont toujours en minuscule. {{Example|1= f(x) = 3*x + 2}}
* If you want to use an '''object within an algebraic expression''' or command you need to create the object prior to using its name in the input bar.  
+
*Si vous désirez utiliser un '''objet à l'intérieur d'une expression algébrique''' ou d'une commande, vous devez au préalable créer cet objet avant d'utiliser son nom dans le champ de saisie.  
** y = m x + b creates a line whose parameters are already existing values m and b (e.g. numbers / sliders).  
+
** y = a x + b crée une droite dont les paramètres sont des valeurs a et b (par ex. nombres / curseurs) définies auparavant .  
** Line[A, B] creates a line through existing points A and B.
+
** Droite[A, B] crée la droite passant par les points A et B existants.
* '''Confirm an expression''' you entered into the input bar by pressing the {{KeyCode|Enter}} key.
+
* '''Confirmer une expression''' tapée dans le champ de saisie en pressant la touche {{KeyCode|Entrée}}.
* '''Open the help window''' for using the input bar and commands by selecting ''Help'' from the [[Help Menu]] (or shortcut {{KeyCode|F1}}).
+
* '''Ouvrir la fenêtre d'aide''' à l'utilisation du champ de saisie et des commandes en sélectionnant ''Aide'' dans le [[Menu Aide]] (ou  raccourci clavier {{KeyCode|F1}}).
* '''Error messages''': Always read the messages – they could possibly help to fix the problem!
+
* '''Messages d'erreur ''' : Toujours lire les messages – ils peuvent probablement aider à résoudre le problème !
* '''Commands''' can be typed in or selected from the list next to the [[Input Bar]]. {{hint|If you don’t know which parameters are required within the brackets of a certain command, type in the full command name and press key {{KeyCode|F1}} to open the GeoGebra Wiki.}}
+
*Les '''Commandes''' peuvent être écrites ou choisies dans la liste à droite de [[Saisie]]. {{idée|Si vous ne savez quels paramètres sont requis à l'intérieur des ''chevrons'' de certaines commandes,taper le nom complet de la commande et pressez {{KeyCode|F1}} pour ouvrir le Manuel GeoGebra.}}
* '''Automatic completion of commands''': After typing in the first two letters of a command into the [[Input Bar]], GeoGebra tries to complete the command.
+
* '''Complétion automatique  des commandes''' : Après la frappe des deux premières lettres de la commande dans  [[Saisie]], GeoGebra essaye de  complèter la commande.
** If GeoGebra suggests the desired command, hit the {{KeyCode|Enter}} key in order to place the cursor within the brackets.
+
** Si GeoGebra propose la commande désirée , pressez la touche {{KeyCode|Entrée}} de manière à placer le curseur entre les chevrons.
** If the suggested command is not the one you wanted to enter, just keep typing until the suggestion matches.
+
** Si la commande proposée n'est pas celle que vous désirez, continuez à taper, jusqu'à ce que la suggestion soit la bonne.

Version actuelle datée du 3 mars 2012 à 17:24

en:Tutorial:Basic_Algebraic_Input,_Commands_and_Functions


Trucs et astuces

  • Nommer un nouvel objet en écrivant, dans le champ de saisie, son nom = devant son expression algébrique.
    Exemple: P = (3, 2) crée le point P.
  • Une multiplication nécessite d'être écrite avec une étoile ou une espace entre les facteurs.
    Exemple: a*x ou a x
  • GeoGebra est sensible à la case ! Il s'ensuit que les minuscules et les majuscules ne peuvent être interverties.
    • Les points sont toujours nommés avec des majuscules
      Exemple: A = (1, 2)
    • Les vecteurs sont toujours nommés avec des minuscules
      Exemple: v = (1, 3)
    • Les segments, droites, cercles, fonctions… sont toujours nommés avec des minuscules.
      Exemple: cercle c: (x – 2)^2 + (y – 1)^2 = 16
    • La variable x dans l'écriture d'une fonction et les variables x et y dans l'équation d'une conique sont toujours en minuscule.
      Exemple: f(x) = 3*x + 2
  • Si vous désirez utiliser un objet à l'intérieur d'une expression algébrique ou d'une commande, vous devez au préalable créer cet objet avant d'utiliser son nom dans le champ de saisie.
    • y = a x + b crée une droite dont les paramètres sont des valeurs a et b (par ex. nombres / curseurs) définies auparavant .
    • Droite[A, B] crée la droite passant par les points A et B existants.
  • Confirmer une expression tapée dans le champ de saisie en pressant la touche Entrée.
  • Ouvrir la fenêtre d'aide à l'utilisation du champ de saisie et des commandes en sélectionnant Aide dans le Menu Aide (ou raccourci clavier F1).
  • Messages d'erreur  : Toujours lire les messages – ils peuvent probablement aider à résoudre le problème !
  • Les Commandes peuvent être écrites ou choisies dans la liste à droite de Saisie.
    Note Idée : Si vous ne savez quels paramètres sont requis à l'intérieur des chevrons de certaines commandes,taper le nom complet de la commande et pressez F1 pour ouvrir le Manuel GeoGebra.
  • Complétion automatique des commandes : Après la frappe des deux premières lettres de la commande dans Saisie, GeoGebra essaye de complèter la commande.
    • Si GeoGebra propose la commande désirée , pressez la touche Entrée de manière à placer le curseur entre les chevrons.
    • Si la commande proposée n'est pas celle que vous désirez, continuez à taper, jusqu'à ce que la suggestion soit la bonne.
© 2021 International GeoGebra Institute