Différences entre versions de « Tableur »

De GeoGebra Manual
Aller à : navigation, rechercher
(dodo)
Ligne 1 : Ligne 1 :
<noinclude>{{Manual Page|version=4.0}}</noinclude>{{gui|view}}
+
<noinclude>{{Manual Page|version=4.2}}</noinclude>{{gui|view}}
  
Dans le Tableur de GeoGebra chaque cellule a un nom spécifique  ce qui vous permet d’atteindre directement chaque cellule. Par exemple, la cellule de la colonne A et de la ligne 1 est nommée A1.
+
Comme toute fenêtre, cette fenêtre Graphique peut être ouverte de manière indépendante, en cliquant sur le bouton [[Fichier:View-window.png]] 'Afficher dans une nouvelle fenêtre' qui apparaît lorsque vous approchez votre pointeur de la partie droite du bandeau-titre, et vous pouvez de nouveau l' 'Afficher dans la fenêtre principale' en cliquant sur le bouton [[Fichier:View-unwindow.png]].
  
{{note|Ces noms de cellules peuvent être utilisés dans des expressions et des commandes pour faire référence au contenu de la cellule correspondante.}}
 
  
Dans les cellules du tableur, vous pouvez entrer non seulement des nombres, mais tous les  typesd’objets mathématiques  [[Généraux|généraux]] et [[Objets_géométriques|géométriques]] qui sont reconnus par GeoGebra (par ex., coordonnées de points, [[fonctions]], [[commandes]]). Lorsque cela est possible, GeoGebra affiche immédiatement la représentation graphique de l’objet défini dans la cellule du tableur dans la vue [[Graphique]]. De ce fait, le nom de l’objet reprend le nom de la cellule du tableur utilisé pour sa création (par ex., A5, C1).
+
Dans le Tableur de GeoGebra chaque cellule a un nom spécifique ce qui vous permet l’atteindre directement. Par exemple, la cellule de la colonne A et de la ligne 1 est nommée A1.
  
{{note| Par défaut, les objets du tableur sont classés comme [[Objets_libres,_dépendants_ou_auxiliaires#Objets_auxiliaires|Objets auxiliaires]] dans la fenêtre [[Algèbre]]. Vous pouvez montrer ou cacher ces Objets auxiliaires en cochant ou non ‘Objets auxiliaires ’ dans le [[menu Affichage]].}}
+
{{note|Ces noms  peuvent être utilisés dans des expressions et des commandes pour faire référence au contenu de la cellule correspondante.}}
 +
 
 +
Dans les cellules du tableur, vous pouvez entrer non seulement des nombres, mais  tous les  types d’objets mathématiques  [[Généraux|généraux]] et [[Objets_géométriques|géométriques]] qui sont reconnus par GeoGebra (par ex., coordonnées de points, [[fonctions]], [[commandes]]). <br/>Lorsque cela est possible, GeoGebra affiche immédiatement la représentation graphique de l’objet défini dans la cellule du tableur dans la vue [[Graphique]]. De ce fait, le nom de l’objet reprend le nom de la cellule du tableur utilisé pour sa création (par ex., A5, C1).
 +
 
 +
{{note| Par défaut, les objets créés dans le tableur sont classés comme [[Objets_libres,_dépendants_ou_auxiliaires#Objets_auxiliaires| auxiliaires]] dans la fenêtre [[Algèbre]]. Vous pouvez les montrer ou cacher en cliquant  sur le bouton [[Image:Auxiliary.png]] ‘Objets auxiliaires ’ de la barre de style.}}
  
 
==Adressage relatif==
 
==Adressage relatif==
Ligne 18 : Ligne 21 :
 
==Récupérer des données dans le tableur==
 
==Récupérer des données dans le tableur==
  
En plus de la saisie manuelle de données dans le tableur, vous pouvez utiliser les commandes [[Commande RemplirColonne|RemplirColonne]], [[Commande RemplirLigne|RemplirLigne]] ou [[Commande RemplirCellules|RemplirCellules]]. Voir aussi la section [[Pister#Enregistrer dans le tableur|enregistrer dans le tableur]].
+
En plus de la saisie manuelle de données dans le tableur, vous pouvez utiliser les commandes [[Commande RemplirColonne|RemplirColonne]], [[Commande RemplirLigne|RemplirLigne]] ou [[Commande RemplirCellules|RemplirCellules]]. <br/>Voir aussi la section [[Pister#Enregistrer dans le tableur|enregistrer dans le tableur]].
 +
 
 +
 
 +
==[[Fichier:Menu Open.png]] Importer un fichier de données==
 +
 
 +
Par clic droit sur une cellule vide, vous obtenez, dans le menu contextuel,  la possibilité d'importer un fichier de données au format .txt, .csv ou .dat dans le tableur, soit à partir de votre ordinateur, soit à partir de la toile, voir les paramétrages choisis dans 'Options Tableur'.
 +
 
 +
== [[Fichier:Menu_Properties_Gear.png|20px]]Options du tableur==
 +
 
 +
Par clic droit sur une cellule vide, vous obtenez, dans le menu contextuel,  la possibilité de définir les 'Options du tableur'.
 +
::{{Note| Vous pouvez aussi ouvrir cette fenêtre en cliquant le bouton [[Fichier:Menu_Properties_Gear.png]] 'Préférences', dans le coin supérieur droit, puis en choisissant [[Fichier:View-spreadsheet24.png]] 'Tableur'.}}
 +
<center>
 +
{|
 +
|-
 +
! align=left|Aspect !! &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; !! align=left|Arborescence
 +
|-
 +
| Afficher le Champ de Saisie || &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ||Afficher Arborescence
 +
|-
 +
| Afficher Grille || ||
 +
|-
 +
| Afficher Entêtes Colonnes |||| Répertoire racine
 +
|-
 +
| Afficher Entêtes Lignes || || &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Fichier Système
 +
|-
 +
| Barres défilement horizontal || || &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; URL:
 +
|-
 +
| Barres défilement vertical || ||
 +
|-
 +
| Utiliser Boutons et Cases à cocher || ||
 +
|-
 +
| Autoriser InfoBulles || ||
 +
|-
 +
| Nécessite "=" avant les commandes || ||
 +
|-
 +
| Utiliser l'auto-complétion || ||
 +
|}
 +
</center>
  
 
==Utiliser les données du tableur dans d'autres vues==
 
==Utiliser les données du tableur dans d'autres vues==
  
Vous pouvez exploiter les données du tableur en sélectionnant plusieurs cellules, puis, après clic droit, choisir une option du menu "Créer" .
+
Vous pouvez exploiter les données du tableur en sélectionnant plusieurs cellules, puis, après clic droit, choisir une des options accessibles, suivant votre sélection, du menu "Créer" :
 +
* Liste ;
 +
* Liste de points ;
 +
* Matrice ;
 +
* Tableau ;
 +
* Ligne brisée ;
 +
* Tableau Calculs.
 +
 
 +
 
 +
==Barre de style==
 +
 
 +
La barre de style de cette fenêtre, ouverte en pressant le bouton  [[Fichier:Triangle-right.png]] contient huit boutons : [[Fichier:BarreStyleTableur.png]]
 +
 
 +
[[Fichier:Formula bar.png]] Afficher le Champ de Saisie,  '''G'''  En gras,  ''I'' en italiques, [[Fichier:Format-justify-left.png]] Alignement Gauche, [[Fichier:Format-justify-center.png]] Centré,  [[Fichier:Format-justify-right.png]] Alignement Droite, <code> &nbsp;&nbsp;&nbsp;  </code> Couleur d'arrière-plan,  [[Fichier:Border frame.png]] Bordures.
 +
 
 +
 
 +
<center>
 +
{|
 +
|-
 +
|[[Fichier:Formula bar.png]] Afficher le Champ de Saisie || <code> &nbsp;&nbsp;&nbsp;  </code> Couleur d'arrière-plan || [[Fichier:Border frame.png]] Bordures
 +
|-
 +
| [[Fichier:BarreStyleTableurSaisie.png]] || [[Fichier:BarreStyleTableurCouleurArPlan.png]]  || [[Fichier:BarreStyleTableurBordures.png]]
 +
|}
 +
</center>
 +
 
 +
{{idée|Si vous désirez faire apparaître dans Graphique, un texte dans une boîte coloriée, définissez le dans une cellule du tableur, utilisez l'option Couleur d'arrière-plan pour colorier la cellule.<br/> Et par clic droit sur la cellule validée, sélectionnez 'Afficher l'objet' dans le menu contextuel.}}
 +
 
 +
 
 +
 
 +
 
 +
__NoTOC__
 +
--[[Utilisateur:Noel Lambert|Noel Lambert]] ([[Discussion utilisateur:Noel Lambert|discussion]]) 30 mars 2013 à 22:56 (CET)

Version du 30 mars 2013 à 23:56


Comme toute fenêtre, cette fenêtre Graphique peut être ouverte de manière indépendante, en cliquant sur le bouton View-window.png 'Afficher dans une nouvelle fenêtre' qui apparaît lorsque vous approchez votre pointeur de la partie droite du bandeau-titre, et vous pouvez de nouveau l' 'Afficher dans la fenêtre principale' en cliquant sur le bouton View-unwindow.png.


Dans le Tableur de GeoGebra chaque cellule a un nom spécifique ce qui vous permet l’atteindre directement. Par exemple, la cellule de la colonne A et de la ligne 1 est nommée A1.

Note : Ces noms peuvent être utilisés dans des expressions et des commandes pour faire référence au contenu de la cellule correspondante.

Dans les cellules du tableur, vous pouvez entrer non seulement des nombres, mais tous les types d’objets mathématiques généraux et géométriques qui sont reconnus par GeoGebra (par ex., coordonnées de points, fonctions, commandes).
Lorsque cela est possible, GeoGebra affiche immédiatement la représentation graphique de l’objet défini dans la cellule du tableur dans la vue Graphique. De ce fait, le nom de l’objet reprend le nom de la cellule du tableur utilisé pour sa création (par ex., A5, C1).

Note : Par défaut, les objets créés dans le tableur sont classés comme auxiliaires dans la fenêtre Algèbre. Vous pouvez les montrer ou cacher en cliquant sur le bouton Auxiliary.png ‘Objets auxiliaires ’ de la barre de style.

Adressage relatif

Par défaut, lorsque vous recopiez le contenu d'une cellule dans une autre, toutes les références sont modifiées en accord avec la cellule de destination.

Exemple: Soit A1=1,A2=2. Et dans B1 la saisie (A1,A1). En copiant B1 dans B2 (soit par Ctrl + C, Ctrl + V soit en tirant le coin de la cellule) vous obtenez (A2,A2) dans B2.

Pour annuler ce comportement, vous pouvez insérer le symbole $ devant le nom de colonne ou de ligne de la cellule de référence.

Note : Sur Mac les raccourcis clavier copier & coller sont Cmd + C et Cmd + V

Récupérer des données dans le tableur

En plus de la saisie manuelle de données dans le tableur, vous pouvez utiliser les commandes RemplirColonne, RemplirLigne ou RemplirCellules.
Voir aussi la section enregistrer dans le tableur.


Menu Open.png Importer un fichier de données

Par clic droit sur une cellule vide, vous obtenez, dans le menu contextuel, la possibilité d'importer un fichier de données au format .txt, .csv ou .dat dans le tableur, soit à partir de votre ordinateur, soit à partir de la toile, voir les paramétrages choisis dans 'Options Tableur'.

Menu Properties Gear.pngOptions du tableur

Par clic droit sur une cellule vide, vous obtenez, dans le menu contextuel, la possibilité de définir les 'Options du tableur'.

Note : Vous pouvez aussi ouvrir cette fenêtre en cliquant le bouton Menu Properties Gear.png 'Préférences', dans le coin supérieur droit, puis en choisissant View-spreadsheet24.png 'Tableur'.
Aspect        Arborescence
Afficher le Champ de Saisie        Afficher Arborescence
Afficher Grille
Afficher Entêtes Colonnes Répertoire racine
Afficher Entêtes Lignes        Fichier Système
Barres défilement horizontal        URL:
Barres défilement vertical
Utiliser Boutons et Cases à cocher
Autoriser InfoBulles
Nécessite "=" avant les commandes
Utiliser l'auto-complétion

Utiliser les données du tableur dans d'autres vues

Vous pouvez exploiter les données du tableur en sélectionnant plusieurs cellules, puis, après clic droit, choisir une des options accessibles, suivant votre sélection, du menu "Créer" :

  • Liste ;
  • Liste de points ;
  • Matrice ;
  • Tableau ;
  • Ligne brisée ;
  • Tableau Calculs.


Barre de style

La barre de style de cette fenêtre, ouverte en pressant le bouton Triangle-right.png contient huit boutons : BarreStyleTableur.png

Formula bar.png Afficher le Champ de Saisie, G En gras, I en italiques, Format-justify-left.png Alignement Gauche, Format-justify-center.png Centré, Format-justify-right.png Alignement Droite,     Couleur d'arrière-plan, Border frame.png Bordures.


Formula bar.png Afficher le Champ de Saisie     Couleur d'arrière-plan Border frame.png Bordures
BarreStyleTableurSaisie.png BarreStyleTableurCouleurArPlan.png BarreStyleTableurBordures.png
Note Idée : Si vous désirez faire apparaître dans Graphique, un texte dans une boîte coloriée, définissez le dans une cellule du tableur, utilisez l'option Couleur d'arrière-plan pour colorier la cellule.
Et par clic droit sur la cellule validée, sélectionnez 'Afficher l'objet' dans le menu contextuel.



--Noel Lambert (discussion) 30 mars 2013 à 22:56 (CET)

© 2021 International GeoGebra Institute