Diferencia entre revisiones de «Nueva herramienta»

De GeoGebra Manual
Saltar a: navegación, buscar
 
(No se muestran 3 ediciones intermedias del mismo usuario)
Línea 1: Línea 1:
{{DISPLAYTITLE:Nueva Herramienta}}<noinclude>{{Manual Page|version=4.2}}</noinclude>{{Interfaz_Gráfica|Cuadro}}En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori.<br>En el  [[Menú de Herramientas|menú]] de [[Herramientas]] basta un ''clic'' sobre [[Image:Menu Create Tool.png]] [[Propias#Creando una... Nueva Herramienta|''Nueva herramienta'']] para abrir el correspondiente cuadro de diálogo.
+
{{DISPLAYTITLE:Nueva Herramienta}}<noinclude>{{Manual Page|version=5.0}}</noinclude>{{Interfaz_Gráfica|Cuadro}}En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori.<br>En el  [[Menú de Herramientas|menú]] de [[Herramientas]] basta un ''clic'' sobre [[Image:Menu Create Tool.png]] [[Propias#Creando una... Nueva Herramienta|''Nueva herramienta'']] para abrir el correspondiente cuadro de diálogo.
 
;
 
;
 
Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:<br>
 
Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:<br>
Línea 5: Línea 5:
 
*{{KeyCode|Objetos de entrada}} y<br><br>  
 
*{{KeyCode|Objetos de entrada}} y<br><br>  
 
*{{KeyCode|Nombre e Icono}}<br><br>
 
*{{KeyCode|Nombre e Icono}}<br><br>
{{Examples|1=Receta para crear una [[Herramientas|herramienta]] ''Cuadrada'' que trazará un cuadrado con dos ''clic'' sucesivos en dos posiciones vacías de la [[Vista Gráfica]] (que establecerán los puntos vértices de una de sus diagonales).
+
 
*Construir un cuadrado empezando por dos puntos A y B que den lugar a los otros dos vértices para que al  conectarlos, con la herramienta [[Image:Tool Polygon.gif]] [[Herramienta de Polígono|Polígono]], procuren el cuadrado deseado.<br>(Basta con indicar el [[Herramienta de Medio o Centro|Punto medio o Centro]] entre los dos marcados y llevar adelante las maniobras necesarias para que el ambos giren un ángulo recto alrededor de tal centro).
+
<h3>Receta de [[Herramientas|herramienta]] ''Cuadrada''</h3>
*Seleccionar [[Image:Menu Create Tool.png]] [[Propias#Creación de una... Nueva Herramientas|Nueva Herramienta]] en el menú [[Menú de Herramientas|correspondiente]].
+
{{Example|1=<div><br>
*Especificar en {{KeyCode|Objetos de salida}} al cuadrado con un ''clic'' para seleccionarlo, o elegirlo en el menú que se descuelga a partir de la flechita derecha del campo de entrada correspondiente.
+
Receta para crear una [[Herramientas|herramienta]] ''Cuadrada'' que trazará un cuadrado con dos ''clic'' sucesivos en dos posiciones vacías de la [[Vista Gráfica]] (que establecerán los puntos vértices de una de sus diagonales).<br>
*Además del ''clic'' sobre el cuadrado o de su selección del menú descolgable, también deben especificarse sus lados como ''Objetos de salida''.
+
*Construir un cuadrado empezando por dos puntos A y B que den lugar a los otros dos vértices para que al  conectarlos, con la herramienta [[image: Mode polygon.svg|link=Herramienta de Polígono|32px]] [[Herramienta de Polígono|Polígono]], procuren el cuadrado deseado.<br>Basta con indicar el [[image: Mode midpoint.svg|link=Herramienta de Medio o Centro|32px]] [[Herramienta de Medio o Centro|Punto medio o Centro]] entre los dos marcados y llevar adelante las maniobras necesarias para que el ambos giren un ángulo recto alrededor de tal centro.<br>
*Especificar los {{KeyCode|Objetos de entrada}}: GeoGebra automáticamente especifica los ''Objetos de entrada'' (en este caso, los puntos A y B). También puede modificarse la selección de los objetos de entrada usando el menú desplegado o eligiéndolos con un ''clic'' que los señale en la construcción
+
*Seleccionar [[Image:Menu Create Tool.png]] [[Propias#Creación de una... Nueva Herramientas|Nueva Herramienta]] en el menú [[Menú de Herramientas|correspondiente]].<br>
*Anotar el ''Nombre'' de la herramienta’ y el del [[Comandos|comando]] para esta que se está creando.}}     
+
*Especificar en {{KeyCode|Objetos de salida}} al cuadrado con un ''clic'' para seleccionarlo, o elegirlo en el menú que se descuelga a partir de la flechita derecha del campo de entrada correspondiente.<br>
 +
*Además del ''clic'' sobre el cuadrado o de su selección del menú descolgable, también deben especificarse sus lados como ''Objetos de salida''.<br>
 +
*Especificar los {{KeyCode|Objetos de entrada}}: GeoGebra automáticamente especifica los ''Objetos de entrada'' (en este caso, los puntos A y B).<br>También puede modificarse la selección de los objetos de entrada usando el menú desplegado o eligiéndolos con un ''clic'' que los señale en la construcción
 +
*Anotar el ''Nombre'' de la herramienta’ y el del [[Comandos|comando]] para esta que se está creando.</div>}}     
 
{{OJo|1=El ''Nombre'' de la herramienta aparecerá en la correspondiente [[Barra de Herramientas|''barra'']] y el del nuevo comando que se le ha asociado podrá emplearse en la [[Barra de Entrada|Entrada]] como uno más de los “propios” de GeoGebra.}}
 
{{OJo|1=El ''Nombre'' de la herramienta aparecerá en la correspondiente [[Barra de Herramientas|''barra'']] y el del nuevo comando que se le ha asociado podrá emplearse en la [[Barra de Entrada|Entrada]] como uno más de los “propios” de GeoGebra.}}
{{Notes|1=<br>
+
{{Notes|1=<div>
 
*Además, se puede anotar el texto que orienta y se expone en la [[Barra de Herramientas#Ayuda de la Barra de Herramientas|Ayuda de la Barra de Herramientas]].
 
*Además, se puede anotar el texto que orienta y se expone en la [[Barra de Herramientas#Ayuda de la Barra de Herramientas|Ayuda de la Barra de Herramientas]].
 
*También puede elegirse una imagen para que represente el ícono de la herramienta.<br>GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.<hr>
 
*También puede elegirse una imagen para que represente el ícono de la herramienta.<br>GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.<hr>
*Las salidas de las herramientas no son trasladables aún que se hubieran definido como  '''<code>[[Comando Punto|Punto]][ <Recorrido> ].</code>'''<br>En caso de precisarse salidas trasladables, se puede recurrir a definir una lista de comandos para emplearlos con el comando [[Comando Ejecuta|Ejecuta]].}}
+
*Las salidas de las herramientas no son trasladables aún que se hubieran definido como  '''<code>[[Comando Punto|Punto]][ <Recorrido> ]</code>'''<br>En caso de precisarse salidas trasladables, se puede recurrir al comando [[Comando Ejecuta|Ejecuta]] sobre la lista de los que deben emplearse.</div>}}

Revisión actual del 00:27 11 jul 2015

En primer lugar, es preciso elaborar la construcción que la herramienta debe poder trazar a posteriori.
En el menú de Herramientas basta un clic sobre Menu Create Tool.png Nueva herramienta para abrir el correspondiente cuadro de diálogo.

Ahora se precisa, para crear efectivamente la herramienta, completar los datos en las tres pestañas:

  • Objetos de salida,

  • Objetos de entrada y

  • Nombre e Icono

Receta de herramienta Cuadrada

Ejemplo:

Receta para crear una herramienta Cuadrada que trazará un cuadrado con dos clic sucesivos en dos posiciones vacías de la Vista Gráfica (que establecerán los puntos vértices de una de sus diagonales).

  • Construir un cuadrado empezando por dos puntos A y B que den lugar a los otros dos vértices para que al conectarlos, con la herramienta Mode polygon.svg Polígono, procuren el cuadrado deseado.
    Basta con indicar el Mode midpoint.svg Punto medio o Centro entre los dos marcados y llevar adelante las maniobras necesarias para que el ambos giren un ángulo recto alrededor de tal centro.
  • Seleccionar Menu Create Tool.png Nueva Herramienta en el menú correspondiente.
  • Especificar en Objetos de salida al cuadrado con un clic para seleccionarlo, o elegirlo en el menú que se descuelga a partir de la flechita derecha del campo de entrada correspondiente.
  • Además del clic sobre el cuadrado o de su selección del menú descolgable, también deben especificarse sus lados como Objetos de salida.
  • Especificar los Objetos de entrada: GeoGebra automáticamente especifica los Objetos de entrada (en este caso, los puntos A y B).
    También puede modificarse la selección de los objetos de entrada usando el menú desplegado o eligiéndolos con un clic que los señale en la construcción
  • Anotar el Nombre de la herramienta’ y el del comando para esta que se está creando.
Bulbgraph.pngAtención: El Nombre de la herramienta aparecerá en la correspondiente barra y el del nuevo comando que se le ha asociado podrá emplearse en la Entrada como uno más de los “propios” de GeoGebra.
Notas:
  • Además, se puede anotar el texto que orienta y se expone en la Ayuda de la Barra de Herramientas.
  • También puede elegirse una imagen para que represente el ícono de la herramienta.
    GeoGebra se ocupa de escalarla para que se ajuste al nuevo botón de la Barra.
  • Las salidas de las herramientas no son trasladables aún que se hubieran definido como Punto[ <Recorrido> ]
    En caso de precisarse salidas trasladables, se puede recurrir al comando Ejecuta sobre la lista de los que deben emplearse.
© 2022 International GeoGebra Institute