Diferencia entre revisiones de «Gestión de herramientas»

De GeoGebra Manual
Saltar a: navegación, buscar
Línea 1: Línea 1:
{{DISPLAYTITLE:Gestión de Herramientas}}<noinclude>{{Manual Page|version=4.2}}</noinclude>{{Interfaz_Gráfica|Gestión}}Desde el cuadro que despliega [[Image:Menu Properties.png]] ''Gestión de Herramientas'' de ese [[Menú de Herramientas|menú]], cualquier de las ya [[Propias|creadas]] se puede guardar, eliminar, recuperar para reutilizarla e incluso compartir, sumándola al repertorio de las de [[Envío a GeoGebra|GeoGebra]].[[File:Gestion de Herramientas.PNG|left|296px]]<br>Como se aprecia, toda [[Herramientas|herramienta]] ya almacenada en un [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo '''<code>.ggt</code>''']], desde este cuadro se puede...
+
{{DISPLAYTITLE:Gestión de Herramientas}}<noinclude>{{Manual Page|version=5.0}}</noinclude>{{Interfaz_Gráfica|Gestión}}
*someter a cambios como el de su icono, ayuda de sintaxis y nombre o solo el del [[Comandos|comando]] asociado  
+
Desde el cuadro que despliega [[Image:Menu Properties.png]] ''Gestión de Herramientas'' de ese [[Menú de Herramientas|menú]], cualquier de las ya [[Propias|creadas]] se puede guardar, eliminar y/o recuperar para reutilizarla en otra construcción de GeoGebra.<br>Incluso se las puede compartir, sumándolas al repertorio de las enviadas e incluso disponibles en [[Envío a GeoGebra|GeoGebra]].
*indicarlo, según se (des)tilde la casilla  pertinente, como uno efectivamente a ''Mostrar en la [[Barra de Herramientas]]'', o no
+
 
:{{OJo|1=Una [[Barra de Herramientas#Creando una Herramienta Nueva…|herramienta ya creada y recuperada]] tiene asociado un [[Comandos|comando]] que, sea que se la muestre o no en la [[Barra de Herramientas]], sigue disponible y hasta referido cuando se despliega la lista de ''Todos los Comandos''.}}
+
<h3>Recuperando  [[Herramientas|herramientas]] de [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|Archivo]]</h3>
 +
Como se aprecia, toda [[Herramientas|herramienta]] ya almacenada en un [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo '''<code>.ggt</code>''']], desde este cuadro se puede:<br>
 +
* someter a cambios como el de su icono, ayuda de sintaxis y nombre o solo el del [[Comandos|comando]] asociado  
 +
* indicarla, según se (des)tilde la casilla  pertinente, como una efectivamente a ''Mostrar en la [[Barra de Herramientas]]'', o no[[File:Gestion de Herramientas.PNG|left|276px]]<br>
 +
:{{OJo|1=Una [[Barra de Herramientas#Creando una Herramienta Nueva…|herramienta creada y/o recuperada]] tiene asociado un [[Comandos|comando]] que, aunque no se la muestre en la [[Barra de Herramientas|''barra'',]] sigue disponible y hasta referido cuando se despliega la lista de ''Todos los Comandos''.}}
 
*descartar completamente en tanto se la {{KeyCode|Borra}}.
 
*descartar completamente en tanto se la {{KeyCode|Borra}}.
 
:{{Note|1=Esta es una maniobra más definitiva que la de decidir si se incluye o no en la [[Barra de Herramientas|Barra]].}}
 
:{{Note|1=Esta es una maniobra más definitiva que la de decidir si se incluye o no en la [[Barra de Herramientas|Barra]].}}
Línea 9: Línea 13:
 
*''abrir'' en la ventana que presenta el boceto desde el que se la hubiera creado para habilitar su revisión
 
*''abrir'' en la ventana que presenta el boceto desde el que se la hubiera creado para habilitar su revisión
 
:{{Note|1=Toda [[Herramientas|herramienta]] ''almacenada'' también se ''Abre'' desde el [[Menú Archivo|menú]] correspondiente, seleccionando su [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo '''<code>.ggt</code>''']].}}
 
:{{Note|1=Toda [[Herramientas|herramienta]] ''almacenada'' también se ''Abre'' desde el [[Menú Archivo|menú]] correspondiente, seleccionando su [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo '''<code>.ggt</code>''']].}}
<h4>Modificando la [[Propias|''propia'' herramienta]]</h4>
+
<h3>Modificando la [[Propias|''propia'' herramienta]]</h3>
 
GeoGebra despliega una nueva ventana cuando se opta por modificar la herramienta.<br>Allí se listan los objetos de entrada, libres. Al completar los cambios, se puede guardar la herramienta con la opción [[Image:Menu_Create_Tool.png]] correspondiente del [[Menú de Herramientas]] y anotando el antiguo nombre para reescribir la anterior.
 
GeoGebra despliega una nueva ventana cuando se opta por modificar la herramienta.<br>Allí se listan los objetos de entrada, libres. Al completar los cambios, se puede guardar la herramienta con la opción [[Image:Menu_Create_Tool.png]] correspondiente del [[Menú de Herramientas]] y anotando el antiguo nombre para reescribir la anterior.
 
:{{Note|1=Para reescribir una herramienta ya empleada, debe conservarse el mismo tipo de objetos de entrada y de los de salida.}}
 
:{{Note|1=Para reescribir una herramienta ya empleada, debe conservarse el mismo tipo de objetos de entrada y de los de salida.}}
 
:{{OJo|1=Es importante tener en cuenta que la apertura de un [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo “ggt” ]]-  (GGT) es la extensión de los archivos que almacenan herramientas de usuarios - no modifica la construcción en curso como sí lo hace abrir un  [[Referencia:Formato Archivo#.ggb - Hoja Dinámica GeoGebra|archivo “ggb” (GGB).]]}}<hr>
 
:{{OJo|1=Es importante tener en cuenta que la apertura de un [[Referencia:Formato Archivo#.ggt - Herramientas de GeoGebra|archivo “ggt” ]]-  (GGT) es la extensión de los archivos que almacenan herramientas de usuarios - no modifica la construcción en curso como sí lo hace abrir un  [[Referencia:Formato Archivo#.ggb - Hoja Dinámica GeoGebra|archivo “ggb” (GGB).]]}}<hr>
 
:{{Note|1=Ver también, la sección [[Tutorial:Preparando Herramientas Propias en la Barra#Preparación de Herramientas Propias|correspondiente]] en el tutorial de [http://www.centrobabbage.com ''Centro Babbage''],  [[Tutorial:Preparando Herramientas Propias en la Barra|Preparando Herramientas en la Barra]].}}
 
:{{Note|1=Ver también, la sección [[Tutorial:Preparando Herramientas Propias en la Barra#Preparación de Herramientas Propias|correspondiente]] en el tutorial de [http://www.centrobabbage.com ''Centro Babbage''],  [[Tutorial:Preparando Herramientas Propias en la Barra|Preparando Herramientas en la Barra]].}}

Revisión del 00:18 15 dic 2014

Desde el cuadro que despliega Menu Properties.png Gestión de Herramientas de ese menú, cualquier de las ya creadas se puede guardar, eliminar y/o recuperar para reutilizarla en otra construcción de GeoGebra.
Incluso se las puede compartir, sumándolas al repertorio de las enviadas e incluso disponibles en GeoGebra.

Recuperando herramientas de Archivo

Como se aprecia, toda herramienta ya almacenada en un archivo .ggt, desde este cuadro se puede:

  • someter a cambios como el de su icono, ayuda de sintaxis y nombre o solo el del comando asociado
  • indicarla, según se (des)tilde la casilla pertinente, como una efectivamente a Mostrar en la Barra de Herramientas, o no
    Gestion de Herramientas.PNG

Bulbgraph.pngAtención: Una herramienta creada y/o recuperada tiene asociado un comando que, aunque no se la muestre en la barra, sigue disponible y hasta referido cuando se despliega la lista de Todos los Comandos.
  • descartar completamente en tanto se la Borra.
Nota: Esta es una maniobra más definitiva que la de decidir si se incluye o no en la Barra.
  • guardar con un clic en el correspondiente botón Guarda como... para completar el almacenamiento con su nuevo nombre, icono, ayuda... etc.
Bulbgraph.pngAtención: Toda herramienta se almacena con extensión .ggt en un archivo de GeoGebra específico y diferente a los .ggb de las construcciones.
  • abrir en la ventana que presenta el boceto desde el que se la hubiera creado para habilitar su revisión
Nota: Toda herramienta almacenada también se Abre desde el menú correspondiente, seleccionando su archivo .ggt.

Modificando la propia herramienta

GeoGebra despliega una nueva ventana cuando se opta por modificar la herramienta.
Allí se listan los objetos de entrada, libres. Al completar los cambios, se puede guardar la herramienta con la opción Menu Create Tool.png correspondiente del Menú de Herramientas y anotando el antiguo nombre para reescribir la anterior.

Nota: Para reescribir una herramienta ya empleada, debe conservarse el mismo tipo de objetos de entrada y de los de salida.
Bulbgraph.pngAtención: Es importante tener en cuenta que la apertura de un archivo “ggt” - (GGT) es la extensión de los archivos que almacenan herramientas de usuarios - no modifica la construcción en curso como sí lo hace abrir un archivo “ggb” (GGB).

Nota: Ver también, la sección correspondiente en el tutorial de Centro Babbage, Preparando Herramientas en la Barra.
© 2021 International GeoGebra Institute