Diferencia entre revisiones de «Exportar como Página Web html»

De GeoGebra Manual
Saltar a: navegación, buscar
m (Página redirigida a Exporta como página web (html))
 
(No se muestran 12 ediciones intermedias de otro usuario)
Línea 1: Línea 1:
<noinclude>{{Manual Page|version=4.2}}</noinclude>{{Interfaz_Gráfica|medio}}<small><center>{{Attention|1=Ver sección [[Caja de Diálogo de Hoja Dinámica a Exportar|Caja de Hoja a Exportar]].}}</center></small>
+
#REDIRECT[[Exporta como página web (html)]]
Para crear, a partir de archivos GeoGebra, páginas web interactivas, las llamadas '''Hojas Dinámicas''', basta con seleccionar la opción [[File:Text-html.png]] ''Hoja Dinámica como Página Web (html)'' del ítem '''Exporta''' del [[Menú Archivo]] y  proseguir.<br>La ventana de diálogo de Hojas Dinámicas presenta dos pestañas:
 
*[[File:export.png|14px]] Sube al ámbito de GeoGebra
 
*[[File:Export-html.png|14px]] Exporta como Página Web (html)<br>
 
 
 
===[[File:export.png|24px]] Sube al ámbito de GeoGebra===
 
Desde  esta pestaña se  puede ingresar...
 
*un título para la construcción
 
*un ''Texto previo''  como  breve descripción preliminar y uno ''Debajo de la Construcción'' como desafío o propuesta
 
... al completar esta información, basta pulsar {{KeyCode|Subir}} para que se sume al repertorio de [[GeoGebra]].
 
{{note|1=Para que sea posible subir un archivo a GeoGebra, se debe crear previamente una cuenta y/o una contraseña e ingresar con esa identificación.}}
 
===[[File:Export-html.png|24px]] Exporta como Página Web (html)===
 
Para crear un archivo de página '''<code>html</code>'''  en el equipo de trabajo, deben seguirse las indicaciones que aparecen detalladas a continuación:<br>
 
#Seleccionar la pestaña [[File:Export-html.png|23px]] '''Exporta como Página Web (html)'''  en la [[Caja de Diálogo de Hoja Dinámica a Exportar|''Caja de Diálogo'']] desplegada por la opción [[File:Export-html.png|16px]] ''Hoja Dinámica como Página Web'' desde el '''Exporta''' del [[Menú Archivo]]<br><h4>Pestaña General</h4>
 
#En la zona superior de la ventana de exportación, anotar los datos correspondientes a ''Título'', ''Autoría'' y ''Fecha'' de la Hoja Dinámica.<br>
 
#Añadir un ''Texto previo''  y uno ''Debajo de la Construcción'' en sendos espacios ofrecidos en la pestaña '''General'''.{{Note|1=Un enunciado inicial y una propuesta o desafío posterior suelen ser lo adecuado.}}<h4>Pestaña Avanzado</h4>'''[[File:Funcionalidad !.PNG|thumb|280px|right]]'''<br>
 
#Indicar las condiciones de '''''Funcionalidad''''' de la construcción dinámica (des)tildando las casillas de esa sección, en la pestaña '''Avanzado'''.{{Note|1=Esto habilita, por ejemplo, un icono de reinicio y otras alternativas de la interfaz de uso expuesta en el ''applet'' interactivo resultante.}}'''[[File:Interfaz I.PNG|thumb|220px|left]]'''<br>
 
#Establecer cuestiones de la '''''Interfaz de Uso'''''<br>Además de las dimensiones fijadas por la altura y el ancho, también se puede determinar si se cuenta o no...<br>- con la [[Barra de Herramientas]]<br>- con la posibilidad de guardar e imprimir.
 
#Indicar si la construcción va a incluirse de por sí en la página web directamente o si se abrirá con un ''clic'' sobre un botón.
 
<h4>Applet / Aplicación</h4>
 
El archivo HTML exportado, por ejemplo  <code>circular.html</code> puede apreciarse con cualquier navegador de Internet  Sea Mozilla, Internet Explorer, Safari u otros.
 
{{Note|1=Si la medida del ''applet'' excede las dimensiones de pantalla cuando la resolución es la estándar (1024 x 768), conviene redimensionarlo antes de exportarlo efectivamente como ''Hoja Dinámica''.}}
 
Para que el comportamiento de la construcción sea dinámico, el equipo de trabajo debe tener instalado Java.
 
{{Note|1=Se lo puede bajar gratuitamente desde http://www.java.com}}
 
Para trabajar sobre una Hoja Dinámica en uno de los equipos de una red, como la escolar, quien la administre debe asegurarse de contar con  Java adecuadamente instalado, incluyendo todo "plugin" pertinente para los buscadores correspondientes.
 
{{Notes|1=
 
*Para editar el texto de una Hoja Dinámica, basta con abrir el archivo HTML exportado con cualquier sistema de procesamiento de textos (por ejemplo. FrontPage, OpenOffice Writer). También puede editarse el ''applet'' de la Hoja Dinámica  abriendo el archivo GGB con GeoGebra y guardándolo después, con el mismo nombre.
 
*Ver [[Incrustando a CMS, VLE (Moodle - Ambiente de Enseñanza Virtual) y Wiki]] para mayores detalles sobre el modo de exportar aplicaciones de GeoGebra (''applets'') para estos sistemas de trabajo en línea.}}
 
===Ajustes Avanzados===
 
'''Funcionalidad''': 
 
*''Clic derecho habilitado, zoom y modalidades de edición de teclado'': Al tildar esta alternativa será posible acceder al menú contextual de los objetos de la [[Vista Gráfica]] y decidir si cada uno de ellos, por ejemplo, se va a [[Herramienta de Expone / Oculta Objeto|mostrar u ocultar]], su rótulo va a quedar o no expuesto, dejará o no [[Rastreo|rastro]], y otras alternativas de la [[Caja de Diálogo de Propiedades]]). Es posible también emplear las [[Teclas de Atajos|teclas de atajo]].
 
*''Activa Desplazamiento de Rótulos'': Cuando se tilda, es posible mover los rótulos de los puntos o de otros objetos.
 
*''Expone el icono de reinicio de construcción'': Pasa a quedar disponible, en la esquina superior derecha de la aplicación interactiva, un icono que permite reiniciar el boceto, representaciones gráficas y condiciones a su estado inicial.
 
*''Explorador para guiones JavaScript'': Al estar habilitados los guiones JavaScipt el explorador expone adecuadamente la construcción.
 
'''Interfaz de Uso''':
 
*''Expone la Barra de Menú'': La barra de menú aparece en el ''applet''  interactivo.
 
*''Habilita Guardar, Imprimir y Deshacer'': Es posible deshacer lo que se intenta sobre la construcción en marcha, imprimirla y guardarla. Como de este modo, se permite el acceso, a partir de la aplicación, al disco rígido o cualquier dispositivo de almacenamiento y a las impresoras, en cada ocasión se solicitará la confirmación previa para abrir tal aplicación para corroborar la confianza pertinente, por lo que estos accesos involucran (ver en [[Referencia:Parámetros Applet]], la mención a ''applets'' identificadas). 
 
*''Expone la Barra de Herramientas'': La barra de herramientas queda expuesta y se puede emplear cualquiera de las geométricas sobre la aplicación interactiva.
 
*''Expone Ayuda de Barra de Herramientas'': En conjunto con la Barra de Herramientas, se dispone de la Ayuda correspondiente al operar sobre la aplicación interactiva. Esta es una alternativa que promueve cierta autonomía en el aprendizaje operatorio básico que se precisa para trabajar con la aplicación, sobre todo la de geometría, y es un propósito que lleva  tildar esta opción.
 
*''Expone la Barra de Entrada'': El campo de entrada aparece en la zona inferior de la aplicación  interactiva permitiendo usar la entrada algebraica y hasta los comandos para profundizar las exploraciones.
 
*''Admite Reescalado'': Cuando está activa esta opción, el ''applet'' intentará re-escalar la construcción según el ''zoom'' del explorador, así como cambiar el tamaño del ''applet''. Esta opción se ignora en caso de haber múltiples [[vistas]] de la aplicación (applet) expuestas.
 
*''Ancho'' y ''Altura'': Permite establecer las dimensiones de la aplicación  interactiva. {{Note|1=<br>Si se reduce la medida de la aplicación, puede que zonas importantes de la hoja dinámica resulten ''invisibles'' cuando se vaya a operar con la aplicación.}} <hr>
 
*Inclusión de '''''Barras'''''. Las '''dimensiones''' deben cuidarse para que lo exportado refleje lo que se pretende. {{OJo|1=Si se incluye la [[Barra de Menú|Barra de Menúes]], la de [[Barra de Herramientas|Herramientas]] o la de [[Barra de Entrada|Entrada]] puede que resulte conveniente ajustar las dimensiones, el ancho y la altura de la aplicación.}}
 
 
 
'''Archivos''':
 
*'''Admite Uso fuera de línea (''offline'')''':  Crea no sólo el archivo html, sino también los '''<code>*.jar</code>''' correspondientes. {{Note|1=Es preciso habilitar esta opción para contar con la aplicación o ''applet'' aún sin conexión a http://geogebra.org.}}
 
*''Eliminar Cortes de Línea'': elimina los cortes de línea del código resultante. Esta maniobra, pese a redundar en una edición de código menos amigable, se requiere cuando se va a  incluir la aplicación en [http://wordpress.com WordPress].
 
*<big>''Desplegable de Archivo''</big>: Se puede elegir si el archivo a exportar será  html, MediaWiki, GoogleGadget o Moodle.
 
*''Unico Archivo'': Se creará una página web dinámica usando un único ''archivo '''.html'''''.
 
*''Único Archivo (Pestañas)'': Más de una hoja dinámica podrá desplegarse con el explorador, para pasar de una a otra se empelarán las correspondientes pestañas. Esta maniobra crea algunos archivos adicionales (por ejemplo, Tabber.js y ggb.css) que se requieren ser copiados junto al '''.html'''.
 
*''Archivos Vinculados'': Crea hojas dinámicas vinculadas lo que se condice con varios archivos '''.html''' a ser copiados en conjunto. Esta maniobra deja, ademas, disponibles los botones {{KeyCode|Siguiente}} y {{KeyCode|Atrás}} para trabajar en más de una. {{OJo|1=Para crear varias aplicaciones interactivas es preciso producir más de una construcción usando el mismo mecanismo ''Archivo'' - ''Nueva Ventana'' o {{KeyCode|Ctrl+N}}.}}
 
{{warning|1=La cantidad de datos que es necesario cargar para la ejecución de la aplicación o ''applet'' y su ''peso'' en ''bytes'' se reduce '''significativamente''' (400kB a 1300kB, cuando se emplea geogebra.org como código base - ''codebase ''-) si se contemplan las medidas que se listan a continuación.}}
 
<hr>'''''Peso''''' de los archivos como limitante
 
'''Condiciones para acotar el ''peso'' de los datos'''
 
*Todo se reduce a la [[Vista Gráfica]], evitando la [[Vista de Hoja de Cálculo|Hoja de Cálculo]], ni [[Vista Algebraica]].
 
*No se incluye ni la barra de menúes ni la de entrada, etc.
 
*Se controla el uso del Buscador para Guiones de Java - ''JavaScript''<hr>
 
;Respecto de los [[Comandos|comandos]]
 
Se hace viable la exportación completa y/o se reduce el ''peso'' cuando '''no''' se emplea comando alguno de los que requieren cálculo simbólico...
 
*Los propios de la [[Vista Algebraica CAS|Vista CAS]] como f'(x), [[Comando Integral|Integral]], [[Comando Tangente|Tangente]], [[Comando Desarrolla|Desarrolla]] u
 
*Otros, propios de [[Comandos Específicos CAS (Cálculo Avanzado)|CAS (Cálculo Avanzado)]] o [[Comandos Exclusivos CAS (Cálculo Avanzado)|exclusivos]]
 
*Los de [[Comandos de Matemática Discreta|Matemática Discreta]].
 
:<hr><small>
 
{{Attention|1=Puede estar inhabilitada temporalmente la exportación en las versiones más recientes de GeoGebra.<br>En los ámbitos '''3D'''(''imensionales'') es de por sí, inviable.}}</small>
 

Revisión actual del 15:13 22 sep 2015

© 2021 International GeoGebra Institute