Werkzeug erstellen - Dialog: Unterschied zwischen den Versionen

Aus GeoGebra Manual
Wechseln zu: Navigation, Suche
K (Textersetzung - „version=4.0“ durch „version=4.2“)
(added note and icons)
 
Zeile 1: Zeile 1:
<noinclude>{{Manual Page|version=4.2}}</noinclude>{{gui|dialog}}
+
<noinclude>{{Manual Page|version=5.0}}</noinclude>{{gui|dialog}}
Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü ''Werkzeuge'' die Option [[Image:Menu Create Tool.png]] ''Neues Werkzeug erstellen...''. Im erscheinenden Dialog-Fenster können Sie anschließend die drei Karten ''Ausgabe-Objekte'', ''Eingabe-Objekte'', und ''Name & Symbo''l für Ihr neues Werkzeug ausfüllen.
+
Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü [[File:Menu-tools.svg|link=|18px]] [[Werkzeuge-Menü|Werkzeuge]] die Option [[File:Menu-tools-new.svg|link=|18px]] ''Neues Werkzeug erstellen...''. Im erscheinenden Dialog-Fenster können Sie anschließend die drei Karten ''Ausgabe-Objekte'', ''Eingabe-Objekte'', und ''Name & Symbol'' für Ihr neues Werkzeug ausfüllen.
  
{{example|Erzeugen Sie ein Quadrat-Werkzeug, das durch zweimaliges Klicken auf das Zeichenblatt ([[Grafik-Ansicht]]) oder auf zwei existierende Punkte ein Quadrat erstellt.}}
+
{{example|Erzeugen Sie ein Quadrat-Werkzeug, das durch zweimaliges Klicken in die [[File:Menu view graphics.svg|link=|16px]] [[Grafik-Ansicht]] oder auf zwei existierende Punkte ein Quadrat erstellt.}}
  
* Konstruieren Sie zuerst ein Quadrat. Beginnen Sie dazu mit zwei Punkten A und B. Konstruieren Sie danach die anderen beiden Eckpunkte und verbinden Sie alle vier Eckpunkte mithilfe des Werkzeugs [[Image:Tool Polygon.gif]] [[Vieleck_(Werkzeug)|Vieleck]] zu einem Quadrat Vieleck1.
+
* Konstruieren Sie zuerst ein Quadrat. Beginnen Sie dazu mit zwei Punkten A und B. Konstruieren Sie danach die anderen beiden Eckpunkte und verbinden Sie alle vier Eckpunkte mithilfe des Werkzeugs [[File:Mode polygon.svg|link=|22px]] [[Vieleck_(Werkzeug)|Vieleck]] zu einem Quadrat Vieleck1.
* Wählen Sie die Option [[Image:Menu Create Tool.png]] ''Neues Werkzeug erstellen'' im Menü Werkzeuge.
+
* Wählen Sie die Option [[File:Menu-tools-new.svg|link=|18px]] ''Neues Werkzeug erstellen'' im Menü [[File:Menu-tools.svg|link=|18px]] ''Werkzeuge''.
 
* Geben Sie die Ausgabe-Objekte an: Klicken Sie dazu einfach auf das Quadrat oder wählen Sie dessen Namen aus der Liste aus. Geben Sie auch die Seiten des Quadrats als Ausgabe-Objekte an.
 
* Geben Sie die Ausgabe-Objekte an: Klicken Sie dazu einfach auf das Quadrat oder wählen Sie dessen Namen aus der Liste aus. Geben Sie auch die Seiten des Quadrats als Ausgabe-Objekte an.
* Geben Sie die Eingabe-Objekte an: Basierend auf den von Ihnen angegebenen Ausgabe-Objekten wählt GeoGebra die entsprechenden Eingabe-Objekte automatisch aus (in diesem Fall die Punkte A und B). Sie können diese Auswahl von Objekten jederzeit verändern, indem Sie direkt auf die Objekte in der Grafik-Ansicht klicken oder deren Namen aus der Liste auswählen.
+
* Geben Sie die Eingabe-Objekte an: Basierend auf den von Ihnen angegebenen Ausgabe-Objekten wählt GeoGebra die entsprechenden Eingabe-Objekte automatisch aus (in diesem Fall die Punkte A und B). Sie können diese Auswahl von Objekten jederzeit verändern, indem Sie direkt auf die Objekte in Ihrer Konstruktion klicken oder deren Namen aus der Liste auswählen.
 
* Geben Sie einen Namen und einen Befehlsnamen für Ihr neues Werkzeug ein.
 
* Geben Sie einen Namen und einen Befehlsnamen für Ihr neues Werkzeug ein.
 
{{Note|Der Name des Werkzeugs erscheint später in der [[Werkzeugleiste]], während der Befehlsname in der [[Eingabezeile]] verwendet werden kann.}}
 
{{Note|Der Name des Werkzeugs erscheint später in der [[Werkzeugleiste]], während der Befehlsname in der [[Eingabezeile]] verwendet werden kann.}}
Zeile 13: Zeile 13:
 
* Sie können auch einen Text für die [[Werkzeugleiste#Hilfe in der Werkzeugleiste|Hilfe in der Werkzeugleiste]] eingeben.
 
* Sie können auch einen Text für die [[Werkzeugleiste#Hilfe in der Werkzeugleiste|Hilfe in der Werkzeugleiste]] eingeben.
 
* Weiters können Sie ein Bild für die Schaltfläche Ihres Werkzeugs in der Werkzeugleiste auswählen. GeoGebra verändert die Größe des Bildes automatisch, um es der Schaltfläche anzupassen.
 
* Weiters können Sie ein Bild für die Schaltfläche Ihres Werkzeugs in der Werkzeugleiste auswählen. GeoGebra verändert die Größe des Bildes automatisch, um es der Schaltfläche anzupassen.
 +
 +
{{note|1=
 +
Die Ausgabe-Objekte des Werkzeugs sind nicht verschiebbar, selbst wenn sie als <code>[[Punkt (Befehl)|Punkt]][<Pfad>]</code> definiert wurden. Falls Sie verschiebbare Ausgabe-Objekte brauchen, können Sie eine Liste von Befehlen definieren und diese dann mit dem Befehl [[Ausführen (Befehl)|Ausführen]] verwenden.}}

Aktuelle Version vom 9. Oktober 2015, 10:47 Uhr

Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü Menu-tools.svg Werkzeuge die Option Menu-tools-new.svg Neues Werkzeug erstellen.... Im erscheinenden Dialog-Fenster können Sie anschließend die drei Karten Ausgabe-Objekte, Eingabe-Objekte, und Name & Symbol für Ihr neues Werkzeug ausfüllen.

Beispiel: Erzeugen Sie ein Quadrat-Werkzeug, das durch zweimaliges Klicken in die Menu view graphics.svg Grafik-Ansicht oder auf zwei existierende Punkte ein Quadrat erstellt.
  • Konstruieren Sie zuerst ein Quadrat. Beginnen Sie dazu mit zwei Punkten A und B. Konstruieren Sie danach die anderen beiden Eckpunkte und verbinden Sie alle vier Eckpunkte mithilfe des Werkzeugs Mode polygon.svg Vieleck zu einem Quadrat Vieleck1.
  • Wählen Sie die Option Menu-tools-new.svg Neues Werkzeug erstellen im Menü Menu-tools.svg Werkzeuge.
  • Geben Sie die Ausgabe-Objekte an: Klicken Sie dazu einfach auf das Quadrat oder wählen Sie dessen Namen aus der Liste aus. Geben Sie auch die Seiten des Quadrats als Ausgabe-Objekte an.
  • Geben Sie die Eingabe-Objekte an: Basierend auf den von Ihnen angegebenen Ausgabe-Objekten wählt GeoGebra die entsprechenden Eingabe-Objekte automatisch aus (in diesem Fall die Punkte A und B). Sie können diese Auswahl von Objekten jederzeit verändern, indem Sie direkt auf die Objekte in Ihrer Konstruktion klicken oder deren Namen aus der Liste auswählen.
  • Geben Sie einen Namen und einen Befehlsnamen für Ihr neues Werkzeug ein.
Anmerkung: Der Name des Werkzeugs erscheint später in der Werkzeugleiste, während der Befehlsname in der Eingabezeile verwendet werden kann.
  • Sie können auch einen Text für die Hilfe in der Werkzeugleiste eingeben.
  • Weiters können Sie ein Bild für die Schaltfläche Ihres Werkzeugs in der Werkzeugleiste auswählen. GeoGebra verändert die Größe des Bildes automatisch, um es der Schaltfläche anzupassen.
Anmerkung: Die Ausgabe-Objekte des Werkzeugs sind nicht verschiebbar, selbst wenn sie als Punkt[<Pfad>] definiert wurden. Falls Sie verschiebbare Ausgabe-Objekte brauchen, können Sie eine Liste von Befehlen definieren und diese dann mit dem Befehl Ausführen verwenden.
© 2021 International GeoGebra Institute