Konstruktionsprotokoll: Unterschied zwischen den Versionen

Aus GeoGebra Manual
Wechseln zu: Navigation, Suche
K (Textersetzung - „version=4.0“ durch „version=4.2“)
(update)
 
Zeile 1: Zeile 1:
<noinclude>{{Manual Page|version=4.2}}</noinclude>{{gui|dialog}}
+
<noinclude>{{Manual Page|version=5.0}}</noinclude>
 +
{{gui|dialog}}
 +
=='''GeoGebra Web und Tablet Apps Version'''==
  
Im Menü ''Ansicht'' kann durch Auswahl der Option ''Konstruktionsprotokoll'' das interaktive Konstruktionsprotokoll in einem neuen Fenster geöffnet werden. Diese Tabelle listet alle Konstruktionsschritte auf und bietet die Möglichkeit, eine vorbereitete GeoGebra Konstruktionen Schritt für Schritt mithilfe der [[Navigationsleiste]] abzuspielen.
+
Das interaktive [[File:Menu view construction protocol.svg|link=|16px]] '''Konstruktionsprotokoll''' kann im Menü [[File:Menu-view.svg|link=|16px]] [[Ansicht-Menü|Ansicht]] geöffnet werden. Das [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokoll'' ist eine Tabelle, die alle Konstruktionsschritte auflistet.
 +
Mithilfe der [[Navigationsleiste]] kann man weiters eine vorbereitete GeoGebra-Konstruktionen Schritt für Schritt abspielen lassen. Um sich die ''Navigationsleiste'' im unteren Bereich den GeoGebra-Fensters anzeigen zu lassen, wählen Sie die Option ''Navigationsleiste'' im Menü [[File:Menu-view.svg|link=|16px]] ''Ansicht''.
 +
 
 +
=='''GeoGebra Desktop Version'''==
 +
 
 +
Das interaktive [[File:Menu view construction protocol.svg|link=|16px]] '''Konstruktionsprotokoll''' kann im Menü ''Ansicht'' geöffnet werden. Das [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokoll'' ist eine Tabelle, die alle Konstruktionsschritte auflistet und es ermöglicht die Konstruktion Schritt für Schritt zu wiederholen.
 +
Mithilfe der [[Navigationsleiste]] kann man weiters eine vorbereitete GeoGebra-Konstruktionen Schritt für Schritt abspielen lassen. Um sich die ''Navigationsleiste'' im unteren Bereich den GeoGebra-Fensters anzeigen zu lassen, klicken Sie mit der rechten Maustaste in die [[File:Menu view graphics.svg|link=|16px]] [[Grafik-Ansicht]] und wählen Sie die Option ''Navigationsleiste'' im erscheinenden [[Kontext-Menü]] aus.
  
 
==Verwenden und Verändern des Konstruktionsprotokolls==
 
==Verwenden und Verändern des Konstruktionsprotokolls==
  
Mithilfe der Tastatur kann innerhalb des Konstruktionsprotokolls navigiert werden:
+
Mithilfe der Tastatur kann innerhalb des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' navigiert werden:
  
* Pfeiltaste ↑ (nach oben): Zum vorherigen Konstruktionsschritt
+
* Pfeiltaste {{KeyCode|}} (nach oben): Zum vorherigen Konstruktionsschritt
* Pfeiltaste ↓ (nach unten): Zum nächsten Konstruktionsschritt
+
* Pfeiltaste {{KeyCode|}} (nach unten): Zum nächsten Konstruktionsschritt
* Position1 Taste: Zum Anfang des Konstruktionsprotokolls
+
* {{KeyCode|Position1}}-Taste: Zum Anfang des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls''
* Ende Taste: Zum Ende des Konstruktionsprotokolls
+
* {{KeyCode|Ende}}-Taste: Zum Ende des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls''
* Entfernen Taste: Lösche den ausgewählten Konstruktionsschritt
+
* {{KeyCode|Entfernen}}-Taste: Lösche den ausgewählten Konstruktionsschritt
  
 
:{{Note| Das Löschen eines Konstruktionsschrittes/Objektes wirkt sich auch auf alle von diesem Schritt/Objekt abhängigen Objekte aus.}}
 
:{{Note| Das Löschen eines Konstruktionsschrittes/Objektes wirkt sich auch auf alle von diesem Schritt/Objekt abhängigen Objekte aus.}}
  
* Ein Doppel-Klick in eine Zeile des Konstruktionsprotokolls wählt den entsprechenden Konstruktionsschritt aus.
+
Sie können auch eine Maus zum Navigieren innerhalb des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' verwenden:
* Ein Doppel-Klick auf die Überschrift einer beliebigen Spalte bringt den Fokus zurück zum Anfang des Konstruktionsprotokolls.
+
 
* Ein Konstruktionsschritt kann durch Ziehen in eine andere Zeile des Konstruktionsprotokolls verschoben werden.
+
* Ein Doppel-Klick in eine Zeile des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' wählt den entsprechenden Konstruktionsschritt aus.
 +
* Ein Doppel-Klick auf die Überschrift einer beliebigen Spalte bringt den Fokus zurück zum Anfang des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls''.
 +
* Ein Konstruktionsschritt kann durch Ziehen in eine andere Zeile des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' verschoben werden.
 
{{Note| Wegen der Abhängigkeitsbeziehungen zwischen verschiedenen Objekten ist es nicht immer möglich, einen Konstruktionsschritt zu verschieben.}}
 
{{Note| Wegen der Abhängigkeitsbeziehungen zwischen verschiedenen Objekten ist es nicht immer möglich, einen Konstruktionsschritt zu verschieben.}}
* Ein Rechts-Klick in eine Zeile des Konstruktionsprotokolls öffnet das Kontext-Menü für das entsprechende Objekt.
+
* Ein Rechts-Klick in eine Zeile des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' öffnet das ''Kontext-Menü'' für das entsprechende Objekt.
{{Note|Neue Konstruktionsschritte können an jeder beliebigen Position des Konstruktionsprotokolls eingefügt werden: Wählen Sie jenen Konstruktionsschritt aus, unterhalb dessen der neue Schritt eingefügt werden soll. Lassen Sie das Konstruktionsprotokoll-Fenster offen während Sie ein neues Objekt erzeugen. Dadurch wird der neue Konstruktionsschritt unterhalb der ausgewählten Zeile in das Konstruktionsprotokoll eingefügt.}}
+
 
 +
{{Note|Neue Konstruktionsschritte können an jeder beliebigen Position des Konstruktionsprotokolls eingefügt werden: Wählen Sie jenen Konstruktionsschritt aus, unterhalb dessen der neue Schritt eingefügt werden soll. Lassen Sie das Konstruktionsprotokoll-Fenster offen während Sie ein neues Objekt erzeugen. Dadurch wird der neue Konstruktionsschritt unterhalb der ausgewählten Zeile in das [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokoll'' eingefügt.}}
  
 +
Wählen Sie eine der aufgelisteten Optionen, nachdem Sie das links äußere Symbol in der Konstruktionsprotokoll-Werkzeugleiste ausgewählt haben, um zu entscheiden welche Informationen bezüglich der Konstruktion angezeigt werden sollen.
 
Nach dem Einblenden der Spalte Haltepunkt können einzelne Konstruktionsschritte mithilfe der entsprechenden Kontrollkästchen als „Haltepunkte“ definiert werden. Dadurch können Gruppen von Konstruktionsschritten erzeugt werden, welche beim Durchspielen der Konstruktion mithilfe der [[Navigationsleiste]] gemeinsam ein- oder ausgeblendet werden (z. B. die Eckpunkte, Seiten und Fläche eines Dreiecks).
 
Nach dem Einblenden der Spalte Haltepunkt können einzelne Konstruktionsschritte mithilfe der entsprechenden Kontrollkästchen als „Haltepunkte“ definiert werden. Dadurch können Gruppen von Konstruktionsschritten erzeugt werden, welche beim Durchspielen der Konstruktion mithilfe der [[Navigationsleiste]] gemeinsam ein- oder ausgeblendet werden (z. B. die Eckpunkte, Seiten und Fläche eines Dreiecks).
  
{{Note| In der ''Gestaltungsleiste'' des Konstruktionsprotokoll-Fensters können zusätzliche Spalten des Protokolls ein- und ausgeblendet werden  (z. B. Name, Definition, Befehl, Algebra, Haltepunkt).}}
 
  
 
==Das Konstruktionsprotokoll als Webseite exportieren==
 
==Das Konstruktionsprotokoll als Webseite exportieren==
  
In GeoGebra kann das Konstruktionsprotokoll als Webseite exportiert werden. Nach einblenden des Konstruktionsprotokolls (Menü Ansicht) kann das Menü Datei des Konstruktionsprotokoll-Fensters geöffnet und die Option Export als Webseite (html)... ausgewählt werden.  
+
In der GeoGebra Desktop Version kann das [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokoll'' als Webseite exportiert werden. Wählen Sie dazu nach dem Öffnen des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' (Menü ''Ansicht'') das dritte Symbol in der Konstruktionsprotokoll-Werkzeugleiste (Option ''Export als Webseite'').  
  
Im Export-Fenster des Konstruktionsprotokolls können Sie Titel, Autor und Datum der Konstruktion eingeben. Zusätzlich kann ausgewählt werden, ob ein Bild der [[Grafik-Ansicht]], oder ein Bild der [[Algebra-Ansicht]] und [[Grafik-Ansicht]] auf der Webseite angezeigt werden sollen und ob das Konstruktionsprotokoll in Farbe dargestellt werden soll (d.h. die Zeilen des Konstruktionsprotokolls sind farblich den entsprechenden Objekten angepasst).
+
Im Export-Fenster des [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokolls'' können Sie Titel, Autor und Datum der Konstruktion eingeben. Zusätzlich kann ausgewählt werden, ob ein Bild der [[File:Menu view graphics.svg|link=|16px]] ''Grafik-Ansicht'' und ein Bild der [[File:Menu view algebra.svg|link=|16px]] [[Algebra-Ansicht]] auf der Webseite angezeigt werden sollen und ob das [[File:Menu view construction protocol.svg|link=|16px]] ''Konstruktionsprotokoll'' in Farbe dargestellt werden soll (d.h. die Zeilen des Konstruktionsprotokolls sind farblich den entsprechenden Objekten angepasst).
  
 
:{{Note| Das exportierte html-Dokument kann mit jedem Internet-Browser geöffnet (z. B. Firefox, Internet Explorer, Safari) und mit vielen Textverarbeitungs-Programmen editiert werden (z. B. OpenOffice Writer).}}
 
:{{Note| Das exportierte html-Dokument kann mit jedem Internet-Browser geöffnet (z. B. Firefox, Internet Explorer, Safari) und mit vielen Textverarbeitungs-Programmen editiert werden (z. B. OpenOffice Writer).}}

Aktuelle Version vom 6. November 2015, 16:08 Uhr


GeoGebra Web und Tablet Apps Version

Das interaktive Menu view construction protocol.svg Konstruktionsprotokoll kann im Menü Menu-view.svg Ansicht geöffnet werden. Das Menu view construction protocol.svg Konstruktionsprotokoll ist eine Tabelle, die alle Konstruktionsschritte auflistet. Mithilfe der Navigationsleiste kann man weiters eine vorbereitete GeoGebra-Konstruktionen Schritt für Schritt abspielen lassen. Um sich die Navigationsleiste im unteren Bereich den GeoGebra-Fensters anzeigen zu lassen, wählen Sie die Option Navigationsleiste im Menü Menu-view.svg Ansicht.

GeoGebra Desktop Version

Das interaktive Menu view construction protocol.svg Konstruktionsprotokoll kann im Menü Ansicht geöffnet werden. Das Menu view construction protocol.svg Konstruktionsprotokoll ist eine Tabelle, die alle Konstruktionsschritte auflistet und es ermöglicht die Konstruktion Schritt für Schritt zu wiederholen. Mithilfe der Navigationsleiste kann man weiters eine vorbereitete GeoGebra-Konstruktionen Schritt für Schritt abspielen lassen. Um sich die Navigationsleiste im unteren Bereich den GeoGebra-Fensters anzeigen zu lassen, klicken Sie mit der rechten Maustaste in die Menu view graphics.svg Grafik-Ansicht und wählen Sie die Option Navigationsleiste im erscheinenden Kontext-Menü aus.

Verwenden und Verändern des Konstruktionsprotokolls

Mithilfe der Tastatur kann innerhalb des Menu view construction protocol.svg Konstruktionsprotokolls navigiert werden:

  • Pfeiltaste (nach oben): Zum vorherigen Konstruktionsschritt
  • Pfeiltaste (nach unten): Zum nächsten Konstruktionsschritt
  • Position1-Taste: Zum Anfang des Menu view construction protocol.svg Konstruktionsprotokolls
  • Ende-Taste: Zum Ende des Menu view construction protocol.svg Konstruktionsprotokolls
  • Entfernen-Taste: Lösche den ausgewählten Konstruktionsschritt
Anmerkung: Das Löschen eines Konstruktionsschrittes/Objektes wirkt sich auch auf alle von diesem Schritt/Objekt abhängigen Objekte aus.

Sie können auch eine Maus zum Navigieren innerhalb des Menu view construction protocol.svg Konstruktionsprotokolls verwenden:

  • Ein Doppel-Klick in eine Zeile des Menu view construction protocol.svg Konstruktionsprotokolls wählt den entsprechenden Konstruktionsschritt aus.
  • Ein Doppel-Klick auf die Überschrift einer beliebigen Spalte bringt den Fokus zurück zum Anfang des Menu view construction protocol.svg Konstruktionsprotokolls.
  • Ein Konstruktionsschritt kann durch Ziehen in eine andere Zeile des Menu view construction protocol.svg Konstruktionsprotokolls verschoben werden.
Anmerkung: Wegen der Abhängigkeitsbeziehungen zwischen verschiedenen Objekten ist es nicht immer möglich, einen Konstruktionsschritt zu verschieben.
  • Ein Rechts-Klick in eine Zeile des Menu view construction protocol.svg Konstruktionsprotokolls öffnet das Kontext-Menü für das entsprechende Objekt.
Anmerkung: Neue Konstruktionsschritte können an jeder beliebigen Position des Konstruktionsprotokolls eingefügt werden: Wählen Sie jenen Konstruktionsschritt aus, unterhalb dessen der neue Schritt eingefügt werden soll. Lassen Sie das Konstruktionsprotokoll-Fenster offen während Sie ein neues Objekt erzeugen. Dadurch wird der neue Konstruktionsschritt unterhalb der ausgewählten Zeile in das Menu view construction protocol.svg Konstruktionsprotokoll eingefügt.

Wählen Sie eine der aufgelisteten Optionen, nachdem Sie das links äußere Symbol in der Konstruktionsprotokoll-Werkzeugleiste ausgewählt haben, um zu entscheiden welche Informationen bezüglich der Konstruktion angezeigt werden sollen. Nach dem Einblenden der Spalte Haltepunkt können einzelne Konstruktionsschritte mithilfe der entsprechenden Kontrollkästchen als „Haltepunkte“ definiert werden. Dadurch können Gruppen von Konstruktionsschritten erzeugt werden, welche beim Durchspielen der Konstruktion mithilfe der Navigationsleiste gemeinsam ein- oder ausgeblendet werden (z. B. die Eckpunkte, Seiten und Fläche eines Dreiecks).


Das Konstruktionsprotokoll als Webseite exportieren

In der GeoGebra Desktop Version kann das Menu view construction protocol.svg Konstruktionsprotokoll als Webseite exportiert werden. Wählen Sie dazu nach dem Öffnen des Menu view construction protocol.svg Konstruktionsprotokolls (Menü Ansicht) das dritte Symbol in der Konstruktionsprotokoll-Werkzeugleiste (Option Export als Webseite).

Im Export-Fenster des Menu view construction protocol.svg Konstruktionsprotokolls können Sie Titel, Autor und Datum der Konstruktion eingeben. Zusätzlich kann ausgewählt werden, ob ein Bild der Menu view graphics.svg Grafik-Ansicht und ein Bild der Menu view algebra.svg Algebra-Ansicht auf der Webseite angezeigt werden sollen und ob das Menu view construction protocol.svg Konstruktionsprotokoll in Farbe dargestellt werden soll (d.h. die Zeilen des Konstruktionsprotokolls sind farblich den entsprechenden Objekten angepasst).

Anmerkung: Das exportierte html-Dokument kann mit jedem Internet-Browser geöffnet (z. B. Firefox, Internet Explorer, Safari) und mit vielen Textverarbeitungs-Programmen editiert werden (z. B. OpenOffice Writer).
© 2020 International GeoGebra Institute