Benutzerdefinierte Werkzeuge

Aus GeoGebra Manual
Wechseln zu: Navigation, Suche

Dieser Text ist noch nicht übersetzt. Sie können das englische Original en:Manual:Custom Tools lesen. Wenn sie Übersetzer-Rechte haben, können sie den Text ergänzen.

In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit der Maus als auch als Befehl in der Eingabezeile verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.

Ein benutzerdefiniertes Werkzeug erstellen

Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü Werkzeuge die Option Neues Werkzeug erstellen. Im erscheinenden Dialog-Fenster können Sie anschließend die drei Karten Ausgabe-Objekte, Eingabe-Objekte, und Name & Symbol für Ihr neues Werkzeug ausfüllen.

Ein benutzerdefiniertes Werkzeug speichern

Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Klicken Sie dazu im Menü Werkzeuge auf die Option Werkzeuge verwalten. Wählen Sie anschließend das zu speichernde Werkzeug aus der Liste im erscheinenden Dialog aus und klicken Sie auf die Schaltfläche Speichern unter um das Werkzeug als GeoGebra-Werkzeug-Datei (Dateiname endet mit .ggt) auf Ihrem Computer zu speichern.

Anmerkung: Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.

Accessing custom tools

If you open a new GeoGebra interface using item New from the File menu, after you created a custom tool, it will still be part of the GeoGebra Toolbar. However, if you open a new GeoGebra window (item Menu New.png New Window from the File Menu), or open GeoGebra on another day, your custom tools won’t be part of the Toolbar any more.

There are different ways of making sure that your user defined tools are displayed in the Toolbar of a new GeoGebra window:

After creating a new user defined tool you can save your settings using item Menu Save.png Save Settings from the Options Menu. From now on, your customized tool will be part of the GeoGebra Toolbar.

Anmerkung: You can remove the custom tool from the Toolbar after opening item Customize Toolbar… from the Tools Menu. Then, select your custom tool from the list of tools on the left hand side of the appearing dialog window and click button Remove. Don’t forget to save your settings after removing the custom tool.

Importing custom tools

After saving your custom tool on your computer (as a GGT file), you can import it into a new GeoGebra window at any time. Just select item Menu Open.png Open from the File Menu and open the file of your custom tool.

Anmerkung:
  • Opening a GeoGebra tool file (GGT) in GeoGebra doesn’t affect your current construction. It only makes this tool part of the current GeoGebra Toolbar.
  • You can also load GGT file by dragging it from file manager and droping into GeoGebra window.
© 2021 International GeoGebra Institute