Benutzerdefinierte Werkzeuge: Unterschied zwischen den Versionen

Aus GeoGebra Manual
Wechseln zu: Navigation, Suche
K
 
(4 dazwischenliegende Versionen von 3 Benutzern werden nicht angezeigt)
Zeile 1: Zeile 1:
<noinclude>{{Manual Page|version=4.0}}</noinclude>{{tool|type=custom|name=Benutzerdefinierte Werkzeuge}}
+
<noinclude>{{Manual Page|version=5.0}}</noinclude>
 +
{{tool|type=custom|name=Benutzerdefinierte Werkzeuge}}
  
In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit der Maus als auch als Befehl in der [[Eingabezeile]] verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.
+
 
 +
In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit einem Zeigegerät als auch als Befehl in der [[Eingabezeile]] verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.
 +
{{note|1=
 +
Objekte, die von solchen benutzerdefinierten Werkzeugen erstellt werden, können nicht bewegt werden (z.B. durch Ziehen mit der Maus), auch wenn sie als <code>[[Punkt (Befehl)|Punkt]][<Pfad>]</code> definiert wurden. Falls Sie jedoch beweglichen Objekte haben möchten, können Sie alternativ eine Liste von Befehlen definieren und diese mit dem Befehl [[Ausführen (Befehl)|Ausführen]] verwenden.}}
  
 
==Ein benutzerdefiniertes Werkzeug erstellen==
 
==Ein benutzerdefiniertes Werkzeug erstellen==
Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü [[Werkzeuge-Menü|Werkzeuge]] die Option Neues Werkzeug erstellen. Im erscheinenden [[Werkzeug erstellen - Dialog|Dialog-Fenster]] können Sie anschließend die drei Karten Ausgabe-Objekte, Eingabe-Objekte, und Name & Symbol für Ihr neues Werkzeug ausfüllen.
+
Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü [[File:Menu-tools.svg|link=|16px]] [[Werkzeuge-Menü|Werkzeuge]] die Option [[File:Menu-tools-new.svg|link=|16px]] [[Werkzeug erstellen - Dialog|Neues Werkzeug erstellen]].
  
 
==Ein benutzerdefiniertes Werkzeug speichern==
 
==Ein benutzerdefiniertes Werkzeug speichern==
Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Klicken Sie dazu im Menü [[Werkzeuge-Menü|Werkzeuge]] auf die Option Werkzeuge verwalten. Wählen Sie anschließend das zu speichernde Werkzeug aus der Liste im erscheinenden [[Werkzeugleiste anpassen - Dialog|Dialog-Fenster]] aus und klicken Sie auf die Schaltfläche Speichern unter um das Werkzeug als GeoGebra-Werkzeug-Datei auf Ihrem Computer zu speichern.
+
Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Wählen Sie dazu im Menü [[File:Menu-tools.svg|link=|16px]] [[Werkzeuge-Menü|Werkzeuge]] die Option [[File:Menu-tools.svg|link=|16px]] ''Werkzeuge verwalten'' aus.
  
 
{{note|Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.}}
 
{{note|Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.}}
  
 
==Ein benutzerdefiniertes Werkzeug abrufen==
 
==Ein benutzerdefiniertes Werkzeug abrufen==
Wenn Sie eine neue GeoGebra-Oberfläche öffnen (Menü Datei – Neu) nachdem Sie ein benutzerdefiniertes Werkzeug erstellt haben, so bleibt dieses Werkzeug in der Werkzeugleiste erhalten. Wenn Sie jedoch ein neues GeoGebra-Fenster öffnen (Menü Datei – [[Image:Menu New.png]] Neues Fenster), oder wenn Sie GeoGebra schließen und später wieder öffnen, so verschwindet Ihr benutzerdefiniertes Werkzeug aus der Werkzeugleiste.
+
Wenn Sie eine neue GeoGebra-Oberfläche öffnen (Menü [[File:Menu-file.svg|link=|16px]] [[Datei-Menü|Datei]] [[File:Menu-file-new.svg|link=|16px]] ''Neu'') nachdem Sie ein benutzerdefiniertes Werkzeug erstellt haben, so bleibt dieses Werkzeug in der Werkzeugleiste erhalten. Wenn Sie jedoch ein neues GeoGebra-Fenster öffnen (Menü [[File:Menu-file.svg|link=|16px]] ''Datei'' – [[Image:Menu New.png]] Neues Fenster), oder wenn Sie GeoGebra schließen und später wieder öffnen, so verschwindet Ihr benutzerdefiniertes Werkzeug aus der Werkzeugleiste.
 +
 
 +
Es gibt verschiedene Wege um sicher zu gehen, dass Ihre benutzerdefinierten Werkzeuge in einem neuen GeoGebra-Fenster angezeigt werden:
 +
 
 +
*Nach dem Erstellen eines benutzerdefinierten Werkzeugs können Sie im Menü [[File:Menu-options.svg|link=|16px]] [[Einstellungen-Menü|Einstellungen]] die Option  [[File:Menu-file-save.svg|link=|16px]] ''Einstellungen speichern'' auswählen, um das neue Werkzeug zu einem permanenten Teil der [[Werkzeugleiste]] zu machen.
 +
:{{note|Sie können das benutzerdefinierte Werkzeug wieder aus der Werkzeugleiste entfernen, indem Sie im Menü [[File:Menu-tools.svg|link=|16px]] [[Werkzeuge-Menü|Werkzeuge]] die Option [[File:Menu-tools-customize.svg|link=|16px]] ''Werkzeugleiste anpassen'' öffnen. Wählen Sie danach das entsprechende Werkzeug aus der linken Liste der Werkzeuge im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche ''Entfernen'' (GeoGebra Desktop Version) bzw. ziehen Sie es auf die rechte Seite des Dialog-Fensters (GeoGebra Web und Tablet Apps Version). Vergessen Sie nicht, ihre Einstellungen nach dem Entfernen des benutzerdefinierten Werkzeugs nochmals zu speichern.}}
  
==Benutzerdefinierten Werkzeuge in die Werkzeugleiste aufnehmen==
+
==Ein benutzerdefiniertes Werkzeug importieren==
*Nach dem Erstellen eines benutzerdefinierten Werkzeugs können Sie im Menü [[Einstellungen-Menü|Einstellungen]] die Option  [[Image:Menu Save.png]] Einstellungen speichern auswählen, um das neue Werkzeug zu einem permanenten Teil der [[Werkzeugleiste]] zu machen.
+
*Nachdem Sie ihr benutzerdefiniertes Werkzeug auf Ihrem Computer (als .ggt-Datei) gespeichert haben, können Sie es jederzeit in ein neues GeoGebra-Fenster importieren. Wählen Sie dazu im Menü [[File:Menu-file.svg|link=|16px]] ''Datei'' die Option [[File:Menu-file-open.svg|link=|16px]] Öffnen und öffnen sie die entsprechende Datei.
{{note|Sie können das benutzerdefinierte Werkzeug wieder aus der Werkzeugleiste entfernen, indem Sie im Menü [[Werkzeuge-Menü|Werkzeuge]] die Option Werkzeugleiste anpassen öffnen. Wählen Sie danach das entsprechende Werkzeug aus der linken Liste der Werkzeuge im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche Entfernen. Vergessen Sie nicht, ihre Einstellungen nach dem Entfernen des benutzerdefinierten Werkzeugs nochmals zu speichern.}}
 
*Nachdem Sie ihr benutzerdefiniertes Werkzeug auf Ihrem Computer (als .ggt-Datei) gespeichert haben, können Sie es jederzeit in ein neues GeoGebra-Fenster importieren. Wählen Sie dazu im Menü [[Datei-Menü|Datei]] die Option [[Image:Menu Open.png]] Öffnen und öffnen sie die entsprechende Datei.
 
 
{{note|Das Öffnen einer GeoGebra-Werkzeug-Datei hat keinerlei Effekt auf die aktuelle Konstruktion und fügt das neue Werkzeug lediglich zur Werkzeugleiste hinzu.}}
 
{{note|Das Öffnen einer GeoGebra-Werkzeug-Datei hat keinerlei Effekt auf die aktuelle Konstruktion und fügt das neue Werkzeug lediglich zur Werkzeugleiste hinzu.}}
{{note|Sie können .ggt-Datein auch durch Ziehen aus dem Datei Manager in das GeoGebra Fenster einfügen.}}
+
{{note|Sie können .ggt-Datein auch durch Ziehen aus dem Datei-Manager in das GeoGebra-Fenster einfügen.}}
 
 
==[[Liste benutzerdefinierter Werkzeuge]]==
 
Hier finden Sie eine Liste von benutzerdefinierten Werkzeugen. Wenn Sie selbst Werkzeuge erstellt haben, können Sie diese (als ggt-Datei) hier hochladen.
 
 
__NOTOC__
 
__NOTOC__

Aktuelle Version vom 23. Oktober 2015, 12:19 Uhr



In GeoGebra können Sie benutzerdefinierte Werkzeuge erstellen, die auf existierenden Konstruktionen basieren. So erzeugte Werkzeuge können anschließend sowohl mit einem Zeigegerät als auch als Befehl in der Eingabezeile verwendet werden. Alle neu erstellten benutzerdefinierten Werkzeuge werden automatisch in Ihrer GeoGebra-Datei gespeichert.

Anmerkung: Objekte, die von solchen benutzerdefinierten Werkzeugen erstellt werden, können nicht bewegt werden (z.B. durch Ziehen mit der Maus), auch wenn sie als Punkt[<Pfad>] definiert wurden. Falls Sie jedoch beweglichen Objekte haben möchten, können Sie alternativ eine Liste von Befehlen definieren und diese mit dem Befehl Ausführen verwenden.

Ein benutzerdefiniertes Werkzeug erstellen

Nachdem Sie die entsprechende Konstruktion für Ihr Werkzeug erstellt haben, wählen Sie im Menü Menu-tools.svg Werkzeuge die Option Menu-tools-new.svg Neues Werkzeug erstellen.

Ein benutzerdefiniertes Werkzeug speichern

Wenn Sie Ihre Konstruktion als GeoGebra-Datei speichern, bleiben die benutzerdefinierten Werkzeuge automatisch darin erhalten. Sie können benutzerdefinierte Werkzeuge auch als eigene Datei speichern, um sie in anderen GeoGebra-Konstruktionen verwenden zu können. Wählen Sie dazu im Menü Menu-tools.svg Werkzeuge die Option Menu-tools.svg Werkzeuge verwalten aus.

Anmerkung: Benutzerdefinierte Werkzeuge werden als .ggt-Dateien gespeichert damit Sie diese von gewöhnlichen GeoGebra-Dateien (.ggb) unterscheiden können.

Ein benutzerdefiniertes Werkzeug abrufen

Wenn Sie eine neue GeoGebra-Oberfläche öffnen (Menü Menu-file.svg DateiMenu-file-new.svg Neu) nachdem Sie ein benutzerdefiniertes Werkzeug erstellt haben, so bleibt dieses Werkzeug in der Werkzeugleiste erhalten. Wenn Sie jedoch ein neues GeoGebra-Fenster öffnen (Menü Menu-file.svg DateiMenu New.png Neues Fenster), oder wenn Sie GeoGebra schließen und später wieder öffnen, so verschwindet Ihr benutzerdefiniertes Werkzeug aus der Werkzeugleiste.

Es gibt verschiedene Wege um sicher zu gehen, dass Ihre benutzerdefinierten Werkzeuge in einem neuen GeoGebra-Fenster angezeigt werden:

  • Nach dem Erstellen eines benutzerdefinierten Werkzeugs können Sie im Menü Menu-options.svg Einstellungen die Option Menu-file-save.svg Einstellungen speichern auswählen, um das neue Werkzeug zu einem permanenten Teil der Werkzeugleiste zu machen.
Anmerkung: Sie können das benutzerdefinierte Werkzeug wieder aus der Werkzeugleiste entfernen, indem Sie im Menü Menu-tools.svg Werkzeuge die Option Menu-tools-customize.svg Werkzeugleiste anpassen öffnen. Wählen Sie danach das entsprechende Werkzeug aus der linken Liste der Werkzeuge im erscheinenden Dialog-Fenster aus und klicken Sie auf die Schaltfläche Entfernen (GeoGebra Desktop Version) bzw. ziehen Sie es auf die rechte Seite des Dialog-Fensters (GeoGebra Web und Tablet Apps Version). Vergessen Sie nicht, ihre Einstellungen nach dem Entfernen des benutzerdefinierten Werkzeugs nochmals zu speichern.

Ein benutzerdefiniertes Werkzeug importieren

  • Nachdem Sie ihr benutzerdefiniertes Werkzeug auf Ihrem Computer (als .ggt-Datei) gespeichert haben, können Sie es jederzeit in ein neues GeoGebra-Fenster importieren. Wählen Sie dazu im Menü Menu-file.svg Datei die Option Menu-file-open.svg Öffnen und öffnen sie die entsprechende Datei.
Anmerkung: Das Öffnen einer GeoGebra-Werkzeug-Datei hat keinerlei Effekt auf die aktuelle Konstruktion und fügt das neue Werkzeug lediglich zur Werkzeugleiste hinzu.
Anmerkung: Sie können .ggt-Datein auch durch Ziehen aus dem Datei-Manager in das GeoGebra-Fenster einfügen.
© 2021 International GeoGebra Institute