Tutoriel:Nouveautés4.0

De GeoGebra Manual
Aller à : navigation, rechercher

(reprise en français d'un travail initié par Birgit et de mon article Vers4)


En construction --------------------------------------------------------------------Noël 13:58, 6 November 2010 (CET) --Noel Lambert 28 décembre 2011 à 15:00 (CET)


In 3.9.72 there are a few new transform syntaxes Translate[<Object>,<Point>] (not new, just Translate[A,(0,1)] is shorter than Translate[A,Vector[(0,1)]]

Dilate[<Object>,<Ratio>] (same as Dilate[<Object>,<Ratio>,(0,0)]

Reflect[<Object>,<Circle>] should works for objects like function, curve, line, for segments it returns bad result.

Shear[<Object>,<Line/Vector>,<Ratio>] + Stretch[<Object>,<Line/Vector>,<Ratio>] -- switched arguments order to be consistent with others, now these work with functions and segments

ApplyMatrix[<Matrix>,<Object>] should work with functions and segments.

Functions can be rotated, translated, enlarged.



Outil modifié

  • Point

permet maintenant de créer un point sur un côté d'un polygone


Nouveaux Outils

  • PointDansRégion

Permet de construire un point à l'intérieur d'un polygone, d'un cercle ou d'une ellipse

  • Attach / Detach Point
Presser <Alt> pour attacher un point à l'intérieur d'une forme (plutôt que sur les côtés)
  • Bouton
  • ChampTexte
  • Stylo

Dessiner un rectangle avec l'outil Déplacer pour écrire dans une zone sélectionnée de Graphique ou sélectionner une image existante (avant de sélectionner stylo) pour écrire par dessus. Le bouton droit de la souris agirait en tant que Gomme .

(* Palette graphique retiré)

  • PolygoneIndéformable[<Point libre>, ..., <Point libre> ]

Construit un polygone indéformable. En déplaçant le premier point, on déplace le polygone, en déplaçant le second on fait tourner le polygone.

  • LigneBrisée
  • Dynamic Text
  • Courbes implicites par ex. x^3 + y^2 = 1 sont dessinées dans Graphique.
  • Fonctions à plusieurs variables, par ex. f(x, y) = x^2 + y^2

Vous pouvez aussi vous en servir pour définir des fonctions à une seule variable par ex. g. g(x) = f(x, 2) ou des fonctions à plus de variables par ex. f(a,b,c)=a+b+c

Nouvelles Fonctionnalités

Fonctionnalités Générales

  • Exporter feuille: Option pour encapsuler le fichier ggb dans le fichier HTML (encodage en Base64, utilisant le paramètre 'ggbBase64' )
  • Export en 'GIFAnimé ' (actuellement clic droit sur un curseur. Ceci sera dirigé vers une fenêtre de dialogue)
  • L'outil Compas autorise maintenant de choisir d'abord un cercle puis un point comme centre
  • Option 'Entier' et 'Random' pour les curseurs
  • Fichier -> Ouvrir URL permet de charger des appliquettes en collant leur URL depuis un navigateur(extension .html ou .ggb). Ceci permet aussi d'ouvrir un fichier encapsulé dans une chaîne Base 64 ou une chaîne XML GeoGebra.
  • Option "Tracé d'intersection" pour les points d'intersection. Soit M un point d'intersection par ex de 2 cercles c1 et C2, avec cette option cochée vous pouvez ne pas afficher c1 et c2 mais subsisteront 2 petits arcs de cercle se coupant en M (pareil avec des droites)
  • Option InfoBulle (Propriétés -> Avancé) Oui/Non/Légende/Cellule suivante/Automatique (avant l'info bulle n'était active qui si Algèbre était ouverte)
  • Affichage amélioré des formules et matrices dans Tableur
  • Si une expression comme ab + 1 est validée, et si la variable ab n'est pas définie alors elle est automatiquement créée par ab = a* b si a et b sont des nombres, ou par ab=Distance[a,b] si a et b sont des points
  • LaTeX[matrice] et LaTeX[vecteur] ont un affichage amélioré
  • les fonctions csc, sec, cot, csch, sech, coth et leurs dérivées sont intégrées
  • Algèbre : vous pouvez maintenant utiliser Majuscule-clic pour une sélection multiple
  • Racine carrée et cubique, conjugué et argument d'un complexe sont définis

sqrt(3 + i), cbrt(3 + i), conjugate(3 + i), arg(3 + i)

  • Option "Importer Données" dans le menu contextuel du tableur
  • Les codes Windows sont utilisables dans les champs texte (par ex. Alt-0176 pour °) [pas pourMac OSX]
  • Possibilité d'utiliser les Unicode dans les expressions par ex. Eastern Arabic, Thai

Tous les systèmes de nombres cités ici (excepté Osmanya) sont supportés : http://en.wikipedia.org/wiki/Hindu%E2%80%93Arabic_numeral_system

  • La syntaxe a = a + 1 ou A = A + (1, 2) est maintenant utilisable pour les objets libres (utile pour les boutons)
  • Les pourcentages peuvent maintenant être utilisés par ex. a = 3.4%
  • Les nombres peuvent être affichés suivant les paramètres locaux (actuellement en Arabe, Tamil, Thai et Malayalam )
  • Possibilité d'utiliser des exposants de plus d'un caractère, par ex. y = x²², x⁻¹
  • Alt-moins donne maintenant un exposant "-" (et plus le signe +/-)
  • En Grec et Arabe, les points sont étiquetés dans l'alphabet local
  • Lien avec la grille fonctionne maintenant lorsqu'on déplace Polygones, Segments, Vecteurs etc (en utilisant le premier point).
  • Les polygones peuvent être créés à partir d'une liste de points par Polygone[liste].
  • Vous pouvez maintenant déplacer un côté d'un polygone
  • Meilleur rendu des expressions LaTeX (en utilisant JLaTeXMath)
  • Légendes pouvant utiliser LaTeX (entre $ $ ) (pour tous les objets, sauf Cases à cocher,ChampTextes et Boutons)
  • Dynamique "bascule objet/grille" quand on dessine un nouvel objet.
  • Ajustement automatique des rayons des angles visibles
  • Coloration des crochets de syntaxe dans le Champ de saisie etc.
  • Possibilité d'utiliser sin²(x), sin⁻¹(x)
  • Export vers Asymptote (coche dans Export PSTricks )
  • Anticipation pour les parallèles et perpendiculaires, et aussi pour les médiatrices et les bissectrices
  • Support pour sin²(x), sin³(x), sin⁻¹(x) pour saisir les fonctions
  • Support pour f(x) = sin²(x) pour l'affichage LaTex[f]
  • Les courbes peuvent maintenant être transformées par ex. Symétrie[Courbe[t^2, t^3, t, -1, 1], axeY]
  • Améliorations dans Graphique pour Intégrale,Pente, BoiteMoustaches, Barres, Histogramme
  • Épaisseur de tracé à 0 possible pour Intégrale, Pente, Barres, Histogramme, Angle
  • Le clavier est maintenant automatiquement actif sur les appliquettes
  • Textes dynamiques plus simples : a"texte"b équivaut à a+"texte"+b
  • Aide -> A propos -> Copier dans Presse Papiers copie des informations de débogage dans le presse papiers. Ceci peut vous permettre de recréer votre travail s'il y a eu un problème à l'enregistrement.

Fichier -> Pour insertion (Ctrl-Shift-M) copie seulement les balises de l'appliquette dans le presse-papiers, prêtes à être collées dans MediaWiki, Moodle etc

  • Options pour Légende :
    • %v pour afficher la valeur
    • %n pour afficher le nom
    • %x pour afficher l'abscisse (ou coefficient de x pour la droite d'équation a x + b y + c = 0)
    • %y pour afficher l'ordonnée (ou coefficient de y pour la droite d'équation a x + b y + c = 0)
    • %z pour afficher la cote ( pour GGb3D) (ou terme constant pour la droite d'équation a x + b y + c = 0)
  • Custom Tools can now have angles, integrals, lower/upper sums, histograms, boxplots and barcharts as an output.
* Custom Tools with Numeric and Angle inputs as first input can be now used by just clicking in the Graphics View to activate the dialog.
* Trace pour Polygones, Listes et Lieux (utile par ex pour RésolEquaDiff[x + y, y² - 1, x(A), y(A), 5, 0.05] )
* Right-click with multiple objects selected now opens a menu, not Object Properties
* Popup chooser when multiple objects are clicked removed.
* Texts created in the Input Bar are now put in the middle of the Graphics View (not at the origin)
* Texts and Loci now visible in the Algebra View (Auxiliary by default)
* Option in the Style Bar for the Algebra View to list objects by type
* Curseur de bornes et d'incrément dynamiques 
* New Graphic Export options: Transparent PNGs and EMF
* New Worksheet Export options: Allow Rescaling, Remove Line Breaks, Use Browser for JavaScript scripts
* Options to export multiple worksheets to HTML: Single File (Tabs) and Linked Files
* Dynamic Opacity dans Propriété -> Avancé
  • Dynamic Color options for RGB, HSL, HSV dans Propriété -> Avancé
  • Les lignes peuvent être considérées comme fonctions, par exemple
	+	a:y=2x
	+	a(3)
  • En maintenant enfoncée la touche Alt lors de la construction d'un Polygone ou d'une LigneBrisée on force les angles à être des multiples de 15°
  • Construction Protocol export to HTML improved (eg included Tool icons)



Fonctionnalités en test

  • Outils > Gérer les outils > Ouvrir
  • Export vers Asymptote (case à cocher dans Export PSTricks )
  • Reconnaissance de caractères
  • bouton "Afficher Aide en ligne" dans les messages d'erreur de syntaxe
  • affichage plus performant des textes LaTeX dynamiques avec par ex . \frac{x_A}{y_A}=\jlmDynamic{x(A)/y(A)}
  • Intervalles: "3<x && x < 5" est transcrit "3 < x < 5"
  • RacinesComplexes[ <Polynôme> ]
  • Intersection[ligne,polygone]
  • booléens dans les fonctions, par ex. f(x) = x (x == round(x))
  • Intersections et unions de polygones (à venir)
  • Calculs Probabilités
  • Personnalisation de l'intersection des axes, possibilités de n'afficher que les branches droite/haut , de les placer en bord de fenêtre, grille "polaire" (radar)
  • Couleur d'arrière-plan et hachures pour les Textes (actuellement uniquement en utilisant le tableur ou la barre de style)


  • RésolEquaDiff[ <f'(x,y)>, < x initial>, <y initial>, <x final>, <pas> ] (Résolution Équations Différentielles)
  • RésolEquaDiff[ <y'>, < x'>, <x initial>,<y initial>, <t final>,<pas> ]
  • RésolEquaDiff[ <b(x)>, < c(x)>, <f(x)>, <x initial><y initial>,<y' initial>, <x final>,<pas> ]

+ also see FillCells[ ], First[ <Locus>, <Number> ] and Length[ <Locus> ] commands

  • Deux fenêtres graphiques
  • Hachures & Insertion d'image pour Polygones, Coniques, Pente, SommeSupérieure etc
  • StemPlot[ <List> ]
* PlaySound[ <Note>, <Duration>, <Length>]
* PlaySound[ <Note Sequence>, <Instrument> ]
* PlaySound[ <File> ]
* Inequalities
* Shear[object,line,ratio]
* Stretch[object,line,ratio]

Note that line can be also segment or vector.

* PointIn[x>0 && y>0 && x+y<3]
* <param = "useBrowserForJS" value = "true"/>
  • HTML5 export
* FormulaText[If[x < 3, x, x + 1]]
  • Upload to GeoGebra
	* Compound paths, eg point on {Segment[B, A], Segment[B, C], Segment[B, D], (1,1), Circle[A,B], x y = 1}
	+	* Animation of Points on Paths (eg circles, lines, compound paths)
	+	
	+	* Distance[ <Point>, <Object> ]
	+	* ClosestPoint[ <Point>, <Object> ]
	+	These two commands work for Circles, Curves, Lines, Segments. For functions they work on vertical distance. They don't work for Parabolas, Hyperbolas, Ellipses yet. Also Distance[ <Point>, <Segment> ] now works properly.

Script

Tous les objets GeoGebra peuvent maintenant avoir un script associé. Celui-ci peut être une liste de commandes GeoGebra et/ou un peu de JavaScript. Ainsi par exemple une image ou un cercle peuvent réagir comme un bouton.

Les nouveaux objets Bouton et ChampTexte ont été spécifiquement destinés à travailler avec les scripts. Si vous validez un texte quelconque dans un ChampTexte, le texte est passé à un script en tant que %0, ainsi vous pouvez avoir une commande comme suit :
texte = "%0"
Texte[%0,(3,4)]

Le texte est aussi passé à JavaScript en tant que variable 'arg' autorisant des commandes telles que :
ggbApplet.evalCommand('input="' + arg + '"');

GeoGebra intègre maintenant un interpréteur JavaScript. Si vous exportez en feuille dynamique, le JavaScript de chaque bouton est exporté dans une fonction à part dans le fichier HTML et le navigateur qui gère alors le JavaScript.

Le JavaScript Global est accessible à toutes les fonctions, et est aussi exporté dans le fichier HTML.

Commandes externes supportées :

  • alert("hello");
  • prompt("Quel est votre logiciel favori","GeoGebra");

par ex. : dans le Javascript du bouton : a=prompt("entrer un nombre","1"); ggbApplet.setValue('a',a); (si le nombre 'a' est déjà défini) ou ggbApplet.evalCommand('a='+a); (pour créer le nombre 'a' et lui affecter la valeur a)


Opérations sur les listes

<Objet> ∈ <Liste> est un élément de

<Liste> ⊆ <Liste> contient

<Liste> ⊂ <Liste> contient (strictement)

<Liste> \ <Liste> donne la différence (pas encore opérationnel)

<liste1>(n) retourne le n-ième élément de liste1 par ex. liste1(2) <matrice1>(m,n) retourne l'élément dans la colonne m et la ligne n de matrice1 par ex. matrice1(2,3)

Nouvelles fonctionnalités pour le tableur

  • Dialogue d'analyse des données
  • Dialogue pour Enregistrer dans Tableur
  • Création de tableau
  • Importation de fichier de données

3D View

Calcul formel

Clavier virtuel

Le clavier virtuel est accessible par Affichage -> Clavier virtuel

Il est transparent si vous utilisez Java 1.6.0_10 ou supérieur (Allez à Aide -> A propos pour connaître votre version)

  • Claviers pour Math, Grec, Hébreu, Arabe, Français, Allemand, Suédois, Norvégien, Malayalam, Espagnol et Anglais (US et UK) incluant tous les accents etc
  • Possibilité d'entrer des instructions avec la touche Alt, ex. Alt-0176
  • Différents claviers utilisables en lien avec les paramètres régionaux
  • Fonctionne avec toutes les applications, pas seulement avec GeoGebra
  • La fenêtre peut être redimensionnée
  • La touche AltGr affiche les "accents" dans la ligne supérieure pour toutes les langues. Accents définis : aigu, grave, circonflexe, cédille, tréma, ... chevron, tilde, brève, point au-dessus, ogonek, rond en chef, double aigu, solidus, dialytika tonos

Commandes

Commandes renommées

Commandes améliorées

  • Intersection[ <Courbe implicite > , <Courbe implicite> ]
  • Intersection[ <Courbe implicite> , <Conique> ]
  • Intersection[ <Courbe implicite> , <Ligne> ]
  • Intersection[ <Courbe implicite> , <Fonction> ]
  • Tangente[ <Courbe implicite>, <Point> ]
  • Tangente[ <Conique>, <Point> ] est maintenant aussi bien autorisé que Tangente[ <Point>, <Conique> ]
  • Tangente[ <Fonction>, <Point> ] est maintenant aussi bien autorisé que Tangente[ <Point>, <Fonction> ]
  • Dérivées des fonctions de plusieurs variables : f(x,y) = x^2 + y, Dérivée[ f(x,y), x ], Dérivée[ f(x,y), x, 2 ]
  • Normale[ <Moyenne>, <Ecart type>, x ] retourne maintenant la loi de probabilité de la loi normale

Par ex. Normale[0, 1, x] crée la fonction ℯ^(-x²/2) / sqrt(2 π)

  • Coin[5], Coin[6]

Coin[5] retourne sous forme de point (mais on s'en fout) largeur et hauteur de Graphique en pixels

Coin[6] retourne sous forme de point (mais on s'en fout) largeur et hauteur de toute la fenêtre en pixels la dernière nouvelle le concernant était qu'il allait sûrement être supprimé vu sa faible performance)


  • NbSI et GarderSi fonctionnent maintenant avec des expressions autres que des nombres

par ex. NbSi[ x == (1,2), {A, B, C} ] par ex. NbSi[ x == "hello", liste ]


  • Tableau[ <Matrice>, <Chaine> ] utilise maintenant ||, {}, [] ou () à préciser dans la chaîne, lignes horizontales en précisant _ et lignes verticales en précisant |

par ex. Tableau[{{1,2},{3,4}},"c()"] par ex. Tableau[{{1,2},{3,4}},"c|_"] par ex. Tableau[{{1,2},{3,4}},"c||"] par ex. Tableau[{{1,2},{3,4}},"c||||"]

  • Simplifier[ <Expression> ]

Simplifier élimine mieux les facteurs d'une fraction, par ex. Simplifier[(x-1)/(x^2-2x+1)]

  • Factoriser[ <Expression> ]

Factoriser a été améliorée et donne de meilleures réponses pour des factorisations simples et aussi pour des plus compliquées par ex. Factoriser[ x^33 - 1 ]

  • Vertex[<Polygon>]
	+	Returns vertices of polygon
  • Intersection[ligne,polygone] retourne les points d'intersection de la ligne et du polygone, ainsi que les segments déterminés
  • Intersection[ <Courbe implicite >, <Ligne> ]

fonctionne seulement si les coefficients de x³y³, x³y² and x²y³ sont nuls, ou si la ligne est parallèle aux axes.

Nouvelles commandes

Les commandes repérées par  * fonctionnent aussi dans Calcul formel
  • Shear[object,line,ratio]
  • Stretch[object,line,ratio]

* PathParameter[ <Point on Path> ]

	+	eg turns a Point on Circle into a slider
	+	* Point[ <Object>, <Parameter> ]
	+	eg Point[c, a] (for a circle c and slider a)
  • PrimeFactors[ <Number> ]

Returns a list of prime factors (works for numbers up to 9 007 199 254 740 992) eg PrimeFactors[1] returns {} eg PrimeFactors[23] returns {23} eg PrimeFactors[12] returns {2, 2, 3}

  • RSquare[ <List of Points>, <Function> ]
  • StemPlot[ <List> ] (UK: StemAndLeaf[ <List> ]
  • Hull[ <List of Points> ,<Percentage> ]
Produces a "Characteristic Hull" as described here: http://www.geosensor.net/papers/duckham08.PR.pdf

When the percentage is 1, the Convex Hull is produced. As the percentage is decreased, the area of the hull decreases.

  • ConvexHull[ <List of Points> ]
  • MinimumSpanningTree[ <List of Points> ]
  • DelauneyTriangulation[ <List of Points> ]
  • TravelingSalesman[ <List of Points> ]
  • Voronoi[ <List of Points> ]

Draws a Voronoi Diagram Draws a Voronoi Diagram

  • ShortestDistance[ <Liste de Segments>, <Point de départ>, <Point d'arrivée>, <Booléen "pondération"> ]

true -> utilise les distances entre points false -> toutes les distances sont à 1 (compte les nœuds du chemin)

Compound paths, eg point on {Segment[B, A], Segment[B, C], Segment[B, D], (1,1), Circle[A,B], x y = 1}

  • Périmètre[ <Lieu> ]
Utile pour ShortestDistance[ ]
  • SelectedIndex[ <Liste> ]
  • SelectedElement[ <Liste> ]

Ces deux commandes retourne l' index / l'élément d'une liste déroulante choisi par l'utilisateur. Ceci n'est utilisable actuellement que dans le tableur (et si l'option "Utiliser Boutons et Cases à cocher" est activée).


Voronoi[ <Liste Points> ] Dessine un Diagramme de Voronoi

  • ToolImage[ <Nombre> ]

Copie l'icône de l'outil choisi dans Graphique. Les numéros pour chaque outil sont listés ici :

http://www.geogebra.org/trac/browser/trunk/geogebra/geogebra/euclidian/EuclidianConstants.java

  • CréerGraphique[ <Fonction> ]
  • Echantillon[ <Liste>, <Taille> ]
  • Echantillon[ <Liste>, <Taille> , <avec répétition> ]
  • TexteVertical[ <Texte> ]
  • TexteTourné[ <Texte>, <Angle> ]


  • LigneBrisée[ <Liste de Points> ]
  • LigneBrisée[ <Point>, <Point>, <Point>, ... ]
  • PolygoneIndéformable[< Point libre>, ..., <Point libre> ]

Crée un polygone indéformable. En déplaçant le premier point on translate le polygone, en déplaçant le second on le fait tourner.


Length[ <Text> ]

* Length[ <Locus> ]

  • Take[ <Text>, <Start>, <End> ]
  • First[ <Text>, <Number>]
  • First[ <Locus>, <Number>]


  • Simplifier[ <Texte> ]

Essaye d'améliorer les expressions texte en supprimant les signes '-' répétés , etc ,par ex. Simplifier["f(x) = "+a+"x²+"+b+"x+"+c] Noter que LaTeX[f] produit normalement des résultats plus beaux et est plus simple dans LaTeX on peut utiliser \tiny, \large

  • RacinesComplexes[ <Polynôme> ]
  • SoitValeur[ <Booléen>, <0|1> ]

Définit l'état d'un booléen / Case à cocher 1 = vrai, 0 = faux

  • SoitValeur[ <Liste>, <Elément>]

Définit l'élément choisi dans une liste déroulante

  • SoitValeur[ <Objet> , <Objet> ]

utile dans un Script par ex. SoitValeur[a, b]

  • SoitValeur[ <Liste>, <Nombre>, <Objet> ]

utile dans un Script par ex. SoitValeur[list1, AléaEntreBornes[1,3], AléaEntreBornes[1,10]]

  • ActualiserConstruction[]

utile dans un Script. Actualise tous les nombres aléatoires(comme Ctrl-R)

  • AppliquerMatrice[ <Matrice>, <Objet> ]

Fonctionne pour Images, Polygones, Segments, Lignes, Points, Cercles, Secteurs, Arcs, Demi-cercles, Ellipses, Paraboles, Hyperboles et Courbes.

  • ElémentAuHasard[ <Liste> ]
  • Mélangée[ <Liste> ]
  • Rang[ <Liste> ]
  • MatriceEchelonnéeRéduite[ <Matrice> ]
  • Intersection[ <" Conique Implicite">, <Ligne> ]

ne fonctionne que si les coefficients de x³y³, x³y² et x²y³ sont nuls, ou si la ligne est parallèle aux axes.


  • AnalyserNombre[ <Nombre>, <chaîne> ]

par ex. AnalyserNombre[a,"%0"] dans un script GeoGebra

  • AnalyserFonction[ <Fonction>, <chaîne> ]

par ex. AnalyserFonction[f,"%0"] dans un script GeoGebra

  • Polygone[ <Liste * AnalyserNombre[ <Nombre>, <chaîne> ] (à revoir)
  • Polygone[ <Liste de Points> ]



  • Point[ <Liste> ]

par ex. Point[ {1,2} ] par ex. Point[ { {1,2}, {3,4} } ]

  • PointListe[ <Liste> ]

par ex. PointListe[ { {1, 2}, {3 ,4}} ]

  • Point[ <Object>, <Parameter> ]

eg Point[c,asin(a)] (for a circle c and slider a)

  • RacineListe[ <Liste> ]

par ex. RacineListe[ {1, 2, 3} ]



  • Numérateur[ <Fonction> ] *
  • Dénominateur[ <Fonction> ] *
  • ElémentsSimples[ <Fonction> ] *
  • Limite[ <Fonction>, <Valeur> ] *
  • LimDroite[ <Fonction>, <Valeur> ] *
  • LimGauche[ <Fonction>, <Valeur> ] *
  • Facteurs[ <Polynôme> ] *
  • Degré[ <Polynôme> ] *
  • Coefficients[ <Polynôme> ] *
  • Coefficients[ <Conique> ] retourne une liste avec les coefficients de : x², y², 1, xy, x, y
  • Quotient[ <Polynôme>, <Polynôme> ] *
  • Reste[ <Polynôme>, <Polynôme> ] *
  • Asymptote[ <Fonction> ]
  • Excentricité[ <Conique> ]
  • Garder[ <Texte>, <Début>, <Fin> ]
  • Premiers[ <Texte>, <Nombre>]
  • Premiers[ <Texte>]
  • Derniers[ <Texte>, <Nombre>]
  • Derniers[ <Texte>]
  • Longueur[ <Texte> ]
  • Texte[ <Objet>, <Point>, <Booléen pour Substitution des Variables>, <Booléen pour formule LaTeX > ]
  • Symétrie[ <Cercle>, <Cercle> ] symétrie du premier cercle par rapport au second
  • Cellule[ <Colonne>, <Ligne> ]


  • Reflect[ <Circle>, <Object> ]

Inverts object in circle


  • CoordonnéesDynamiques[ <Point>, <Nombre>, <Nombre> ]

A=Point[axeX] B=Point[axeX] CoordonnéesDynamiques[B,Min[x(B),x(A)],0] Cacher B Mettre le calque de C à 1 Maintenant, C ne peut être placé à la droite de A

A=(1,2) Cacher A B=CoordonnéesDynamiques[A, Si[x(A) > 3, 3,Si[x(A) < -(3), -3, If[x(A) < 0, round(x(A)), x(A)]]], Si[x(A) < 0, 0.5, Si[y(A) > 2, 2, Si[y(A) < 0, 0, y(A)]]]]

A=(1,2) B=(2,3) Cacher B C=CoordonnéesDynamiques[B, Si[Distance[A, B] < 1, x(A), x(B)], Si[Distance[A, B] < 1, y(A), y(B)]] fait de A un point d'aimantation quand C est déplacé dans son voisinage

  • Dérivée pour les fonctions à plusieurs variables : f(x,y) = x^2 + y, Dérivée[ f(x,y), x ], Dérivée[ f(x,y), x, 2 ]
  • Simplifier[ <Texte> ]

Essaye d'améliorer l'écriture d'expression en supprimant par exemple les répétitions de signes, etc Simplifier["f(x) = "+a+"x²+"+b+"x+"+c] Note : LaTeX[f] retourne normalement des résultats meilleurs et est plus simple


  • PointDans[ <Région> ]
  • IsInRegion[ <Point>, <Region> ]
  • SoitDifference[ <Liste>, <Liste>] utilisé par <Liste> \ <Liste>
  • Elément[ <Matrice>, <Ligne>, <Colonne> ]
  • AléaUniforme[ <Min>, <Max> ]
  • RegExpo[<Liste de Points>]

Ajuste une fonction du type a*b^x aux points de la liste. (Tout comme RegExp[], mais sans nécessiter e, car e est inconnu de beaucoup d'élèves même s'ils connaissent une fonction de croissance exponentielle.)

  • Reg[<Liste de Points>,<Liste de Fonctions>]

Ajuste une combinaison des fonctions aux points de la liste. Par exemple, avec les points A, B, C, ... L={A, B, C, ...}, f(x)=1, g(x)=x, h(x)=e^x, F={f,g,h} la commande Reg{L,F} retourne la courbe d'ajustement par moindres carrés de reg(x) = a + b x + c e^x

  • SommeCarrésErreurs[<Liste de Points>,<fonction>]

Si nous avons quelques points dans une liste : L={A,B,C,D,E} et avons défini par exemple : f(x)=RegPoly[L,1] et g(x)=RegPoly[L,2] nous pouvons alors décider du meilleur ajustement, au sens de la plus petite somme de carrés des erreurs (Gauss), en comparant : sse_f=SommeCarrésErreurs[L,f] and sse_g=SommeCarrésErreurs[L,g].

  • TDistribution[ <Degré de liberté>, <valeur Variable> ]
  • InverseTDistribution[ <Degré de liberté>, <Probabilité> ]
  • FDistribution[ <Degré de liberté Numérateur>, <Degré de liberté Dénominateur>, <valeur Variable> ]
  • InverseFDistribution[ <Degré de liberté Numérateur>, <Degré de liberté Dénominateur>, <Probabilité> ]
  • Gamma[ <Alpha>, <Beta>, <valeur Variable> ]
  • InverseGamma[ <Alpha>, <Beta>, <Probabilité> ]
  • Cauchy[ <Median>, <Scale>, <valeur Variable> ] cauchy
  • InverseCauchy[ <Médiane>, <Scale>, <Probabilité> ]
  • ChiCarré[ <Degré de liberté>, <valeur Variable> ]
  • InverseChiCarré[ <Degré de liberté>, <Probabilité> ]
  • Exponentielle[ <Moyenne>, <valeur Variable>]
  • InverseExponentielle[ <Moyenne>, <Probabilité> ]
  • HyperGéométrique[ <Taille Population >, <Nombre de succès>, <Taille Échantillon>, <valeur Variable> ]
  • InverseHyperGéométrique[ <Taille Population>, <Nombre de succès>, <Taille Échantillon>, <Probabilité> ]
  • Pascal[ <Nombre de succès>, <Probabilité de succès>, <valeur Variable> ]
  • InversePascal[ <Nombre de succès>, <Probabilité de succès>, <Probabilité> ]
  • Weibull[ <Shape>, <Scale>, <valeur Variable> ] weibull
  • InverseWeibull[ <Shape>, <Scale>, <Probabilité> ]
  • Zipf[ <Nombre d'éléments>, <Exposant>, <valeur Variable> ] zipf
  • InverseZipf[ <Nombre d'éléments>, <Exposant>, <Probabilité> ]
  • SampleSD[ <Liste de nombres> ]

retourne l'écart-type d'échantillonnage

  • VarianceÉchantillon[ <Liste de nombres> ]

retourne la variance d'échantillonnage

  • SoitLégende[ <Objet>, <Texte> ]
  • SoitEtiquetteMode[ <Objet>, <Numéro> ]
  • SoitCouleur[ <Objet>, "couleur" ]
  • SoitCouleur[ <Objet>, <Rouge>, <Vert>, <Bleu> ]
  • SoitCouleursDynamiques[ <Objet>, <Rouge>, <Vert>, <Bleu> ]
  • SoitConditionPourAfficherObjet[ <Objet>, <Condition> ]
  • SoitCoordonnées[ <Point>, <x>, <y> ]
  • SoitRemplissage[ <Objet>, <Nombre> ]
  • SoitPointTaille[ <Point>, <Nombre> ]
  • SoitPointStyle[ <Point>, <Nombre> ]
  • SoitLigneEpaisseur[ <Ligne>, <Nombre> ]
  • SoitLigneStyle[ <Ligne>, <Nombre> ]
  • SoitCalque[ <Objet>, <Calque> ]
  • SoitFixé[ <Objet>, <true | false> ]
  • Renommer[ <Objet>, <Nom> ]
  • CopierObjetLibre[ <Objet> ]
  • AfficherCalque[ <Nombre> ]
  • CacherCalque[ <Nombre> ]
  • SélectionnerObjets[ <Objet> ]
  • SélectionObjets[ ] efface la sélection
  • SélectionObjets[ <Objet>, <Objet>, ... ]


  • RemplirLigne[ <Ligne>, <Liste> ]
  • RemplirColonne[ <Colonne>, <Liste> ]
  • RemplirCellules[ <Plage>, <Objet> ]
  • RemplirCellules[ <Cellule départ>, <Liste> ]
  • RemplirCellules[ <Cellule départ>, <Matrice> ]

par ex. RemplirCellules[A1:B20, lieu1] pour recueillir les coordonnées de points du lieu dans le tableur par ex. RemplirCellules[A1:B20, 3] pour copier '3' dans plusieurs cellulles par ex. RemplirCellules[A1:B2, {{1,2},{3,4}}] pour copier une matrice dans le tableur [UNFINISHED]

  • Agrandir[ <Facteur> ]
  • Agrandir[ <Facteur> ,<Centre>]
  • Réduire[ <Facteur> ]
  • Réduire[ <Facteur> ,<Centre>]
  • Pan[ <x>, <y> ]
  • Slider[ <Min>, <Max>, <Increment>, <Speed>, <Width>, <Is Angle>, <Horizontal>, <Animating>, <Random>]
	+	Only first two are compulsory.

Commandes 3D

Nouveaux raccourcis clavier

  • Ctrl-H Afficher/Cacher Objets (pas pour MacOS)
  • Ctrl-Shift-H Afficher/Cacher Étiquettes (pas pour MacOS)
  • Ctrl-G Afficher/Cacher Objets
  • Ctrl-Shift-G Afficher/Cacher Étiquettes
  • Ctrl-I Inverse Sélection
  • Tab Sélection de l'objet suivant (alphabétiquement/ordre du tableur, pas pour les objets pour lesquels " Sélectionnable" n'est pas cochée)
  • Shift-Tab Sélection de l'objet précédent (alphabétiquement/ordre du tableur, pas pour les objets pour lesquels "Sélectionnable" n'est pas cochée)
  • Ctrl-Tab bascule entre Graphique et Tableur
  • Page Haut augmente le numéro du calque des objets sélectionnés
  • Page Bas diminue le numéro du calque des objets sélectionnés
  • Alt-moins retourne maintenant un moins surélevé (non un plus-ou-moins)
  • BarreEspace : Bascule pour le boolén sélectionné
  • BarreEspace : lance les scripts du Bouton sélectionné
  • ce qui suit fonctionne (en combinaison avec Alt, Shift, Ctrl pour modifications) pour adapter Graphique quand aucun objet n'est sélectionné :
    • PageHaut : Déplace vers le haut d'une hauteur d'écran
    • PageBas : Déplace vers le bas d'une hauteur d'écran
    • Inser : Déplace vers la gauche d'une largeur d'écran
    • Home : Déplace vers la droite d'une largeur d'écran
    • Flèche Gauche : Déplace vers la gauche de 1% de la largeur d'écran
    • Flèche Droite : Déplace vers la droite de 1% de la largeur d'écran
    • Flèche Haut : Déplace vers le haut de 1% de la hauteur d'écran
    • Flèche Bas : Déplace vers le bas de 1% de la hauteur d'écran
  • Ctrl-M retour à Affichage standard de Graphique
  • Ctrl-Shift-M: Export pour une plate-forme d'apprentissage en ligne
  • Bouton Menu du clavier ouvre le menu de Graphique / dialogue des propriétés
  • Ctrl-Shift-N: Sélectionne la fenêtre suivante
  • Ctrl-Alt-Shift-N: Sélectionne la fenêtre précédente


Description de tous GeoGebra Keyboard Shortcuts


Applet Description de tous GeoGebra Applet Parameters

Command Line Arguments Description de tous GeoGebra Command Line Arguments

JavaScript commands

  • String getPNGBase64(double exportScale, boolean transparent, double DPI)
eg var str = ggbApplet.getPNGBase64(1, true, 72);
  • boolean writePNGtoFile(String filename, double exportScale, boolean transparent, double DPI)
signed applets only

eg var success = ggbApplet.writePNGtoFile("c:\\test.png", 1, false, 300);

Description de tous GeoGebra JavaScript Methods

GeoGebra's XML File Format GeoGebra's XML file format is documented at GeoGebra_XML_Format

License You are free to copy, distribute and transmit GeoGebra for non-commercial purposes. Please see the GeoGebra license for details: http://www.geogebra.org/download/license.txt


En juillet 2009, l'équipe de développeurs GeoGebra s'est attelée à construire la nouvelle version 4.0. Nos remerciements à nos nouveaux nombreux programmeurs qui ont généré une multitude de nouvelles fonctionnalités.


Beaucoup de nouvelles commandes et outils

List command in the input help

The commands to list would be very time consuming. A summary of the changes, you could list as areas with the greatest growth function:

  • Analyse de données
  • Analyse
  • Théorie des graphes
  • Opérations sur les listes (in GeoGebra there arelists)
  • ...

More important than all these functions, but the new list of all usable functions in GeoGebra, which is now available as a side imposable range (triangle in the rectangle in the lower right corner click .). Sorted by topic you will probably find it faster than it was before in the shorter list of case. You get into this field not only the name but also the syntax presented and it is offered a button that leads directly into the manual wiki.

In the Wiki-Manual there are also lists, in which the commands are also sorted by topic. The advantage here is that you will sometimes refer to other functions and examples given. Two examples of advanced page in the wiki:

  • Check box [1]
  • New Point Tool [2]

Also known as "simple" users can add information to the wiki and provide interesting examples of other colleagues.

Évolution de l'interface

A frequently cited criticism GeoGebra 4.0 is: GeoGebra is so "inflated" that is no longer available for younger students. The interface is too complicated, but thanks to extensive programming of the interface. Improvements in Java, have made the appearance of GeoGebra with just one click convert with the Perspectives menu.

Perspectives

It possible to make the so-called Perspectives, some of which are already defined as a selection. A perspective is a default for the type and arrangement of the visible portion of view, the tools offered and general settings. So there is a prospect "Elementary Geometry", in which all the tools for simple drawing objects (not stacked) together are available, the only visible sign area and the font is slightly larger.

Perspectives can create yourself, if not one of the guidelines range. It all views are freely movable and can even outsource the GeoGebra window. None of the views must always be visible and you can therefore use a clean table window.

Fichier:Surface Neu.png
Axles changed up the design bar to a point

is helpful for the younger artistdesign bar, which is primarily there to the appearance of objects quickly . change Instead of looking in the extensive properties dialog, you can easily make changes directly accessible via a couple of buttons.

Fenêtres graphiques

L'introduction d'une seconde fenêtre graphique a considérablement augmenté la capacité de GeoGebra.

Par exemple, on peut maintenant créer une situation géométrique dans une fenêtre graphique et lui associer la représentation graphique d'une fonction liée à un objet dans l'autre fenêtre graphique, avec des repères distincts.

→ Exercise: function derived graphically and use another window to draw inference.
→ Exercise: representation of the unit circle and the trigonometric function depending on the angle

Even in the character area itself was working on the recruitment opportunities at the axes. This way you can now limit the axes to represent positive values, or always on the edge of the axes. Besides, you can now also functions as a function of other variables defined as x. Indicate to the already existing possibility a point in polar coordinates, then a polar coordinate grid is available.

Algèbre

Affichage LaTeX des objets ce qui rend la lecture plus aisée, plus compréhensive des écritures de fonctions par exemple

Nouvelles fonctionnalités pour Tableaux blancs ou Tablettes

As many want to use GeoGebra as a tool for teaching math with interactive whiteboards is understandable. Unfortunately, this has been quite inconvenient and you have had to make do with a few tricks, creation of an applet usually requires a keyboard. Now there are some changes that simplify operation and expand on the whiteboard.

  • The aforementioned 'bar design' allows quicker access to object properties. Otherwise it was very awkward to bring up the Properties dialog and change something there.
  • Changes to the properties you can save but also by adjusting the preferences for objects according to your wishes. In the settings, there is now a list of all objects where you almost can advance to adjust settings to look the way you want it.
  • A virtual keyboard, which appears whenever you click on an input field (after the keyboard is enabled).
  • For smaller pupils and colleagues who have trouble reaching the top is drawing tools, now allows the 'Tools strip down' view.
  • If you want something you have to sketch in a drawing, now no longer the image into a table GeoGebra software copy and paste. A simple pen tool allows the drawing by hand. Here, the image is stored as subscribed in GeoGebra.

NOTE: A GeoGebra version for mobile phones or tablet is in the works. If your device has a JavaScript capable browser you can test it by visiting GeoGebra tube. Your browser does your device as a "mobile" before GeoGebra server, just so no Java support, then the mobile version of GeoGebra used. This works, but some already, but not, for example with files that use scripting or scripting does not work.

Extensions of the spreadsheet

There are many new functions for the integrated spreadsheet in GeoGebra.

The first new feature you can detect even if it displays the table and click on one of the cells. So there is now a specialTable tool bar, can be found in the tools that you can use in the table. The normal drawing tool bar will reappear when you dialing the algebra or the drawing view.

The appearance of the table and the display of values ​​in the table can now also be affected. If you click right on the table, it can be in the context menutableoptions' and select pre-set some properties. Thus, even the lines are rendered invisible. For the table, there is now also a'design bar, with one magazine ad, can set the background color, alignment, and borders. The input and correction of longer formulas is facilitated by an input field, as he is known also from other spreadsheet programs will be offered.

The'co-sign from view and table has been further improved. Even in version 3.2 there was the functionTrace to Spreadsheet nowvalues ​​in Table enter, which was significantly improved. Points and any value (ie about the lengths of lines, angles, or a single coordinate) can now easily enter into the table. Conversely, now also offered tools with which you can generate from the data in the table, drawing objects and other expenses for the sign-view, such astable,matrices', etc. to which it some small dialogs for setting options out there.

Now the very extensive amount of toolsanalysis of data is. If you have a list of dates and numbers - they can also be imported from other programs or copied to the table - you can make a variety of types ofgraphical and mathematical analysis, two or more variables as well as simple statistics such as sum, average, etc.

New export opportunities

In addition to the already previously exploitable opportunities for the export of GeoGebra out there are major changes. And also when exporting to HTML page, there are a few improvements.

Thus, besides the creation of complete HTML page, the possibility of Exports of applets for wikis, Moodle and as a Google Gadget .

Of interest is the ability to create an animation from a animated gif image. This one is independent of Java on mobile devices so that usually is not available.

The biggest innovation in this area is undoubtedly the introduction of a materials database under the name GeoGebra. You can upload directly from GeoGebra out the worksheet and must not have its own page on the Internet. GeoGebra also offers the possibility of using the files from other members and the organization of all selected worksheets to make them more useful to the students.


Simplification of existing functions

Text tool

In GeoGebra, there is even the possibility to create dynamic text, ie Values ​​from the drawing may be included in the text, so that the text change in the drawing also changed.

However, the creation of dynamic text was perceived by many to be complicated, especially if you wanted to link multiple dynamic components. A new Text tool gives you a dialogue that is intended to simplify the entry. Instead of placing shares in quotes and give the individual components with a "+" to link it now a selection box where you can select individual objects. Thus, the selection of a point to the fact that its coordinates are displayed dynamically, and this is reflected by the fact that the name of the item is displayed in a box. Within this box you can make changes, then apply some functions, such as the determination of the x-value of this point.

Certainly important, the Previewfunction' is. For the purposes of LaTeX' there is finally a long list of templates, as well as a large number of characters. Regarding the use of LaTeX, it was started by members of the Forum in the English Wiki Manual to prepare a list of standard formulas so that you can copy the code simple can.

Slider

Another small but important change is the fact that sliders have now dynamic limits. This means that you can use any value in GeoGebra now as a value for the upper or lower limits. Now it is possible, for example, fractions, set the slider to the counter so that he can have a maximum size of the denominator.

Animation

Now it was only one possible animation with the help of sliders, to create then in version 4.0 provides a new opportunity. Points to any kind of line (line, line, circle, ... and associated routes - this semi-circle + line) were drawn can now be easily animated by a right click you turn on the animation . The animation on the infinitely long line has been designed so that the outward movement is faster.

Positioning of points

Every now and again been in demand in the forum, if you do not restrict the movement of a point some way. There were opportunities to work, but it was cumbersome and could hold only one point in a rectangle and a circle. Gliders were only for circles or straight lines.

With the toolPoint on Object you can now put a point on any face or, if you click on the edge of a surface, let him slide on the edge. The subsequent release or on-(A-) hanging one point was only possible through a redefinition of what was probably too complicated for novice users. You now have the toolpoint of attach / detach.

Long-missing capabilities for the school

Requests in the forum for new features worth it anyway. And so many other requests of the users have been implemented that have been missing for a long time.

Inégalités

Les inégalités sont maintenant implémentées, elles peuvent donc être définies et représentées. Not only linear but also for all types of conics.

The presentation included in the drawing window indicates whether < or <=. There is also an inverse representation possible in order to optimize the linear valid range to set them free. Linear inequalities with one variable can be intervals displayed on the axes in the usual presentation with filled or empty circle.

Interval data as <math> 3 <x <8 </ math> can now be used in other places where you'd otherwise use an AND operation.

List operations

Are now available ...

  • <Object> <List> ∈ is an element of
  • <List> ⊆ <List> is a subset of
  • <List> ⊂ <List> is a proper subset of
  • <List> \ <List> Determines the difference

<List> * (N) defines the n-th element of the list.

The first query can return a boolean result variable, so <math> true </ math> or <math> false </ math>. The last two give you a list as a result.

Cut points can be indicated

What has been asked often in designs is now possible. One no longer needs to construct additional lines or arcs but can select a cut point (in the Properties dialog) to "show cut cropped lines." Where they are visible only when the circles are invisible.

Significant new opportunities for functions

Determination of ...

  • Absolute extrema for functions in the limited interval
  • Vertical asymptotes and limits (on the right side, left side)
  • ...

Loci of slider

... needs some text ...

Scripting

Under Scripting refers to a type of programming, which, put simply, SOGT sure that will run on a user action into multiple actions GeoGebra. In older versions this was possible only for HTML and JavaScript but knowledgeable in the current version you have installed without the possibility of programming skills in GeoGebra buttons or input lines and link them with a list of commands. You have to learn any new commands, but simply uses the commands as they can be used in the input line.

Especially for the new scripting commands have been introduced, with which one can influence, for example, the appearance of objects and the canvas.

Finally

Where is the CAS?

If you ask this, you have probably heard or read CAS should be incorporated in version 4.0; a CAS window and for some time in the beta version was already available. Beginning in 2011, it was resolved by the developer side to try a new CAS system for GeoGebra. The previously built-MathPiper did not meet all required functionality, and so the use of an external CAS called Maxima was allowed. This allowed users a better tool, although a less than ideal one.

In 2011, a Java version of Reduce (computer algebra system) [3], one of the oldest CAS programs (1960) became available, it was converted to Open Source a few years. The integration of MPReduce was begun under the Google Summer of Code; testing proved it to be well integrated. The decision was made to let go all other versions of CAS. Since of the integration process would be incomplete for the release date of version 4.0, the developers took out the CAS view from version 4.0. The CAS version will be published in the next stable release called version 4.2.

Those interested can test the beta version to 4.2. As usual, they now find a link to a Web Start version in the sub-forum to version 4.2 (near the bottom of the page).

Printed or PDF?

If you have this text as PDF or get printed, then you should definitely visit the page on the wiki directly, which is at the address

can be achieved. It is worthwhile, because there you can try some of the functions in the form of small embedded GeoGebra applets or experience, at least in "action". There the gif image is animated really well.

Actually, there are more new features

This page is certainly a very good overview of the new version 4.0, but there are many little things that were not mentioned here because it would be just too much. Anyone who wants can look around on the following page:

Where do I now get the version 4.0 from?

It's simple: go to the side of the GeoGebra project in the top menu and select'Download on. Appearing on the page you will find a selection of all possible types of use. PrimaryGeoGebra' way, is a GeoGebra variant in which the perspective is "Elementary Geometry" same used at the beginning.

© 2021 International GeoGebra Institute