Notas Lanzamiento de GeoGebra 4.0

De GeoGebra Manual
Saltar a: navegación, buscar
Esta página ofrece un pantallazo sobre las nuevas posibilidades de GeoGebra 4.0 respecto de la versión 3.2 detallada en el Manual previo.

Para mayores detalles se puede consultar;


Nota: Se dispone también de categorizaciones de Comandos y/o de Herramienta.

Posibilidades de GeoGebra 4.0

Desde la Instalación

Se puede instalar GeoGebra 4.0 empleando el Inicio Web o la opción de Descargacorrespondiente .

Bulbgraph.pngAtención: GeoGebra 4.0 no puede ejecutarse con Java 1.4.2, es preciso instalar como mínimo la versión de Java 5 desde java.com
Nota:
La versión 4.0 puede encontrarse en el sitio del Proyecto GeoGebra, seleccionando Descarga del menú superior.
En la página emergente se encontrarán una selección de todo tipo posible de empleo.

Compatibilidad con GeoGebra 3.2

Los detalles respecto de la compatibilidad con GeoGebra 3.2 se detallan en la sección Compatibilidad.
Algunas de las diferencias operativas pueden estudiarse contrastado su Manual con la lectura de las correspondientes notas con su tutorial.

Novedades Salientes de GG 4.0

  • Nuevas Herramientas de Texto (mucho más sencillas y ágiles para crear textos dinámicos)
  • Gestión de Disposiciones (Arrastras & Deposita y Vistas Liberadas)
  • Ecuaciones Implícitas como (x2 + y2 - 1)3 = x2 y3
  • Exportación de archivos GIF Animados
  • Guiones, Botones, Campos de Texto
  • Alternativas de Accessibilidad (como empleo completamente independiente del ratón o mouse)
  • Límites dinámicos para los deslizadores y ejes
  • Mejoras en Hojas de Cálculo como las de...
    • los diálogos de seguimiento de los rastreos
    • el Análisis de Datos/Cuadros de Diálogo/Calculadora de Probabilidad/ Inspección de Funciones
  • Mejor rendimiento de Ecuaciones y en LaTeX
  • Animación de puntos en circunferencias/elipses/lugares geométricos/trayectos compuestos/etc.
  • Transformación de Funciones (como Refleja[ sqrt(x), y=x ] para mostrar la inversa)
  • Barra de Estilo para más ágil cambio de propiedades (color, medida de la tipografía, anchos de trazos, etc.)
  • Intervalos como 3 < x < 6
  • Nuevas opciones de sombreado como las de rayado, estampado con figura (archivos de bitmap) y otros
  • Dos Vistas Gráficas
  • Inecuaciones
  • Ascenso de hojas dinámicas directamente subidas al Gestor de Materiales
  • Arrastre de objetos desde la Vista Algebraica -> Vistas Gráficas y Hojas de Cálculo
  • Lugares Geométricos a partir de deslizadores
  • Alternativa de Copiar y Pegar en las vistas gráficas.

GeoGebraPrim

GeoGebra-Prim es la variante de GeoGebra cuya disposición es la más adecuada para la "Geometría Básica" habitual para nivel primario o de acercamientos iniciales. Nuestra versión de GeoGebra para nivel primario está disponible en GeoGebraPrim.jnlp

Características Distintivas

  • Limitado repertorio de Herramientas
  • Todas las Herramientas disponibles se exponen juntas
  • Tipografía de mayor tamaño
  • Objetos más amplios (más anchos y largos)
  • Exposición de la Vista Gráfica exclusivamente
  • Mayor facilidad para selecciones objetos
  • Rotulado de todos los objetos disponible (por omisión)
  • Ángulos limitados por omisión a los convexos (entre 0° y 180°)
  • Redondeo al entero más próximo (por omisión)

Herramientas

Nuevas Herramientas

Permite fijar un punto a la región abarcada por el objeto (polígono, circunferencia o elipse,), tanto el área que abarca como su contorno y sus límites, perímetro formado por sus lados en caso de ser polígono, curvas o rectas si allí fuese el clic
Para vincular un punto a un trayecto o región basta un clic en un punto libre y luego en un recorrido o región.
A partir de esa ocurrencia, tal punto podrá Mode move.png desplazarse dentro del trayecto o área correspondiente.
Pulsar Alt permite vincular el Punto al interior de la figura (en lugar de asociarla a su contorno).
Permite esbozar notas o dibujos a mano alzada en la Vista Gráfica en la zona que previamente se hubiera recuadrado con la herramienta Mode move.png Elige y Mueve o la imagen indicada. El botón derecho del ratón o mouse opera como borrador.

Herramientas Modificadas

Además de operar con su comportamiento habitual, es posible simplemente arrastrar un objeto para trasladarlos (a modo de una herramienta de "copiado").

Completamente replanteada para hacer muy simple la confección de textos dinámicos. La nueva herramienta de texto ofrece una caja de diálogo que simplifica el ingreso. En lugar de escribir los literales entre comillas y encadenar los componentes individuales con un signo "+", ahora se cuenta con una caja de selección de los objetos individuales. Así, la selección de un punto implica que sus coordenadas se expondrán dinámicamente y esto se corresponderá con el nombre de tal ítem expuesto en la caja mencionada. Con esta caja se pueden hacer cambios y luego aplicar funciones que permitan, por ejemplo, la determinación del valor de la abscisa de ese punto. La función de Previsualización es un aporte sustantivo. En cuanto a LaTeX, se añadieron una extensa lista de plantillas y numerosos caracteres. Si se pulsa el botón derecho sobre el rectángulo de encuadre de objetos, se puede seleccionar "Definición" o "Valor" para cada objeto dinámico. Hay, además, una pre-visualización, un menú desplegable de Símbolos y una fila de los empleados recientemente. Los textos incluso se pueden arrastrar mientras está seleccionada la Herramienta de Texto.

Los deslizadores ahora se pueden desplazar arrastrando mientras la Herramienta Deslizador está seleccionada o con el botón derecho del ratón o mouse pulsado cuando la herramienta Mode move.png Elige y Mueve está activa. Es posible establecer para los deslizadores, límites dinámicos. Esto implica que se puede emplear cualquier valor como límite inferior y/o superior del rango correspondiente. Por ejemplo, en fracciones, establecer un deslizador para limitar el máximo del denominador.

Las casillas de control se pueden desplazar arrastrando mientras la Herramienta Casilla de Control está seleccionada.

Se puede crear un Lugar Geométrico a partir de un deslizador y un punto dependiente.

Nuevas Posibilidades

Nuevos Tipos de Objetos

  • Curvas Implícitas, como. x^3 + y^2 = 1 se pueden trazar en la Vista Gráfica.
  • Funciones de Múltiples Variables, como. f(x, y) = x^2 + y^2
    Pueden emplearse también para definir funciones de una única variable, como. g(x) = f(x, 2) y de varias variables como f(a,b,c)=a+b+c
  • Poligonal. Opera como la del Polígono, generando una construcción no siendo necesariamente cerrada. Sus atributos se asocian al perímetro, no al área encerrada. :Ver también el comando Poligonal.
  • Intervalos como 10 = x < 20

Se pueden emplear los comandos PuntoMedio, Máximo y en estos intervalos

Trayectos Compuestos

Se puede ubicar un punto en un recorrido compuesto que, en tal sentido, da origen a un particular tipo de objeto, el de los Pasos Compuestos.

Regiones

A través de inecuaciones que son ahora un objeto habilitado, se pueden establecer regiones para establecer allí un Punto

Ejemplo: Si se define - siendo a = 11, la región (10x² - 12x y + 3y² - 28x + 7y < -35) ∧ (y < -2x + a) determinado entre una parábola y una recta, es posible indicar que haya un Punto en esa zona que, incluso varía dinámicamente si se modifica el valor de a.

Características Generales

  • Se ha añadido la función log(b, x) para la base b
  • Exportación de la Hoja Dinámica: Opción que permite incrustar el archivo ggb en el HTML (codificado como Base64, usando el parámetro 'ggbBase64')
  • Exportación como 'GIF Animado' (la animación se controla usando un deslizador como "reloj")
  • La Herramienta Compás permite seleccionar la circunferencia primero y luego el punto del centro
  • Las opciones 'Entero' y 'Aleatorio' se suman a las habituales para deslizadores
  • Archivo -> Abre Página WEB permite leer archivos ggb desde páginas web al pegar un URL desde un buscador (finalizado en .html o .ggb). También permite controlar archivos al codificar como una cadena Base 64 o GeoGebra XML.
  • La opción "Muestra intersección acotada" para puntos de intersección
  • Opciones de Apunte (Propiedades de Objeto -> Avanzado) Activa, Desactiva, Subtítulo, Siguiente Celda, Automático (comportamiento previo: solo cuando la Vista Algebraica está abierta)
  • Adecuada exposición de fórmulas y matrices en la hoja de cálculo
  • Cuando se ingresa una expresión como ab + 1, si la variable ab no está definida, automáticamente la crea como ab = a *b si a y b son números o en el caso de ab = Distancia[A, B] si A y B son puntos.
  • FórmulaTexto[ <Matriz> ], FórmulaTexto[ <Vector> ] se exponen ahora adecuadamente
  • En la Vista Algebraica se pueden seleccionar múltiples objetos manteniendo pulsada la tecla Shift mientras se los selecciona con clic.
  • Se incluye la opción "Importa Archivo de Datos" a la Hoja de Cálculo a través de su menú contextual
  • Los códigos de teclas al estilo de Windows también operan ahora en los Campos de Texto (como Alt-0176 para °) [no disponible para Mac OSX]
  • Respaldo para el ingreso de dígitos Únicode como parte de expresiones como Eastern Arabic, Thai, así como todos los sistemas numéricos detallados (excepto Osmanya): Sistema Numéricos Hindú-Arabigo
Se admiten...
  • csc(x), sec(x), cot(x), csch(x), sech(x), coth(x) y sus derivadas
  • atan2(x,y)
  • sqrt(3 + i), cbrt(3 + i), conjugate(3 + i), arg(3 + i)
  • Todos los sistemas numéricos detallados aquí (excepto Osmanya): Hindu-Arabic Numeral System
  • La sintaxis a = a + 1 o A = A + (1, 2) para objetos libres (útil para botones)
  • Porcentajes como a = 3.4%
  • Números que se expondrán empleado dígitos en formato local (vigente en Arabe, Tamil, Thai y Malayalam)
  • Potencias en superíndices con más de un dígito como en y = x²², x⁻¹
  • Alt - menos para superíndices negativos (no como menos-o-más)
  • Rótulos en alfabetos locales para los puntos, como los griegos y/o árabes
  • Superíndices en funciones al ingresar, por ejemplo, sin²(x), sin³(x), sin⁻¹(x)
  • Las listas de puntos para definir, por ejemplo, polígonos como en Polígono[ <lista> ].
  • Subtítulos LaTeX (rodeados por $ $ ) (para todos los objetos excepto para una CasillaControl , Campos de Texto o Botones)
  • Radio auto-ajustable para los ángulos visible
  • Atracción a cuadrícula funcional también para textos, imágenes, polígonos, segmentos, vectores, etc. (previamente, solo operaba sobre puntos)
  • Los lados de un polígono pueden emplearse ahora para arrastrarlo
  • Mejorada apariencia de las ecuaciones LaTeX y casi completamente implementada la variedad de los modelos para LaTeX (usando JLaTeXMath)
  • Captura dinámica a "objeto/cuadrícula" cuando se traza un nuevo objeto.
  • Balanceo colorido de llaves, corchetes y paréntesis cuando se ingresa fórmulas en la Barra de Entrada, por ejemplo.
  • Visualización previa del efecto de herramientas como Angulo, Perpendicular, Paralela, Bisectriz, Mediatriz y Cónica por cinco puntos.
  • Exposición adecuada de fórmulas de funciones como f(x) = sin²(x), con el estilo de, por ejemplo, FórmulaTexto[ sin(x)^2 ]
  • Las Curvas Paramétricas pueden transformarse como, por ejemplo, Refleja[Curva[t^2, t^3, t, -1, 1], EjeY]
  • Pruebas en la Vista Gráfica de la aplicación de herramientas como la Integral, Pendiente, Diagrama de Cajas, Gráfico de Barras, Histograma
  • Opción de grosor nulo para los trazos de la Integral, Pendiente, Gráfico de Barras, Histograma, Angulo
  • Las aplicaciones operan automáticamente a partir del teclado
  • Los textos dinámicos simples como a"texto"b son equivalentes al encadenamiento de a+"texto"+b
  • Ayuda-> Acerca de GeoGebra / Licencia -> Información Sistema (Copia al Portapapeles) copia la información para el control de fallas al portapapeles.
    Esto permite recrear el trabajo en marcha en caso de haber un problema, para que quede guardado
  • Ctrl-Shift-M copia solo la etiqueta del <applet> al portapapeles en la MediaWiki, Moodle, etc.
  • Opciones de Subtítulos:
    • %v para el valor
    • %n para el nombre
    • %x para la coordenada x (o coeficiente x para la recta a x + b y + c = 0)
    • %y para la coordenada y (para el coeficiente y para la recta a x + b y + c = 0)
    • %z el término 'c' para la recta a x + b y + c = 0 (también: coordenada z, lista para la Vista 3D)

Novedades

Alternativas en Herramientas de Usuarios
  • Pueden incluir ahora...
    • ángulos, integrales, suma inferior/superior, histogramas, diagramas de cajas y de barras como salida.
    • entradas numéricas y angulares
      • la numérica se puede emplear ahora simplemente con un clic en la Vista Gráfica para activar la correspondiente Caja de Diálogo.
Respecto de Rastros y Rasgos de los Objetos
  • Rastro para Polígonos, Listas y Lugares Geométricos (útil para, por ejemplo ResuelveEDO[x + y, y² - 1, x(A), y(A), 5, 0.05])
  • Para seleccionar varios objetos, clic derecho que da apertura un menú en lugar de la Caja de Diálogo de Propiedades de Objetos
  • Caja de selección emergente cuando se da clic en varios objetos.
  • Los textos creados a partir de la Barra de Entrada, pueden aparecer ahora en el medio de la Vista Gráfica, no solo en el origen de coordenadas
  • Los textos y cada lugar geométrico resultan visibles en la Vista Algebraica (Auxiliares por omisión)
  • Opción en la Barra de Estilo de la Vista Algebraica que permite listar los objetos por orden de tipo
  • Rango e incremento dinámicos de los deslizadores
  • Nuevas opciones para exportar gráficos de distinto tipo: PNGs Transparentes y EMF+
  • Nuevas opciones para exportar la Hoja Dinámica: se admite el re-escalado, eliminación de líneas de corte, empleo de buscadores en guiones de Java - JavaScript -.
  • Opciones para exportar múltiples hojas dinámicas a un HTML: Único Archivo (Pestañas) y Archivos Vinculados
  • Opacidad Dinámica en Propiedades de Objeto -> Avanzadas
  • Opciones de Color Dinámico para RGB, HSL, HSV en Propiedades de Objeto -> Avanzadas
  • Las rectas pueden comportarse ahora, también como funciones. Por ejemplo, a:y = 2x a(3)
  • Para provocar ángulos de amplitud múltiplo de 15° al construir polígonos o poligonales, basta con mantener pulsada Alt
  • El Protocolo de Construcción se exporta a HTML de modo mejorado (por ejemplo, incluyendo los iconos de las herramientas empleadas)
  • Se añade la opción "Incrementado (Solo una vez)" para la animación
  • Las listas son ahora desplazables, por ejemplo, {a, b, Segmento[D, F], (-0.22, 1.82)}
  • Los rótulos de Función se manejan adecuadamente para Valor y Nombre y Valor (usando LaTeX)
  • La interpolación para imágenes puede desactivarse (Propiedades de Objeto > Estilo)
  • Sintaxis del producto vectorial como: u ⊗ v pulsando Alt y * para obtener el símbolo
  • Cuando se seleccionan múltiples deslizadores, pueden modificarse al unísono con las teclas-flecha
  • Cuando se seleccionan exactamente dos deslizadores, las teclas-flecha ascendente/descendente afectan a uno y las de izquierda/derecha, al otro
  • Símbolo especial para i - sqrt(-1) - Alt i
  • El Protocolo de Construcción HTML se puede guardar con cierta información extra para poder reabrirlo en GeoGebra con Archivo -> Abre
  • Función Error Gaussiano erf(x)
  • La caja de diálogo del Deslizador ahora acepta, por ejemplo "a = 2" en el campo de Nombre
  • Se suman como opciones...
    • la que permite emplear "Tipografía Java para textos LaTeX"
    • la de empleo de "Rueda Inversa de mouse o ratón"
    • resultado de ángulos desde funciones trigonométricas inversas
    • símbolo de grados automáticamente insertado en la caja de diálogo de Rota
  • Es posible seleccionar una serie de objetos al encuadrarlos para aplicar la herramienta que les Copia el Estilo Visual
  • En la Vista Algebraica, rendering de LaTeX para las funciones (opción que puede desactivarse en la barra de estilo)
  • Con un clic sobe una herramienta, al mantener pulsado el botón del mouse o ratón, se despliegan las restantes disponibles del mismo tipo.
  • Ctrl Shift B permite exportar a GeoGebraWeb desde GeoGebra 4.0.25.0

Desigualdades

  • Opción de Sombreado Inverso
Inclusión de...
  • Cónicas como, por ejemplo, en x² + y² < 25
  • Funciones como, por ejemplo, y < sin(x)
  • Funciones inversas como, por ejemplo, x<sin(y)+y

Posibilidades de las Hojas de Cálculo

  • Caja de Diálogo de Análisis de Datos
  • Caja de Diálogo de Rastreo en la Hoja de Cálculo
  • Creación de tablas
  • Importación de archivos de datos

Alternativas Experimentales

Guiones / Scripting

Se puede asociar un guion a cualquiera de los objetos de GeoGebra. Esta pretende ser una lista de comandos de GeoGebra y/o de JavaScript. Así, por ejemplo, una imagen o una circunferencia pueden actuar como un botón.

Los nuevos objetos Botón y CampoTexto han sido específicamente diseñados para asociarse a guiones o scripts. Cuando se ingresa algún texto en un campo de texto y se pulsa <Enter>, el texto pasa al guion o script como  %0, de modo que se hace posible tener comandos como...
texto = "%0"
Texto[%0,(3,4)]

El texto también pasa a un guion de tipo JavaScript como una variable 'arg' permitiendo comandos como...
ggbApplet.evalCommand('input="' + arg + '"');

GeoGebra incluye ahora un intérprete JavaScript. Cuando se exporta una hoja dinámica, el guion JavaScript de cada botón también se exporta en una función separada en el archivo HTML y el buscador se emplea para ejecutarlos vía JavaScript.

El JavaScript Global está disponible para todas las funciones y también se exporta al archivo HTML. Respaldo ampliado de comandos adicionales:

*alert("hola");
*prompt("¿Cuál es tu utilitario dinámico preferido","GeoGebra");

Operaciones con Listas

Ahora están disponibles las siguientes posibilidades....

  • <Objeto> ∈ <Lista> que establece si el objeto es un elemento de la lista
Ejemplos:
  • 7 ∈ {3, 4, 2} da false
  • 3 ∈ {3, 4, 2} da true
  • <Lista> ⊆ <Lista> que establece si la primera es subconjunto de la segunda (o es igual)
  • <Lista> ⊂ <Lista> que establece si es subconjunto propiamente dicho
  • <Lista> \ <Lista> Determina la diferencia
Nota:
Las primeras operaciones dan por resultado una variable booleana, como true o false .
La última da una lista.
Teclado.PNG

Teclado Virtual

Se pueden apreciar la nueva pantalla que expone el teclado yendo al Menú Vista -> Teclado

Será transparente en caso de estar bajo Java 1.6.0_10 o superior en un Sistema Operativo / Tarjeta Gráfica acorde.
Nota: Para controlarlo, basta dirigirse a Ayuda -> Acerca de GeoGebra / Licencia

Teclados

  • Teclados para Matemática y caracteres Griegos, Hebreo, Árabe, Coreano, Hindi, Francés, Alemán, Sueco, Noruego, Malayalam, Checo, Croata, Húngaro, Persa, Español e Inglés (USA y UK) incluyendo todos los acentos; etc
  • Respalda...
Operaciones Habilitadas
  • Opera en todas las aplicaciones, no solo en GeoGebra
  • DesplazaPíxeles reescalable
  • AltGr muestra los acentos en la fila inferior para todos los idiomas. Se admiten acentos agudos, , graves, circunflejo, cedilla, diéresis, tilde, breve, doble agudo, sólidos, tonos... etc.

Comandos

Comandos Ampliados y Mejorados

Innovaciones en Comandos

Nuevos Comandos

Los comandos marcados *operan también en la Vista CAS

  • ActualizaConstrucción[] Actualiza la construcción por re-cálculo de todos los objetos, generando nuevos número aleatorios y re-estableciendo tal índole de valores y posiciones. {
    Nota: El comando no afecta los rastros presentes. Produce efecto análogo a pulsar F9 o al de Ctrl + R y similar al de la herramienta Recálculo de Todos los Objetos del Menú Vista.
  • Ejecuta[ <Lista de Textos>] Ejecuta la lista de comandos anotados como textos.
    Ejemplo:
    Se crean los puntos A, B y el central entre ambos, C con Ejecuta[{"A=(1,1)","B=(3,3)","C=PuntoMedio[A,B]"}]
  • Ejecuta[ <Lista de Textos>, <Parámetro 1>, <Parámetro 2>, ... <Parámetro 9> ] Reemplaza %1 por el parámetro 1, %2 por el parámetro 2 y así sucesivamente en cada texto de la lista. Se pueden especificar hasta 9 parámetros. Tras tal reemplazo, las cadenas de guion resultantes son ejecutadas.
    Ejemplo:
    Ejecuta[{"PuntoMedio[%1,%2]"}, A, B}] crea el punto central entre sendos puntos A y B.
  • Ejecuta[ <Lista de Textos>] Ejecuta la lista de comandos anotados como textos.
    Ejemplo:
    Ejecuta[Encadena[{"f_{1}=1","f_{2}=1"},Secuencia["f_{"+(i+2)+"}=f_{"+(i+1)+"}+f_{"+i+"}",i,1,10]]].
Alternativa...
Ejemplos:
Si A=(1,2) Capa[A, 1, false] B=CoordenadasDinámicas[A, Si[x(A) > 3, 3, Si[x(A) < -(3), -3, Si[x(A) < 0, round(x(A)), x(A)]]], Si[x(A) < 0, 0.5, Si[y(A) > 2, 2, Si[y(A) < 0, 0, y(A)]]]]
Incluso...
A=(1,2) B=(2,3) Oculta[B] C=CoordenadasDinámicas[B, Si[Distancia[A, B] < 1, x(A), x(B)], Si[Distancia[A, B] < 1, y(A), y(B)]] Hace que A sea un punto adhesivo cuando C se desplaza por sus cercanías
Diagramas

Los siguientes comandos trazan diagramas para los correspondientes registros de distribuciones de funciones de probabilidad (conocidos, por sus siglas en inglés, como pdf):

Vinculados a Probabilidad
Vinculados a Guiones
Vinculados a Hoja de Cálculos
Específicos de GeoGebra
Controles
Vinculados a Estadísticas
Vinculados a Visibilidad
Vinculados a Funciones y Cálculo

Nuevos Atajos de Tecla y de Ratón o Mouse

  • CtrlH Expone / Oculta Objetos (no en MacOS)
  • CtrlShiftH Expone / Oculta Rótulos (no en MacOS)
  • CtrlG Expone / Oculta Objetos
  • CtrlShiftG Expone / Oculta Rótulos
  • CtrlI Invierte Selección
  • Tab Selecciona nuevo objeto (orden alfabético / de hoja dinámico, no en objetos con "Admite Selección" sin habilitar)
  • ShiftTab Selecciona objetos previos (orden alfabético / de hoja dinámico, no en objetos con "Admite Selección" sin habilitar)
  • CtrlTab alterna el foco entre la Vista Gráfica y la Hoja Dinámica
  • Page Up incrementa la capa de los objetos seleccionados
  • Page Down disminuye la capa de los objetos seleccionados
  • Las siguientes operan (junto a los modificadores Alt, Shift, Ctrl) para paneo por la Vista Gráfica cuando no hay objetos seleccionados:
    • Page Up Aumenta una pantalla
    • Page Down Disminuye una pantalla
    • Inserta Se dirige a la izquierda en la pantalla
    • Home Se dirige a la derecha en la pantalla
    • Flecha Izquierda Se dirige 1% a la izquierda del ancho de la pantalla
    • Flecha Derecha Se dirige 1% a la derecha del ancho de la pantalla
    • Flecha Ascendente Asciende 1% de la altura de la pantalla
    • Flecha Descendente Desciende 1% de la altura de la pantalla
    • CtrlM Restaura la vista estándar de la Vista Gráfica
  • CtrlShiftM Comparte
  • Botón del Menú (en teclado) abre el menú de la Vista Gráfica / Caja de Diálogo de las Object Propiedades
  • Barra Espaciadora Alterna estado de la casilla de control (si se hubiera seleccionado alguna)
  • Barra Espaciadora Ejecuta el guion (si se hubiera seleccionado alguno), como el asociado a un botón
  • CtrlShiftN Selecciona la siguiente ventana (o carga el archivo siguiente si solo uno se hubiera abierto)
  • CtrlAltN Selecciona la última ventana
  • Home se dirige al inicio de la fila (en hoja de cálculo)
  • CtrlHome se dirige a la celda A1 (en hoja de cálculo)
  • CtrlShiftK Expone / Oculta Vista Algebraica CAS
  • CtrlShiftL Expone / Oculta Protocolo de Construcción
  • Shift1 Expone / Oculta Vista Gráfica
  • Shift2 Expone / Oculta Vista Gráfica 2
  • Shift3 Reservado (para Vista 3D, próximamente)
  • CtrlShiftZ Rehace
  • CtrlFlecha-Ascendente (en Campo de Texto) Abre la tabla de símbolos
  • Clic y arrastre - con botón central o rueda del mouse o ratón para un paneo por la vista o re-escala de los ejes
  • F1 Ayuda / Ayuda para el comando en juego
  • Alti da el nuevo símbolo para la raíz cuadrada de -1 - sqrt(-1) - ί
  • Altu ∞ (era Alti)
  • Alt
  • anota el signo ⊗ (Producto Vectorial)
  • Alt- ahora ofrece el superíndice menos (no menos-o-más)
  • Tab cicla a través de los comandos acordes (Barra de Entrada)
  • CtrlShiftB exporta a GeoGebraWeb desde GeoGebra 4.0.25.0

Nuevos Parámetros Applet

  • allowStyleBar, falso por omisión
  • useBrowserForJS, verdadero por omisión

Descripción de todos los Parámetros Applet de GeoGebra

Nuevas Líneas de Argumentos de Comandos

Para emplear líneas de argumentos en los comandos es preciso asegurar que se cuenta con suficiente memoria dedicada, como, por ejemplo:
java -Xms32m -Xmx512m -jar geogebra.jar --settingsfile=geogebra.properties

--settingsfile=<Archivo>
--versionCheckAllow=[on|off|true|false] (a partir de la versión 4.0.28.0)

Descripciones de todas las Nuevas Líneas de Argumentos de Comandos

Nuevos Comandos de JavaScript

  • String getPNGBase64(double exportScale, boolean transparent, double DPI)
    eg var str = ggbApplet.getPNGBase64(1, true, 72);
  • boolean writePNGtoFile(String filename, double exportScale, boolean transparent, double DPI)
    solo para applets señaladas
    como var success = ggbApplet.writePNGtoFile("c:\\test.png", 1, false, 300);
  • boolean isIndependent(String objName) (controla si el objeto es independiente)
  • boolean isMoveable(String objName) (controla si el objeto es desplazable)
  • getBase64()
  • setBase64(String)

Descripción de todos los Métodos de JavaScript de GeoGebra]

Formato de Archivo XML de GeoGebra

El Formato de Archivo XML de GeoGebra está documentado en Referencias XML

Licencia

Ofrece libertad para copiar, distribuir y transmitir GeoGebra con fines no-comerciales. Para mayores detalles, se recomienda consultar los términos de la licencia de GeoGebra


en:Release Notes GeoGebra 4.0 it:Note di versione di GeoGebra 4.0

© 2018 International GeoGebra Institute