Note di versione di GeoGebra 4.0

Questa pagina elenca una panoramica delle nuove caratteristiche di GeoGebra 4.0. È disponibile il nuovo Manuale di GeoGebra che contiene le descrizioni dettagliate di tutti i nuovi strumenti e comandi.

Per installare GeoGebra 4.0 basta fare clic su Webstart oppure utilizzare le opzioni di Download.

GeoGebra 4.0 non è eseguibile con Java 1.4.2, quindi è necessario installare almeno la versione 5 di Java, disponibile su java.com

Compatibilità con GeoGebra 3.2

I dettagli relativi alla compatibilità con GeoGebra 3.2 sono disponibili qui.

GeoGebraPrim

La versione di GeoGebra dedicata agli studenti della scuola primaria è disponibile qui.

* Disponibilità di un numero ristretto di strumenti
* Tutti gli strumenti disponibili sono visibili
* Dimensione dei caratteri aumentata
* Oggetti più grandi e con spessore maggiore del tratto
* Visualizzazione della sola Vista Grafica
* Selezione degli oggetti semplificata
* Etichettatura degli oggetti disattivata (impostazione predefinita)
* Angoli sempre tra 0° e 180° (impostazione predefinita)
* Arrotondamento all'intero successivo (impostazione predefinita)

Strumenti

Nuovi strumenti

 Consente la creazione di un punto all'interno di un poligono, un cerchio o un'ellisse, facendo clic nella posizione desiderata
 Mantenere premuto <Alt> per vincolare un punto nell'interno di una forma (invece che al bordo)
Tracciare un rettangolo nella Vista Grafica con lo strumento Muovi per definire la zona in cui si andrà a disegnare a mano libera, oppure selezionare un'immagine già esistente per disegnare al suo interno. Il tasto destro del mouse funge da gomma.

Modifiche sugli strumenti della versione precedente

Questo strumento è stato completamente riprogrammato per semplificare l'inserimento di testo dinamico. Selezionando l'oggetto dall'elenco a discesa "Oggetti", questo è visualizzato all'interno di un rettangolo, che indica che è un oggetto dinamico, e non semplice testo statico.

Con un clic sul tasto destro del rettangolo è possibile selezionare la "Definizione" o il "Valore" di ciascun oggetto dinamico. È inoltre disponibile un'Anteprima, un elenco a discesa di Simboli e l'elenco dei simboli recentemente utilizzati. I testi possono essere spostati tramite trascinamento, mentre è selezionato lo strumento Inserisci testo.

È ora possibile muovere uno slider mediante trascinamento, mentre è selezionato lo strumento Slider, oppure mediante trascinamento, tenendo premuto il tasto destro del mouse, mentre è selezionato lo strumento Muovi.

È ora possibile muovere la Casella di testo mediante trascinamento, mentre è selezionato lo strumento Casella di controllo per mostrare/nascondere oggetti .

È ora possibile creare un luogo a partire da uno slider e un punto dipendente.

Nuove funzionalità

Nuovi tipi di oggetti

  • Le Curve implicite, ad es. x^3 + y^2 = 1 possono essere tracciate nella Vista Grafica.
  • Funzioni in più variabili, come ad es. f(x, y) = x^2 + y^2
    Queste possono essere utilizzate per definire funzioni in una sola variabile, ad es. g(x) = f(x, 2) oltre a funzioni in più variabili, come ad es. f(a,b,c)=a+b+c
  • Spezzata
 È come un poligono, ma non è chiuso. Vedere lo strumento Spezzata aperta.
 ad es. 10 ≤ x < 20 : è possibile applicare agli intervalli i comandi PuntoMedio, Max e Min.

Caratteristiche generali

  • Aggiunta la funzione log(b, x) per il logaritmo in base b
  • Esportazione del foglio di lavoro: è disponibile un'opzione di incorporamento del file .ggb in un file HTML (con codifica Base64, utilizzando il parametro 'ggbBase64')
  • Esportazione come 'GIF Animata' (l'animazione è controllata da uno slider, che funge da "orologio")
  • Lo strumento Compasso consente la selezione di un cerchio, quindi di un centro
  • Opzioni 'Intero' e 'Casuale' per gli slider
  • File -> Apri pagina Web consente il caricamento di un file .ggb presente in una pagina Web, semplicemente incollandone l'URL da un browser (suffisso .html o .ggb), oltre a consentire il caricamento di file codificati in Base 64 o con una stringa GeoGebra XML.
  • Opzione "Mostra linee intersezione troncate" nei punti di intersezione
  • Opzioni Tooltip (Proprietà dell'oggetto -> Avanzate) Attiva, Non attiva, Legenda, Prossima cella, Automatica (nella versione precedente: solo con la Vista Algebra aperta)
  • Visualizzazione corretta di formule e matrici nel foglio di calcolo
  • Digitando un'espressione del tipo ab + 1, se la variabile ab non è definita, viene automaticamente creata come ab = a * b se a e b sono numeri, oppure come ab = Distanza[a,b] se a e b sono punti.
  • LaTeX[ <Matrice> ], LaTeX[ <Vettore> ] ora sono visualizzati correttamente
  • supporto di csc(x), sec(x), cot(x), csch(x), sech(x), coth(x) e derivate
  • Vista Algebra: è ora possibile selezionare più oggetti con Maiusc-clic
  • sqrt(3 + i), cbrt(3 + i), conjugate(3 + i), arg(3 + i)
  • Opzione "Importa file di dati" nel menu contestuale del Foglio di calcolo
  • Le combinazioni di tasti in stile Windows funzionano anche nei campi testo (ad es Alt + 0 + 1 + 7 + 6 per °) [non in Mac OSX]
  • Supporto per codifica Unicode nelle espressioni per ad es. Arabia, Thai

Sono supportati tutti i sistemi numerici (eccetto Osmanya) descritti qui: Hindu-Arabic Numeral System

  • È possibile utilizzare sintassi del tipo a = a + 1 o A = A + (1, 2) per gli oggetti liberi (utile per i pulsanti)
  • Sono consentite le percentuali ad es. a = 3.4%
  • Supporto per la visualizzazione di numeri con cifre localizzate (al momento in Arabo, Tamil, Thai e Malayalam)
  • Supporto per potenze in formato apice con più di una cifra, ad es. y = x²², x⁻¹
  • Alt + - ora restituisce un segno meno in formato apice (non un meno-o-più)
  • In greco e arabo i punti sono etichettati con lettere localizzate
  • Blocca sulla griglia funziona con testi, immagini, poligono, segmenti, vettori, ecc (utilizza il primo punto)
  • È possibile creare poligoni a partire da una lista di punti con il comando Poligono[lista].
  • È possibile trascinare il lato di un poligono
  • Miglioramento della visualizzazione delle equazioni LaTeX e implementazione quasi completa di LaTeX (con JLaTeXMath)
  • È possibile inserire legende in formato LaTeX (inserendole tra $ $ ) (per tutti gli oggetti tranne caselle di controllo, campi testo e pulsanti)
  • "Blocca su oggetto/griglia" dinamico per i nuovi oggetti.
  • Ampiezza degli angoli visibili modificata automaticamente
  • Visualizzazione di coppie di parentesi collegate nello stesso colore, nella barra di inserimento
  • Anteprima per angoli, rette perpendicolari, rette parallele, bisettrici e assi creati con gli appositi strumenti
  • Supporto per inserimento funzioni del tipo sin²(x), sin³(x), sin⁻¹(x)
  • Supporto per visualizzazione di ad es. f(x) = sin²(x) come in LaTeX[ sin(x)^2 ]
  • È ora possibile applicare trasformazioni alle curve parametriche, come ad es. Simmetrico[Curva[t^2, t^3, t, -1, 1], asseY]
  • Hit testing nella Vista Grafica per Integrale, Pendenza, Boxplot, DiagrammaBarre, Istogramma
  • Opzione per spessore del tratto nullo in Integrale, Pendenza, DiagrammaBarre, Istogramma, Angolo
  • Nelle applet il cursore è visualizzato direttamente nella barra di inserimento
  • Semplificazione del testo dinamico: a"testo"b è equivalente al 'vecchio' a+"testo"+b
  • Guida-> Informazioni/Licenza -> Informazioni di Sistema copia le informazioni utili al debugging negli Appunti del sistema.
  • Ctrl + Maiusc + M copia solo il tag <applet>negli Appunti, per una eventuale esportazione successiva in MediaWiki, Moodle etc etc
  • Opzioni per le legende:
    •  %v valore dell'oggetto
    •  %n nome dell'oggetto
    •  %x ascissa dell'oggetto (o coefficiente della x in una retta in forma a x + b y + c = 0)
    •  %y ordinata dell'oggetto (o coefficiente della y in una retta in forma a x + b y + c = 0)
    •  %z termine noto 'c' di una retta in forma a x + b y + c = 0 (anche: coordinata 'z' - per la futura Vista 3D)
  • Gli strumenti personalizzati ora possono avere come oggetti finali angoli, integrali, somme superiori/inferiori, istogrammi, boxplot e diagrammi a barre.
  • Gli strumenti personalizzati con oggetto iniziale numerico o angolo possono essere ora utilizzati direttamente con un clic nella Vista Grafica per attivare la finestra di dialogo.
  • Attivazione della traccia disponibile per poligoni, liste e luoghi (utile ad es. per RisolviEDO[x + y, y² - 1, x(A), y(A), 5, 0.05] )
  • Un clic del tasto destro del mouse dopo avere selezionato più oggetti ora apre un menu, non la finestra di dialogo Proprietà degli oggetti
  • Eliminato il popup di scelta quando si fa clic su più oggetti.
  • I testi creati nella barra di inserimento sono visualizzati nel centro della Vista Grafica (invece che in corrispondenza dell'origine)
  • Testi e luoghi sono ora visibili nella Vista Algebra (impostazione predefinita: Ausiliari)
  • Nella relativa Barra di stile è disponibile un'opzione per elencare gli oggetti per tipo nella Vista Algebra
  • Slider: intervallo e incremento dinamici
  • Nuove opzioni di esportazione grafica: PNG trasparenti e EMF+
  • Nuove opzioni di esportazione del foglio di lavoro: Consenti ridimensionamento, Rimuovi interruzioni di riga, Usa il browser per gli script JavaScript
  • Opzioni per l'esportazione di fogli di lavoro multipli in HTML: File singolo (Schede) eFile collegati
  • Opacità dinamica degli oggetti in Proprietà -> Avanzate
  • Colori dinamici: opzioni per RGB, HSL, HSV in Proprietà -> Avanzate
  • Le rette ora hanno un comportamento "da funzioni", ad es.
 a:y=2x
 a(3)
  • Mantenendo premuto il tasto Alt mentre si disegna un poligono o una spezzata aperta si ottengono angoli multipli di 15°
  • Miglioramento dell'esportazione in HTML del Protocollo di costruzione (ad es.: inclusione delle icone degli strumenti)
  • atan2(x,y)
  • Nuova opzione per l'animazione: "Crescente (una volta)"
  • Le liste possono essere trascinate, ad es. {a, b, Segmento[D, F], (-0.22, 1.82)}
  • Le etichette delle funzioni utilizzano il formato LaTeX per 'Valore' e 'Nome e valore' (using LaTeX)
  • È ora possibile disattivare l'interpolazione per le immagini (Proprietà > Stile)
  • Sintassi per il prodotto vettoriale: u ⊗ v (Utilizzare Alt + * per ottenere il simbolo ⊗ )
  • Selezionando più slider è possibile modificarne contemporaneamente i valori, utilizzando i tasti freccia
  • Selezionando esattamente due slider, i tasti freccia Su/Giù modificano uno slider, Destra/Sinistra l'altro
  • Simbolo speciale per sqrt(-1): Alt + i
  • Il file HTML del protocollo di costruzione viene salvato con più informazioni, in modo che possa essere riaperto in GeoGebra con File -> Apri
  • Funzione degli errori di Gauss erf(x)
  • La finestra di dialogo degli slider ora accetta anche ad es. "a=2" nel campo Nome
  • Aggiunta l'opzione "Usa i caratteri Java per i testi LaTeX
  • Aggiunta l'opzione "Inverti la rotellina del mouse"
  • Aggiunta l'opzione "Restituisci l'angolo dalle funzioni trigonometriche inverse"
  • Simbolo dei gradi inserito automaticamente nella finestra di dialogo Ruota
  • Selezione di oggetti con un rettangolo di selezione prima di selezionare lo strumento "Copia stile visuale"
  • Visualizzazione dell'espressione delle funzioni in formato LaTeX nella Vista Algebra (opzione, può essere disattivata nella barra di stile)
  • Fare clic e mantenere premuto un pulsante di uno strumento per visualizzare gli altri strumenti disponibili

Disequazioni

  • Opzione per il Riempimento inverso (colorazione della zona soluzioni o della complementare)
  • Supporto per le coniche, ad es. x² + y² < 25
  • Supporto per le funzioni, ad es. y < sin(x)
  • Supporto per le funzioni inverse, ad es. x<sin(y)+y

Nuove caratteristiche del Foglio di calcolo

  • Finestra di dialogo per l'analisi dei dati
  • Finestra di dialogo per Traccia nel foglio di calcolo
  • Crea tabella
  • Importa file di dati

Caratteristiche sperimentali

  • Strumenti > Organizza strumenti > Apri
  • Esportazione in Asymptote
  • Pulsante "Mostra Guida online" con errori di sintassi
  • Testi dinamici LaTeX più efficienti con ad es. \frac{x_A}{y_A}=\jlmDynamic{x(A)/y(A)}
  • Intervalli: "3 < x && x < 5" è ora "3 < x < 5"
  • Intersezione[retta, poligono]
  • Valori booleani nelle funzioni, ad es. f(x) = x (x == round(x))
  • Intersezione e unione di poligoni
  • Calcolatore di probabilità
  • Assi a sola direzione positiva, origine modificabile, griglia polare
  • Colore di sfondo per testi e riempimenti (al momento solo tramite la barra di stile o il foglio di calcolo)
  • RisolviEDO[ <f'(x,y)>, <x iniziale>, <y iniziale>, <x finale>, <Passo> ]
  • RisolviEDO[ <y'>, <x'>, <x iniziale>, <y iniziale>, <t finale>, <Passo> ]
  • RisolviEDO[ <b(x)>, <c(x)>, <f(x)>, <x iniziale>, <y iniziale>, <y' iniziale>, <x finale>, <Passo> ]
 vedere anche ic omandi RiempiCelle[ ], Primo[ <Luogo>, <Numero> ] e Lunghezza[ <Luogo> ] 
  • Due Viste Grafiche
  • Tratteggio e riempimento per poligoni, coniche, pendenza, somma superiore, etc
  • DiagrammaRamoFoglia[ <Lista> ]
  • DiagrammaRamoFoglia[ <Lista>, <Regolazione -1|0|1> ]
  • Suono[ <Nota>, <Durata>, <Lunghezza>]
  • Suono[ <Sequenza di note>, <Strumento> ]
  • Suono[ <File> ]
  • Scorri[<Oggetto>, <Retta>, <Rapporto>]
  • Dilata[<Oggetto>, <Retta>, <Rapporto>]

La retta in realtà può essere anche un segmento o un vettore.

  • PuntoIn[x>0 && y>0 && x+y<3]
  • <param = "useBrowserForJS" value = "true"/>
  • Esportazione in HTML5
  • LaTeX[If[x < 3, x, x + 1]]
  • Caricamento su GeoGebraTube
  • Percorsi composti, ad es. Punto[{Segmento[B, A], Segmento[B, C], Segmento[B, D], (1,1), Circonferenza[A,B], x y = 1}]
 ad es. Punto[{Segmento[D, C], Semicirconferenza[B, C], Segmento[B, A], Semicirconferenza[D, A]}]
  • Animazione dei punti su percorsi (ad es. circonferenze, rette, percorsi composti )
  • Punto[x>3]
  • Distanza[ <Punto>, <Oggetto> ]
  • PuntoDistMin[ <Punto>, <Oggetto> ]
 Questi due comandi sono applicabili a circonferenze, curve, rette, segmenti, parabole, iperboli, ellissi, curve implicite e luoghi. Se applicati a funzioni operano sulle distanze verticali. Anche Distanza[ <Punto>, <Segmento> ] ora funziona senza problemi.
  • Anteprima per i testi in formato LaTeX
  • Nuovo editor per testi e script, con colorazione della sintassi e delle parentesi corrispondenti
  • Zip[<Espressione>,,<list 1>, ...] -- ad es. Zip[PuntoMedio[A,B],A,lista1,B,lista2] è la forma compatta di

Successione[PuntoMedio[lista1(k),lista2(k)],k,1,Min[Lunghezza[lista1],Lunghezza[lista2]]

  • Aggiunta la funzione di errore gaussiana erf(x)
  • I luoghi possono essere colorati con riempimento o tratteggio
  • CurvaImplicita[ <Lista di punti> ]
 Il numero di punti della lista deve essere 9, 14, 20, 26, 33, etc

Le curve implicite create in questo modo possono essere trasformate con i comandi: Trasla, Ruota, Dilata, Simmetrico (rispetto a un punto o una retta)

Scripting

Ora tutti gli oggetti di GeoGebra possono essere associati a uno script, che può essere una lista di comandi di GeoGebra e/o JavaScript. Quindi ad esempio un'immagine o una circonferenza possono avere la stessa funzione di un pulsante.

I nuovi oggetti Pulsante e CampoTesto sono stati progettati appositamente per supportare gli script. Digitando del testo in un campo testo e premendo Invio, il testo viene passato allo script come %0, quindi è possibile avere comandi del tipo:
testo = "%0"
Testo[%0,(3,4)]

Anche il testo viene passato a JavaScript come variabile 'arg', consentendo comandi del tipo:
ggbApplet.evalCommand('input="' + arg + '"');

GeoGebra ora dispone di un'interprete JavaScript incorporato. Nell'esportazione in un foglio di lavoro dinamico, il codice JavaScript di ciascun pulsante viene esportato in una funzione separata del file HTML è il browser esegue il JavaScript.

Global JavaScript è disponibile per tutte le funzioni, ed è esportato nel file HTML .

Ulteriori comandi supportati:

* alert("ciao");
* prompt("Qual è il tuo software preferito","GeoGebra");

Operazioni sulle liste

<Oggetto> ∈ <Lista> è elemento di (appartiene a)

<Lista> ⊆ <Lista> è sottoinsieme di

<Lista> ⊂ <Lista> è sottoinsieme proprio di

<Lista> \ <Lista> differenza di insiemi

Tastiera virtuale

Per visualizzare la nuova tastiera virtuale: Visualizza -> Tastiera

L'aspetto della tastiera è trasparente se si esegue Java 1.6.0_10 o superiore su un sistema operativo / scheda grafica supportati (Informazioni di sistema: Guida -> Informazioni)

  • Sono disponibili tastiere per matematica, greco, italiano, ebreo, arabo, coreano, hindi, francese, tedesco, svedese, norvegese, malayam, ceco, croato, ungherese, persiano, spagnolo e inglese, compresi gli accenti.
  • Supporta i codici Windows con combinazione di tasti, ad es. Alt + 0 + 1 + 7 + 6
  • Funziona in tutte le applicazioni, non solo in GeoGebra
  • La finestra può essere ridimensionata
  • AltGr visualizza gli accenti sulla riga più bassa della tastiera. Accenti supportati: acuto, grave, circonflesso, cediglia, umlaut, caron, tilde, breve, puntato, ogonek, acuto doppio, solido, dialytika.

Comandi

Comandi migliorati

  • Luogo [<Punto che crea il luogo>, <Slider>]
 Determina il luogo di un punto dipendente al variare dei valori assunti dallo slider.
  • Estremo [ <Funzione>, <Valore x iniziale>, <Valore x finale>]
 Calcola gli estremi della funzione tra x iniziale e x finale.
 La funzione deve essere continua nell'intervallo, altrimenti negli intorni dei punti di discontinuità potrebbero essere calcolati falsi estremi.
 (nella versione precedente questo comando era applicabile solo ai polinomi)
  • Intersezione[ <Funzione> , <Funzione>, <Valore x iniziale>, <Valore x finale> ]
  • Tangenti[ <Conica>, <Punto> ] ora è applicabile anche come [ <Punto>, <Conica> ]
  • Tangenti[ <Funzione>, <Punto> ] ora è applicabile anche come [ <Punto>, <Funzione> ]
  • Derivate di funzioni in più variabili: f(x,y) = x^2 + y, Derivata[ f(x,y), x ], Derivata[ f(x,y), x, 2 ]
  • I comandi ContaSe e TieniSe ora sono applicabili anche a espressioni non numeriche
 ad es. ContaSe[ x == (1,2), {A, B, C} ]
 ad es. ContaSe[ x == "hello", lista ]
  • TabellaTesto[ <Matrice>, <Stringa> ] ora supporta le parentesi, specificando ||||, ||, {}, [] o () nella Stringa, divisori orizzontali tra le righe specificando _ e divisori verticali specificando |
 ad es. TabellaTesto[{{1,2},{3,4}},"c()"]
 ad es. TabellaTesto[{{1,2},{3,4}},"c|_"]
 ad es. TabellaTesto[{{1,2},{3,4}},"c||"]
 ad es. TabellaTesto[{{1,2},{3,4}},"c||||"]
 Semplifica ora funziona meglio con le frazioni, ad es. Semplifica[(x-1)/(x^2-2x+1)]
 Questo comando è stato migliorato e restituisce risultati più coerenti, oltre ad essere applicabile con problemi più complessi, come ad es. Fattorizza[ x^33 - 1 ]
Restituisce i vertici di un poligono
  • Integrale[ <Funzione>, <Valore x iniziale>, <Valore x finale>, <Booleano Valutazione> ]
  • IntegraleTra[ <Funzione>, <Funzione>, <Valore x iniziale>, <Valore x finale> ]
  • IntegraleTra[ <Funzione>, <Funzione>, <Valore x iniziale>, <Valore x finale>, <Booleano Valutazione> ]
  Gli integrali possono essere visualizzati graficamente ma non calcolati quando Valutazione = false
  • Prodotto[<Lista>,<Indice max>] (simile a Somma[<Lista>,<Indice max>])
  • Istogramma[ <Lista degli estremi delle classi>, <Lista dei dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
  • Istogramma[ <Booleano Cumulativa>, <Lista degli estremi delle classi>, <Lista dei dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
 Nuove opzioni per gli istogrammi cumulativa e fattore di scala della densità.  
 Se Usa Densità = true le altezze delle barre dell'istogramma sono calcolate come segue: 
       altezza = (fattore di scala * frequenza) / ampiezza della classe 
 Se non è specificato un fattore di scala il valore predefinito è 1. 
 Se Usa Densità = false  non verrà applicata la scala di densità e l'altezza delle barre dell'istogramma è data dai rispettivi valori delle frequenze.

Nuovi Comandi

I comandi con un * sono applicabili anche nella Vista CAS

  • Identica[ <Numero> ]
 genera una matrice identica dell'ordine indicato
  • CerchioIn[ <Punto>, <Punto>, <Punto> ]
  • LaTeX[ <Oggetto>, <Booleano per la sostituzione delle variabili>, <Booleano Mostra nome> ]
  • OraData[]
 Restituisce una lista del tipo {647, 59, 39, 23, 28, 2, 2011, "February", "Monday", 2}
 contenete ora e data correnti nel seguente ordine:
 millisecondi, secondi, minuti, ora (0 - 23), data, mese (1-12), anno, mese (in testo), giorno (in testo), giorno (1 = Domenica, 2 = lunedì etc)
  • Min[ <Intervallo> ]
  • Max[ <Intervallo> ]
  • PuntoMedio[ <Intervallo> ]
  • Min[ <Funzione>, <Valore x iniziale>, <Valore x finale> ]
 Calcola il minimo della funzione nell'intervallo indicato.
 La funzione deve avere un solo punto di minimo nell'intervallo.
  • Max [<Funzione>, <Valore x iniziale>, <Valore x finale> ]
 Calcola il massimo della funzione nell'intervallo indicato.
 La funzione deve avere un solo punto di massimo nell'intervallo.
  • Massimizza[ <Numero dipendente>, <Numero indipendente> ]
 Calcola il numero indipendente che determina il valore massimo del numero dipendente. 
 Il numero indipendente deve essere uno slider e l'intervallo di tale slider verrà utilizzato come intervallo valido per il calcolo.
 Se la costruzione è particolarmente complicata, questo comando potrebbe fallire o terminare automaticamente la sua esecuzione a causa di un utilizzo troppo elevato dei tempi di calcolo del processore. 
  • Minimizza[ <Numero dipendente>, <Numero indipendente> ]
 Calcola il numero indipendente che determina il valore minimo del numero dipendente.
 Il numero indipendente deve essere uno slider e l'intervallo di tale slider verrà utilizzato come intervallo valido per il calcolo. 
 Se la costruzione è particolarmente complicata, questo comando potrebbe fallire o terminare automaticamente la sua esecuzione a causa di un utilizzo troppo elevato dei tempi di calcolo del processore. 
  • SommaSinistra[ <Funzione>, <Valore x iniziale>, <Valore x finale>, <Numero di Rettangoli> ]
 Calcola la somma sinistra della funzione nell'intervallo [a,b] usando n rettangoli. 
 Nota: Il comando disegna anche i relativi rettangoli.
  • SommaRettangoli[ <Funzione>, <Valore x iniziale>, <Valore x finale>, <Numero di Rettangoli>, <Posizione d del primo rettangolo> ]
 Calcola l'integrale numerico della funzione nell'intervallo [a,b] utilizzando il metodo dei rettangoli con n rettangoli. 
 L'altezza dei rettangoli è calcolata a partire da una frazione d di ciascun intervallo (0<=d<=1). 
 Quando d=0 questo comando è equivalente al comando SommaInferiore[], mentre quando d=1 è equivalente al comando SommaSuperiore[].
 Nota: Il comando disegna anche i relativi rettangoli.
  • AvviaAnimazione[ ]
  • AvviaAnimazione[ <Slider> ]
  • AvviaAnimazione[ <Booleano> ]
  • Ordinale[ < Intero> ]
 Trasforma un numero cardinale in uno ordinale (in formato testo)
 es. Ordinale[5] restituisce "5°" 
  • ParametroPercorso[ <Punto su un percorso> ]
 ad es. trasforma un punto su una circonferenza in uno slider
  • Punto[ <Oggetto>, <Parametro> ]
 ad es. Punto[c, a] (per una circonferenza c e uno slider a)
  • FattoriPrimi[ <Numero> ]
 Restituisce la lista di numeri primi il cui prodotto è uguale al numero dato.  (funziona per i numeri fino a 9 007 199 254 740 992)
 ad es. FattoriPrimi[1] restituisce {}
  ad es. FattoriPrimi[23] restituisce {23}
  ad es. FattoriPrimi[24] restituisce {2, 2, 2, 3}
  • Fattori[<Numero>]
 Restituisce una lista di liste {numero primo,esponente} tale che il prodotto dei numeri primi, elevati al corrispondente esponente, 
  è uguale al numero dato. ad es. Fattori[3072] restituisce {(2,10),(3,1)}
  • PosizioneDi[ <Oggetto>, <Lista> ]
  • PosizioneDi[ <Oggetto>, <Lista>, <Posizione di riferimento> ]
  • PosizioneDi[ <Testo>, <Testo> ]
  • PosizioneDi[ <Testo>, <Testo>, <Posizione di riferimento> ]
  • DiagrammaRamoFoglia[ <Lista> ]
  • DiagrammaRamoFoglia[ <Lista> , <Regolazione -1|0|1> ]
  • GraficoResidui[<Lista di punti>, <Funzione>]
  • DiagrammaPunti[<Lista di Numeri>]
  • PoligonoFrequenza[ <Lista degli estremi delle classi>, <Lista altezze> ]
  • PoligonoFrequenza[ <Lista degli estremi delle classi>, <Lista dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
  • PoligonoFrequenza[ <Booleano Cumulativa>, <Lista degli estremi delle classi>, <Lista dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
  • Inviluppo[ <Lista di punti> ,<Percentuale> ]
 Genera un "Inviluppo caratteristico (Characteristic Hull)" come descritto qui: http://www.geosensor.net/papers/duckham08.PR.pdf
 Quando la percentuale è 1, viene determinato l'inviluppo convesso. 
 Al decrescere della percentuale, l'area dell'inviluppo decresce di conseguenza.
  • InviluppoConvesso[ <Lista di punti> ]
  • MinimoAlberoRicoprente[ <Lista di punti> ]
  • TriangolazioneDelaunay[ <Lista di punti> ]
  • CommessoViaggiatore[ <Lista di punti> ]
  • Voronoi[ <Lista di punti> ]
 Traccia un diagramma di Voronoi 
  • DistanzaMinima[ <Lista di segmenti>, <Punto iniziale>, <Punto finale>, <Booleano Peso> ]
  • Perimetro[ <Luogo> ]
 Utile per il comando DistanzaMinima[ ]
  • IndiceSelezionato[ <Lista> ]
  • ElementoSelezionato[ <Lista> ]
 Questi due comandi restituiscono la posizione/elemento di una lista visibile (ad es. una casella combinata), selezionata dall'utente. 
 Le caselle combinate sono attualmente disponibili solo nella Vista Foglio di calcolo (con l'opzione Usa pulsanti e caselle di controllo abilitata). 
  • ImmagineStrumento[ <Numero> ]

Copia l'icona dello strumento selezionato nella Vista Grafica. I numeri relativi a ogni strumento sono elencati qui: http://www.geogebra.org/trac/browser/trunk/geogebra/geogebra/euclidian/EuclidianConstants.java

  • GraficoLento[ <Funzione> ]
  • Campione[ <Lista>, <Dimensione> ]
  • Campione[ <Lista>, <Dimensione>, <Booleano per la sostituzione> ]
  • TestoVerticale[ <Testo> ]
  • RuotaTesto[ <Testo>, <Angolo> ]
  • Spezzata[ <Lista di punti> ]
  • Spezzata[ <Punto>, <Punto>, <Punto>, ... ]
  • PoligonoRigido[<Punto libero>, ..., <Punto libero> ]
 Genera un poligono, la cui forma è invariabile. Per traslare il poligono, trascinare il primo vertice. Per ruotare il poligono, trascinare il secondo vertice. 
  • Semplifica[ <Text> ]
 Semplifica, se possibile, espressioni di testo, rimuovendo ad esempio termini negativi ridondanti. Ad es. Semplifica["f(x) = "+a+"x²+"+b+"x+"+c]
 Nota: LaTex[f] in genere fornisce risultati migliori ed è più intuitivo
  • RadiciCompesse[ <Polinomio> ]
  • ImpValore[ <Booleano>, <0|1> ]
 Imposta lo stato di un valore booleano / casella di controllo
 1 = true, 0 = false
  • ImpValore[ <Lista>, <Elemento>]
 Imposta l'elemento selezionato di una lista visibile (casella combinata)
  • ImpValore[ <Oggetto> , <Oggetto> ]
 Utile nello scripting ad es. ImpValore[a, b]
  • ImpValore[ <Lista>, <Numero>, <Oggetto> ]
  Utile nello scripting ad es. ImpValore[lista1, CasualeTra[1,3], CasualeTra[1,10]]
  • AggiornaCostruzione[]
 Utile nello scripting. Aggiorna tutti i numeri casuali (come Ctrl-R)
  • Esegui[<Lista di stringhe>]
 Esegue una lista di comandi, ad es.  Esegui[Unisci[{"f_{1}=1","f_{2}=1"},Successione["f_{"+(i+2)+"}=f_{"+(i+1)+"}+f_{"+i+"}",i,1,10]]].
  • Esegui[<Lista di stringhe>,<Parametro %0>,....,<Parametro %9>]
 Sostituisce il valore x al parametro %x. Esegue la lista dei comandi risultanti, ad es.  Esegui[{"PuntoMedio[%0,%1]"},A,B}].
  • ApplicaMatrice[ <Matrice>, <Oggetto> ]
  • ElementoCasuale[ <Lista> ]
  • Mischia[ <Lista> ]
  • Posizione[ <Lista> ]
  • PosizioneMedia[ <Lista> ]
  • MatriceRigheRidotte[ <Matrice> ]
  • DSCampione[ <Lista di numeri> ]
 Calcola la deviazione standard del campione
  • DSXCampione[ <Lista di punti> ], DSYCampione[ <Lista di punti> ]
 Calcola la deviazione standard di una coordinata
  • DSX[ <Lista di punti> ], DSY[ <Lista di punti> ]
 Calcola la deviazione standard di una coordinata
  • VarianzaCampione[ <Lista di numeri> ]
 Calcola la varianza campionaria
  • Spearman[<Lista di punti>]
  • Spearman[<Lista di numeri>, <Lista di numeri>]
calcola il coefficiente di correlazione di Spearman
  • Punto[ <Lista> ]
 ad es. Punto[ {1, 2} ]
 ad es. Punto[ { {1, 2}, {3, 4} } ]
  • ListaPunti[ <Lista> ]
 ad es. ListaPunti[ { {1, 2}, {3 ,4}} ] 
  • ListaZeri[ <Lista> ]
 ad es. ListaZeri[ {1, 2, 3} ]
  • AnalisiSintassiNumero[ <Numero>, <Testo> ]
 ad es. AnalisiSintassiNumero[a,"%0"] in uno script GeoGebra 
  • AnalisiSintassiFunzione[ <Funzione>, <Testo> ]
 ad es. AnalisiSintassiFunzione[f,"%0"] in uno script GeoGebra
  • Poligono[ <Lista di punti> ]
  • RegCrescita[<Lista di punti>]
Calcola una funzione del tipo a*b^x utilizzando i punti della lista.
(Proprio come il comando RegExp[ Lista di punti ], per gli utenti che non conoscono il significato di crescita esponenziale). 
  • Regressione[<Lista di punti>,<Lista di funzioni>]
Calcola una combinazione lineare delle funzioni e dei punti della lista. .
Ad es. dati i punti A, B, C, ...
  L={A, B, C, ...}, f(x)=1, g(x)=x, h(x)=e^x, F={f,g,h}
 il comando
  Regressione{L,F}
 calcola una funzione di errore quadratico minimo reg(x) = a + b x + c e^x
  • SommaQuadratiErrori[ <Lista di punti>, <Funzione> ]
 Calcola la somma dei quadrati delle differenze (SSE) tra le ordinate 
  dei punti della lista e i valori che assume la funzione in corrispondenza delle loro ascisse. 
 Data la lista: L={A,B,C,D,E}
 e definite:
 f(x)=RegPol[L,1] e g(x)=RegPol[L,2]
 allora è possibile determinare la migliore regressione, cioè quella avente la minima 
 somma dei quadrati degli errori  (Gauss), confrontando:
 sse_f=SommaQuadratiErrori[L,f] e sse_g=SommaQuadratiErrori[L,g].
  • CoeffDeterminazione[ <Lista di punti>, <Funzione> ]
  • Numeratore[ <Funzione> ] *
  • Denominatore[ <Funzione> ] *
  • FrazioniParziali[ <Funzione> ] *
  • Limite[ <Funzione>, <Valore> ] *
  • LimiteDestro[ <Funzione>, <Valore> ] *
  • LimiteSinistro[ <Funzione>, <Valore> ] *
  • Fattori[ <Polinomio> ] *
  • Grado[ <Polinomio> ] *
  • Coefficienti[ <Polinomio> ] *
  • Coefficienti[ <Conica> ]
Restituisce la lista dei coefficienti di: x², y², 1, xy, x, y
  • Quoziente[ <Polinomio>, <Polinomio> ] *
  • Resto[ <Polinomio>, <Polinomio> ] *
  • Asintoto[ <Funzione> ]
  • Asintoto[ <Implicit Curve> ]
  • CasualeUniforme[ <Min>, <Max> ]
  • Eccentricità[ <Conica> ]
  • Lunghezza[ <Testo> ]
  • Lunghezza[ <Luogo> ]
 Vedere RisolviEDO[ ]
  • Estrai[ <Testo>, <Inizio>, <Fine> ]
  • Primo[ <Testo>, <Numero>]
  • Primo[ <Luogo>, <Numero>]
 Vedere RisolviEDO[ ]
  • Primo[ <Testo>]
  • Ultimo[ <Testo>, <Numero>]
  • Ultimo[ <Testo>]
  • Testo[ <Oggetto>, <Punto>, <Booleano per la sostituzione delle variabili>, <Booleano per la formula LaTeX > ]
  • Simmetrico[ <Circonferenza>, <Oggetto> ]
 Inversione circolare
  • CoordinateDinamiche[ <Punto>, <Numero>, <Numero> ]
 A=Punto[asseX]
 B=Punto[asseY]
 CoordinateDinamiche[B, Min[x(B),x(A)],0]
 ImpVisibileInVista[B, 1, false]
 ImpLivello[C, 1]
 Ora C non può essere spostato alla destra di A
 A=(1,2)
 ImpVisibileInVista[A, 1, false]
 B=CoordinateDinamiche[A, Se[x(A) > 3, 3, Se[x(A) < -(3), -3, Se[x(A) < 0, round(x(A)), x(A)]]], Se[x(A) < 0, 0.5, Se[y(A) > 2, 2, Se[y(A) < 0, 0, y(A)]]]]
 A=(1,2)
 B=(2,3)
 Nascondere B
 C=CoordinateDinamiche[B, Se[Distanza[A, B] < 1, x(A), x(B)], Se[Distanza[A, B] < 1, y(A), y(B)]]
 C viene attratto da A se viene spostato sufficientemente vicino ad esso 
  • PuntoIn[ <Regione> ]
  • TestRegione[ <Punto>, <Regione> ]
  • Elemento[ <Matrice>, <Riga>, <Colonna> ]
  • DistribuzioneT[ <Gradi di libertà>, <Valore variabile> ]
  • DistribuzioneTInversa[ <Gradi di libertà>, <Probabilità> ]
  • DistribuzioneF[ <Gradi di libertà numeratore>, <Gradi di libertà denominatore>, <Valore variabile> ]
  • DistribuzioneFInversa[ <Gradi di libertà numeratore>, <Gradi di libertà denominatore>, <Probabilità> ]
  • Gamma[ <Alfa>, <Beta>, <Valore variabile> ]
  • GammaInversa[ <Alfa>, <Beta>, <Probabilità> ]
  • Cauchy[ <Mediana>, <Scala>, <Valore variabile> ]
  • CauchyInversa[ <Mediana>, <Scala>, <Probabilità> ]
  • ChiQuadro[ <Gradi di libertà>, <Valore variabile> ]
  • ChiQuadroInversa[ <Gradi di libertà>, <Probabilità> ]
  • Esponenziale[ <Media>, <Valore variabile>]
  • EsponenzialeInversa[ <Media>, <Probabilità> ]
  • Weibull[ <Forma>, <Scala>, <Valore variabile> ]
  • WeibullInversa[ <Forma>, <Scala>, <Probabilità> ]
  • Binomiale[ <Numero di successi>, <Probabilità di successo>, <Valore variabile>, <Booleano Cumulativa> ]
  • InverseBinomial[ <Numero di successi>, <Probabilità di successo>, <Probabilità> ]
  • Pascal[ <Numero di successi>, <Probabilità di successo>, <Valore variabile> , <Booleano Cumulativa> ]
  • PascalInversa[ <Numero di successi>, <Probabilità di successo>, <Probabilità> ]
  • Poisson[ <Numero di successi>, <Probabilità di successo>, <Valore variabile> , <Booleano Cumulativa> ]
  • PoissonInversa[ <Numero di successi>, <Probabilità di successo>, <Probabilità> ]
  • IperGeometrica[ <Dimensione popolazione>, <Numero di successi>, <Dimensione campione>, <Valore variabile> , <Booleano Cumulativa> ]
  • IperGeometricaInversa[ <Dimensione popolazione>, <Numero di successi>, <Dimensione campione>, <Probabilità> ]
  • Zipf[ <Numero di elementi>, <Esponente>, <Valore variabile> , <Booleano Cumulativa> ]
  • ZipfInversa[ <Numero di elementi>, <Esponente>, <Probabilità> ]
  • CopiaOggettoLibero[ <Oggetto> ]
  • ImpColore[ <Oggetto>, "colore" ]
  • ImpColore[ <Oggetto>, <Rosso>, <Verde>, <Blu> ]
  • ImpColoreSfondo[ <Oggetto>, "colore" ]
  • ImpColoreSfondo[ <Oggetto>, <Rosso>, <Verde>, <Blu> ]
  • ImpColoreDinamico[ <Oggetto>, <Rosso>, <Verde>, <Blu> ]
  • ImpCondizioneMostraOggetto[ <Oggetto>, <Condizione> ]
  • ImpCoordinate[ <Punto>, <x>, <y> ]
  • ImpRiempimento[ <Oggetto>, <Numero> ]
  • ImpDimensionePunto[ <Punto>, <Numero> ]
  • ImpStilePunto[ <Punto>, <Numero> ]
  • ImpSpessoreLinea[ <Linea>, <Numero> ]
  • ImpStileLinea[ <Linea>, <Numero> ]
  • ImpLivello[ <Oggetto>, <Livello> ]
  • SelezionaOggetti[ ]

elimina la selezione

  • SelezionaOggetti[ <Oggetto>, <Oggetto>, ... ]
  • MostraLivello[ <Numero> ]
  • NascondiLivello[ <Numero> ]
  • ImpFisso[ <Oggetto>, <True | False> ]
  • MostraEtichetta[ <Oggetto>, <True | False> ]
  • Rinomina[ <Oggetto>, <Name> ]
  • RiempiRiga[ <Riga>, <Lista> ]
  • RiempiColonna[ <Colonna>, <Lista> ]
  • RiempiCelle[ <Intervallo celle>, <Oggetto> ]
 ad es. RiempiCelle[A1:B20, loc1] per ottenere le coordinate di un luogo nel Foglio di calcolo
 ad es. RiempiCelle[A1:B20, 3] per copiare '3' in più celle
 ad es. RiempiCelle[A1:B2, {{1,2},{3,4}}] per copiare una matrice nel Foglio di calcolo [caratteristica da implementare]
  • RiempiCelle[ <Cella inizio>, <Lista> ]
  • RiempiCelle[ <Cella inizio>, <Matrice> ]
  • ImpVistaAttiva[ <Numero 1|2> ]
 Imposta la Vista attiva (il numero 3 è riservato per la Vista 3D della prossima versione)
  • ZoomAvanti[ <Fattore di scala> ]
  • ZoomIndietro[ <Fattore di scala> ]
  • ZoomAvanti[ <Fattore di scala>, <Centro> ]
  • ZoomIndietro[ <Fattore di scala>, <Centro> ]
  • SpostaVista[ <x>, <y> ]
  • Cella[ <Colonna>, <Riga> ]
  • ImpLegenda[ <Oggetto>, <Testo> ]
  • ImpModoEtichetta[ <Oggetto>, <Numero> ]
  • Slider[ <Min>, <Max>, <Incremento>, <Velocità>, <Ampiezza>, <Angolo>, <Orizzontale>, <Animazione>, <Casuale>]
 Solo i primi due argomenti sono obbligatori.
  • CasellaControllo[<Legenda>, <Lista degli oggetti da nascondere>] (possono essere utilizzati uno, due o nessun parametro)
  • CampoTesto[], CampoTesto[<Oggetto collegato>]
  • Pulsante[], Pulsante[<Legenda>]
  • Unico[ <Lista>]
 Rimuove i duplicati da una lista.
  • Classi[ <Lista di dati>, <Inizio>, <Ampiezza delle classi> ]
  • Classi[ <Lista di dati>, <Numero delle classi> ]
 restituisce una lista di estremi delle classi. 
  • Frequenza[ <Lista dati grezzi> ]
  • Frequenza[ <Cumulativa>, <Lista dati grezzi>]
  • Frequenza[<Lista degli estremi delle classi>, <Lista dati grezzi>, ]
  • Frequenza[ <Cumulativa>,<Lista degli estremi delle classi>,<Lista dati grezzi>]
  • Frequenza[<Lista degli estremi delle classi>, <Lista dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
  • Frequenza[ <Booleano Cumulativa>, <Lista degli estremi delle classi>, <Lista dati grezzi>, <Usa Densità> , <Fattore di scala Densità> (facoltativo) ]
 restituisce una lista di frequenze
  • Regressione[ <Lista di punti>, <Funzione> ]
  • Intersezione[ <Funzione>, <Funzione> ]
  • ImpVisibileInVista[ <Oggetto>, <Vista Numero 1|2>, <Booleano> ]
  • ZoomAvanti[ <Min x>, <Min y>, <Max x>, <Max y> ]
  • Corner[ <Vista Grafica>, <Numero corner> ]
  • Radici[ <Funzione>, <x iniziale>, <x finale> ]
 calcola le radici della funzione nell'intervallo indicato.
  • CompletaQuadrato[ <Funzione quadratica> ]
 I seguenti comandi tracciano la funzione dei pdf/cdf delle rispettive distribuzioni (predefinito: pdf)
  • DistribuzioneT[ <Gradi di libertà>, x ]
  • DistribuzioneT[ <Gradi di libertà>, x, <Booleano Cumulativa>]
  • DistribuzioneF[ <Gradi di libertà numeratore>, <Gradi di libertà denominatore>, x ]
  • DistribuzioneF[ <Gradi di libertà numeratore>, <Gradi di libertà denominatore>, x, <Booleano Cumulativa> ]
  • Gamma[ <Alfa>, <Beta>, x ]
  • Gamma[ <Alfa>, <Beta>, x, <Booleano Cumulativa> ]
  • Cauchy[ <Mediana>, <Scala>, x ]
  • Cauchy[ <Mediana>, <Scala>, x, <Booleano Cumulativa> ]
  • ChiQuadro[ <Gradi di libertà>, x ]
  • ChiQuadro[ <Gradi di libertà>, x, <Booleano Cumulativa> ]
  • Esponenziale[ <Lambda>, x ]
  • Esponenziale[ <Lambda>, x, <Booleano Cumulativa> ]
  • Weibull[ <Shape>, <Scale>, x ]
  • Weibull[ <Shape>, <Scale>, x, <Booleano Cumulativa> ]
  • Normale[ <Media>, <Deviazione standard>, x ]
  • Normale[ <Media>, <Deviazione standard>, x, <Booleano Cumulativa>]
  • LogNormale[ <Media>, <Deviazione standard>, x ]
  • LogNormale[ <Media>, <Deviazione standard>, x, <Booleano Cumulativa>]
  • LogNormale[ <Media>, <Deviazione standard>, <Valore variabile> ]
  • Uniforme[ <Limite inferiore>, <Limite superiore>, x ]
  • Uniforme[ <Limite inferiore>, <Limite superiore>, x, <Booleano Cumulativa> ]
  • Uniforme[ <Limite inferiore>, <Limite superiore>, <Valore variabile> ]
  • Logistica[ <Media>, <Scala>, x ]
  • Logistica[ <Media>, <Scala>, x, <Booleano Cumulativa> ]
  • Logistica[ <Media>, <Scala>, <Valore variabile> ]
  • Triangolare[ <Limite inferiore>, <Limite superiore>, <Moda>, x ]
  • Triangolare[ <Limite inferiore>, <Limite superiore>, <Moda>, x, <Booleano Cumulativa> ]
  • Triangolare[ <Limite inferiore>, <Limite superiore>, <Moda>, <Valore variabile> ]
 I seguenti comandi tracciano un diagramma a barre dei pdf/cdf delle rispettive distribuzioni (predefinito: pdf)
  • Bernoulli[ <Probabilità>, <Booleano Cumulativa> ]
  • Pascal[ <Numero di successi>, <Probabilità di successo> ]
  • Pascal[ <Numero di successi>, <Probabilità di successo>, <Booleano Cumulativa> ]
  • Poisson[ <Media> ]
  • Poisson[ <Media>, <Booleano Cumulativa> ]
  • Binomiale[ <Numero di successi>, <Probabilità di successo> ]
  • Binomiale[ <Numero di successi>, <Probabilità di successo>, <Booleano Cumulativa> ]
  • IperGeometrica[ <Dimensione popolazione>, <Numero di successi>, <Dimensione campione> ]
  • IperGeometrica[ <Dimensione popolazione>, <Numero di successi>, <Dimensione campione>, <Booleano Cumulativa> ]
  • Zipf[ <Numero di elementi>, <Esponente> ]
  • Zipf[ <Numero di elementi>, <Esponente>, <Booleano Cumulativa> ]


Nuovi tasti di scelta rapida da tastiera e mouse

  • <Ctrl>H mostra / nasconde gli oggetti (non in MacOS)
  • <Ctrl><Maiusc>H mostra / nasconde le etichette (non in MacOS)
  • <Ctrl>G mostra / nasconde Oggetti
  • <Ctrl><Maiusc>G mostra / nasconde le etichette
  • <Ctrl>I inverte la selezione
  • <Tab> seleziona l'oggetto successivo (ordine alfabetico / del foglio di calcolo, ma non gli oggetti con deselezionata l'opzione "Consenti selezione")
  • <Maiusc><Tab> seleziona l'oggetto precedente (ordine alfabetico / del foglio di calcolo, ma non gli oggetti con deselezionata l'opzione "Consenti selezione")
  • <Ctrl><Tab> passa dalla Vista Grafica al Foglio di calcolo e viceversa
  • <Pag Su> aumenta il livello degli oggetti selezionati
  • <Pag Giù> diminuisce il livello degli oggetti selezionati
  • Le seguenti combinazioni di tasti servono (con Alt, Maiusc, Ctrl) per spostare la porzione visibile della Vista Grafica quando nessun oggetto è selezionato:
    • <Pag Su> sposta in alto la porzione visibile di una schermata
    • <Pag Giù> sposta in basso la porzione visibile di una schermata
    • sposta a sinistra la porzione visibile di una schermata
    • <Home> sposta a destra la porzione visibile di una schermata
    • Freccia sinistra sposta a sinistra la porzione visibile dell'1% di un schermata
    • Freccia destra sposta a destra la porzione visibile dell'1% di un schermata
    • Freccia su sposta in alto la porzione visibile dell'1% di un schermata
    • Freccia giù sposta in basso la porzione visibile dell'1% di un schermata
  • <Ctrl>M ristorna alla visualizzazione standard della Vista Grafica
  • <Ctrl><Maiusc>M Condividi
  • Pulsante Menu (sulla tastiera) apre il menu della Vista Grafica / Finestra di dialogo Proprietà dell'oggetto
  • Barra spazio modifica il valore della casella di controllo (se selezionata)
  • Barra spazio esegue uno script o più script (se selezionati) ad es. per un pulsante
  • <Ctrl><Maiusc>N seleziona la finestra successiva (o carica il file successivo nella cartella se un solo file è aperto)
  • <Ctrl><Alt><Maiusc>N seleziona l'ultima finestra
  • <Home> va all'inizio di una riga (nel Foglio di calcolo)
  • <Ctrl><Home> va alla cella A1 (nel Foglio di calcolo)
  • <Ctrl><Maiusc>K mostra/nasconde la Vista CAS
  • <Ctrl><Maiusc>L mostra/nasconde il Protocollo di costruzione
  • <Ctrl><Maiusc>1 mostra/nasconde la Vista Grafica
  • <Ctrl><Maiusc>2 mostra/nasconde la Vista Grafica 2
  • <Ctrl><Maiusc>3 Riservato (per la Vista 3D della prossima versione)
  • <Ctrl><Maiusc>Z riapplica l'ultima azione
  • <Ctrl>Freccia su (in un campo testo) apre la tabella dei simboli
  • Fare clic e trascinare il pulsante di mezzo (o la rotellina del mouse) per spostare la Vista o riscalare gli assi
  • <F1> Guida / Guida relativa al comando corrente
  • <Alt>i restituisce il nuovo simbolo per sqrt(-1) ί
  • <Alt>u ∞ (era <Alt>i)
  • <Alt>* restituisce ⊗ (prodotto vettoriale)
  • <Alt>- ora restituisce un meno in apice (non un simbolo di più o meno)
  • <Tab> scorre la lista di comandi simili (barra di inserimento)

Descrizione di tutti i Tasti_di_scelta_rapida

Nuovi parametri per le applet

  • allowStyleBar, predefinito false
  • useBrowserForJS, predefinito true

Descrizione di tutti i parametri delle applet di GeoGebra

Nuovi argomenti per la riga di comando

Quando si utilizzano argomenti nella riga di comando, verificare di avere allocato una quantità di memoria sufficiente, ad es::
java -Xms32m -Xmx512m -jar geogebra.jar --settingsfile=geogebra.properties

--settingsfile=<File>

Descrizione di tutti gli argomenti della riga di comando di GeoGebra

Nuovi comandi JavaScript

  • String getPNGBase64(double exportScale, boolean transparent, double DPI)
    eg var str = ggbApplet.getPNGBase64(1, true, 72);
  • boolean writePNGtoFile(String filename, double exportScale, boolean transparent, double DPI)
    solo per applet con firma
    ad es. var success = ggbApplet.writePNGtoFile("c:\\test.png", 1, false, 300);
  • boolean isIndependent(String objName) (verifica se l'oggetto è indipendente)
  • boolean isMoveable(String objName) (verifica se l'oggetto può essere mosso)
  • getBase64()
  • setBase64(String)

Descrizione di tutti i metodi JavaScript di GeoGebra

Formato dei file XML di GeoGebra

Il formato XML di GeoGebra è documentato in Riferimenti:XML

Licenza

È possibile copiare, distribuire e trasmettere GeoGebra per scopi non commerciali. Fare riferimento alla licenza di GeoGebra per ulteriori dettagli: http://www.geogebra.org/download/license.txt



  • GeoGebra
  • Help
  • Partners
  • Contact us
    • Feedback & Questions
    • This e-mail address is being protected from spambots. You need JavaScript enabled to view it.
    • +43 732 2468 6879
© 2014 International GeoGebra Institute