GeoGebra


Manual:Construction Protocol

Jump to: navigation, search
Accessories dictionary.png
This page is part of the official manual for print and pdf. For structural reasons normal users can't edit this page. If you found any errors on this page please contact us. Go to the version which can be edited by users.


You can access the interactive Construction Protocol by selecting item Construction Protocol - Show from the View menu. The Construction Protocol is a table that shows all construction steps, allowing you to redo a construction step by step using the Navigation Bar at the bottom of the Construction Protocol dialog.

Navigating and Modifying the Construction Protocol

You may use the keyboard to navigate in the Construction Protocol:

  • Use the ↑ up arrow of your keyboard to go to the previous construction step.
  • Use the ↓ down arrow of you keyboard to go to the next construction step.
  • Use the Home key to go to the beginning of the Construction Protocol.
  • Use the End key to go to the end of the Construction Protocol.
  • Use the Delete key in order to delete the selected construction step.
Note: This may also affect other objects that depend on the selected object/construction step.

You may also use the mouse in order to navigate in the Construction Protocol:

  • Double click a row to select a construction step.
  • Double click the header of any column to go to the beginning of the Construction Protocol.
  • Drag and drop a row to move a construction step to another position in the Construction Protocol.
Note: This is not always possible due to the dependencies between different objects.
  • Right click a row to open the Context Menu for the object of this construction step.
Note: You can insert construction steps at any position. Select the construction step below you would like to insert a new construction step. Leave the Construction Protocol window open while you create a new object. This new construction step is immediately inserted into the selected position of the Construction Protocol.

Using the column Breakpoint in the View menu of the Construction Protocol window, you can define certain construction steps as Breakpoints. This allows you to group several objects together. When navigating through your construction using the Navigation Bar, groups of objects are shown at the same time.

Note: You may switch the different columns of the Construction Protocol on and off by using the Styling Bar of the Construction Protocol window.

Exporting the Construction Protocol as a Webpage

GeoGebra allows you to export the Construction Protocol as a webpage. First, you need to open the Construction Protocol using the View menu. Then open the File menu of the appearing Construction Protocol window and select item Export as Webpage.

In the export window of the Construction Protocol you can enter Title, Author, and a Date for the construction and choose whether or not you want to include a picture of the Graphics View and the Algebra View. In addition, you can also choose to export a Colorful Construction Protocol. This means that objects in the Construction Protocol will match the color of the corresponding objects in the construction.

Note: The exported HTML file can be viewed with any Internet browser (e. g. Firefox, Internet Explorer) and edited with many text processing systems (e. g. OpenOffice Writer).

Powered by MediaWiki a Creative Commons Attribution-ShareAlike 2.5 License