Custom Tools

From GeoGebra Manual
Jump to: navigation, search


GeoGebra allows you to create your own construction tools based on an existing construction. Once created, your custom tool can be used both with a pointing device and as a command in the Input Bar. All tools are automatically saved in your GeoGebra file.

Note: Outputs of the tool are not movable (i.e. you can't drag them with the mouse), even if they are defined as Point[<Path>]. In case you need movable output, you can define a list of commands and use it with Execute Command.

Creating custom tools

To create a custom tool, use the option Menu-tools-new.svg Create new tool from Menu-tools.svg Tools Menu.

Saving custom tools

When you save the construction as GGB file, all custom tools are stored in it. To save the tools in separate file(s) use the Tool Manager Dialog (option Menu-tools.svg Manage Tools from Menu-tools.svg Tools Menu).

Note: Costum tools will be saved as GGT file to distinguish them from normal GeoGebra files (GGB).

Accessing custom tools

If you open a new GeoGebra interface using item Menu-file-new.svg New from the Menu-file.svg File Menu, after you created a custom tool, it will still be part of the GeoGebra toolbar. However, if you open a new GeoGebra window (item Menu New.png New Window from the Menu-file.svg File Menu), or open GeoGebra on another day, your custom tools won’t be part of the toolbar any more.

There are different ways of making sure that your user defined tools are displayed in the toolbar of a new GeoGebra window:

  • After creating a new user defined tool you can save your settings using item Menu-file-save.svg Save Settings from the Menu-options.svg Options Menu. From now on, your customized tool will be part of the GeoGebra toolbar.
Note: You can remove the custom tool from the toolbar after opening item Menu-tools-customize.svg Customize Toolbar from the Menu-tools.svg Tools Menu. Then, select your custom tool from the list of tools on the left hand side of the appearing dialog window and click the Remove button (GeoGebra Desktop Version) or drag and drop it to the right hand side (GeoGebra Web and Tablet Apps Version). Don’t forget to save your settings after removing the custom tool.

Importing custom tools

  • After saving your custom tool on your computer (as a GGT file), you can import it into a new GeoGebra window at any time. Just select item Menu-file-open.svg Open from the Menu-file.svg File Menu and open the file of your custom tool.
Note:
  • Opening a GeoGebra tool file (GGT) in GeoGebra doesn’t affect your current construction. It only makes this tool part of the current GeoGebra toolbar.
  • You can also load GGT file by dragging it from file manager and dropping into GeoGebra window.
  • GeoGebra
  • Help
  • Partners
  • Contact us
    • Feedback & Questions
    • This email address is being protected from spambots. You need JavaScript enabled to view it.
    • +43 677 6137 2693
© 2017 International GeoGebra Institute